From 33f20b64e15104c46c46f801b7d148c500046107 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sun, 14 Mar 2010 18:36:27 -0500
Subject: lighttpd: sync testing to core bugfix

---
 abs/core/lighttpd/PKGBUILD             | 27 +++++++++++++++++----------
 abs/core/lighttpd/__changelog          |  6 ++++++
 abs/core/lighttpd/_changelog           |  2 --
 abs/core/lighttpd/lighttpd.conf        |  2 +-
 abs/core/lighttpd/lighttpd.install     |  1 +
 abs/core/lighttpd/openssl-0.9.8m.patch | 11 +++++++++++
 6 files changed, 36 insertions(+), 13 deletions(-)
 create mode 100644 abs/core/lighttpd/__changelog
 delete mode 100644 abs/core/lighttpd/_changelog
 mode change 100644 => 100755 abs/core/lighttpd/lighttpd.install
 create mode 100644 abs/core/lighttpd/openssl-0.9.8m.patch

diff --git a/abs/core/lighttpd/PKGBUILD b/abs/core/lighttpd/PKGBUILD
index d0811ae..cec41d4 100644
--- a/abs/core/lighttpd/PKGBUILD
+++ b/abs/core/lighttpd/PKGBUILD
@@ -2,8 +2,8 @@
 # Maintainer: Pierre Schmitz <pierre@archlinux.de>
 
 pkgname=lighttpd
-pkgver=1.4.20
-pkgrel=35
+pkgver=1.4.26
+pkgrel=7
 pkgdesc='a secure, fast, compliant and very flexible web-server'
 license=('custom')
 arch=('i686' 'x86_64')
@@ -18,16 +18,16 @@ optdepends=('libxml2: mod_webdav' \
             )
 backup=('etc/lighttpd/lighttpd.conf' 'etc/logrotate.d/lighttpd' 'etc/lighttpd/auth-inc.conf')
 options=('!libtool' 'emptydirs')
-source=("http://www.lighttpd.net/download/lighttpd-${pkgver}.tar.bz2" \
-        'lighttpd.rc.d' 'lighttpd.logrotate.d' 'lighttpd.conf' auth-inc.conf)
-
-md5sums=('ed6ee0bb714f393219a32768d86984d8'
-         'bd690eee0d9e51857448770a151023b0'
-         '857e174643fd7761a2f0d8431a679f6c'
-	 'db6b8b8f144125cf249e97c4b13f3f18')
-
+source=("http://download.lighttpd.net/lighttpd/releases-1.4.x/lighttpd-${pkgver}.tar.bz2" \
+        'lighttpd.rc.d' 'lighttpd.logrotate.d' 'lighttpd.conf' 'auth-inc.conf' \
+        'openssl-0.9.8m.patch')
+install='lighttpd.install'
 build() {
 	cd $srcdir/$pkgname-$pkgver
+
+        # fixed in 1.4.27
+        patch -p2 -i ${srcdir}/openssl-0.9.8m.patch || return 1
+
 	./configure --prefix=/usr \
 		--libexecdir=/usr/lib/lighttpd/modules \
 		--sysconfdir=/etc/lighttpd \
@@ -64,7 +64,14 @@ build() {
 	    -e 's|#server.groupname           = "wwwrun"|server.groupname           = "http"|' \
 	    -e 's|#server.pid-file            = "/var/run/lighttpd.pid"|server.pid-file            = "/var/run/lighttpd/lighttpd.pid"|' \
 	    -e 's|/usr/local/bin/php-cgi|/usr/bin/php-cgi|' \
+            -e 's|"^/mythweb|"^/{1,2}mythweb|' \
 	    -i ${pkgdir}/etc/lighttpd/lighttpd.conf || return 1
 
 	install -D -m644 COPYING $pkgdir/usr/share/licenses/$pkgname/COPYING
 }
+md5sums=('a682c8efce47a2f4263a247ba0813c9b'
+         'bd690eee0d9e51857448770a151023b0'
+         '857e174643fd7761a2f0d8431a679f6c'
+         'fe078f9b8ee701ed21278789cad90acf'
+         'c6e361131000ceec085f40b310ef4a2c'
+         '84c884b8dadd724afe2bc6529e9d4485')
diff --git a/abs/core/lighttpd/__changelog b/abs/core/lighttpd/__changelog
new file mode 100644
index 0000000..a96d942
--- /dev/null
+++ b/abs/core/lighttpd/__changelog
@@ -0,0 +1,6 @@
+changed docroot to /data/srv/
+modified auth to require valid user (include auth-inc.conf)
+
+# by mihanson:
+upgraded to 1.4.26 to address http://linhes.org/flyspray/index.php?do=details&task_id=624
+Added -e 's|"^/mythweb|"^/{1,2}mythweb|' \ to the sed command to work around lighttpd no longer honoring // in a url and/or to work around mythweb producing url's with a // for streaming and downloading.
diff --git a/abs/core/lighttpd/_changelog b/abs/core/lighttpd/_changelog
deleted file mode 100644
index 439f42d..0000000
--- a/abs/core/lighttpd/_changelog
+++ /dev/null
@@ -1,2 +0,0 @@
-changed docroot to /data/srv/
-modified auth to require valid user (include auth-inc.conf)
diff --git a/abs/core/lighttpd/lighttpd.conf b/abs/core/lighttpd/lighttpd.conf
index 7305133..0c55f52 100644
--- a/abs/core/lighttpd/lighttpd.conf
+++ b/abs/core/lighttpd/lighttpd.conf
@@ -238,7 +238,7 @@ cgi.assign                 = ( ".pl"  => "/usr/bin/perl",
                                ".cgi" => "/bin/bash" )
 
    url.rewrite-once = (
-        "^/mythweb/(css|data|images|js|themes|skins|[a-z_]+\.(php|pl)).*" => "$0",
+       "^/mythweb/(css|data|images|js|themes|skins|[a-z_]+\.(php|pl)).*" => "$0",
        "^/mythweb/(pl(/.*)?)$" => "/mythweb/mythweb.pl/$1",
        "^/mythweb/(.+)$"       => "/mythweb/mythweb.php/$1",
        "^/mythweb/(.*)$"       => "/mythweb/mythweb.php"
diff --git a/abs/core/lighttpd/lighttpd.install b/abs/core/lighttpd/lighttpd.install
old mode 100644
new mode 100755
index bf4c132..0e32a66
--- a/abs/core/lighttpd/lighttpd.install
+++ b/abs/core/lighttpd/lighttpd.install
@@ -2,5 +2,6 @@ pre_upgrade() {
     mv /etc/lighttpd/lighttpd.conf  /etc/lighttpd/lighttpd.conf.old
 }
 post_upgrade() {
+    sed -i 's|"^/mythweb|"/{1,2}mythweb|g' /etc/lighttpd/lighttpd.conf
     touch /etc/lighttpd/lighttpd.user
 }
diff --git a/abs/core/lighttpd/openssl-0.9.8m.patch b/abs/core/lighttpd/openssl-0.9.8m.patch
new file mode 100644
index 0000000..321e10b
--- /dev/null
+++ b/abs/core/lighttpd/openssl-0.9.8m.patch
@@ -0,0 +1,11 @@
+--- src/lighttpd-1.4.26/src/network.c.orig	2010-03-12 01:19:34.000000000 +0000
++++ src/lighttpd-1.4.26/src/network.c	2010-03-12 01:20:45.000000000 +0000
+@@ -525,7 +525,7 @@
+ 
+ 		if (!s->ssl_use_sslv2) {
+ 			/* disable SSLv2 */
+-			if (SSL_OP_NO_SSLv2 != SSL_CTX_set_options(s->ssl_ctx, SSL_OP_NO_SSLv2)) {
++                        if (!(SSL_OP_NO_SSLv2 & SSL_CTX_set_options(s->ssl_ctx, SSL_OP_NO_SSLv2))) {
+ 				log_error_write(srv, __FILE__, __LINE__, "ss", "SSL:",
+ 						ERR_error_string(ERR_get_error(), NULL));
+ 				return -1;
-- 
cgit v0.12