From 9cdb8144f8d6add081bf9aeadb4ec16ca9ba297a Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Mon, 18 Jun 2018 20:03:13 +0000
Subject: libglvnd: move to core

---
 abs/core/libglvnd/LICENSE      | 26 ++++++++++++++++++++++++++
 abs/core/libglvnd/PKGBUILD     | 33 +++++++++++++++++++++++++++++++++
 abs/core/libglvnd/__changelog  |  1 +
 abs/extra/libglvnd/LICENSE     | 26 --------------------------
 abs/extra/libglvnd/PKGBUILD    | 33 ---------------------------------
 abs/extra/libglvnd/__changelog |  1 -
 6 files changed, 60 insertions(+), 60 deletions(-)
 create mode 100644 abs/core/libglvnd/LICENSE
 create mode 100644 abs/core/libglvnd/PKGBUILD
 create mode 100644 abs/core/libglvnd/__changelog
 delete mode 100644 abs/extra/libglvnd/LICENSE
 delete mode 100644 abs/extra/libglvnd/PKGBUILD
 delete mode 100644 abs/extra/libglvnd/__changelog

diff --git a/abs/core/libglvnd/LICENSE b/abs/core/libglvnd/LICENSE
new file mode 100644
index 0000000..57bc4f4
--- /dev/null
+++ b/abs/core/libglvnd/LICENSE
@@ -0,0 +1,26 @@
+Copyright (c) 2013, NVIDIA CORPORATION.
+
+Permission is hereby granted, free of charge, to any person obtaining a
+copy of this software and/or associated documentation files (the
+"Materials"), to deal in the Materials without restriction, including
+without limitation the rights to use, copy, modify, merge, publish,
+distribute, sublicense, and/or sell copies of the Materials, and to
+permit persons to whom the Materials are furnished to do so, subject to
+the following conditions:
+
+The above copyright notice and this permission notice shall be included
+unaltered in all copies or substantial portions of the Materials.
+Any additions, deletions, or changes to the original source files
+must be clearly indicated in accompanying documentation.
+
+If only executable code is distributed, then the accompanying
+documentation must state that "this software is based in part on the
+work of the Khronos Group."
+
+THE MATERIALS ARE PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
+IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
+CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT,
+TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
+MATERIALS OR THE USE OR OTHER DEALINGS IN THE MATERIALS.
\ No newline at end of file
diff --git a/abs/core/libglvnd/PKGBUILD b/abs/core/libglvnd/PKGBUILD
new file mode 100644
index 0000000..e589b42
--- /dev/null
+++ b/abs/core/libglvnd/PKGBUILD
@@ -0,0 +1,33 @@
+# $Id: PKGBUILD 249779 2015-10-27 00:47:25Z eric $
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+
+pkgname=libglvnd
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="The GL Vendor-Neutral Dispatch library"
+arch=('x86_64')
+url="https://github.com/NVIDIA/libglvnd"
+license=('custom:BSD-like')
+makedepends=('libxext' 'libx11' 'glproto' 'python2')
+provides=('libgl' 'libegl' 'libgles')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/NVIDIA/libglvnd/archive/v$pkgver.tar.gz"
+        LICENSE)
+sha512sums=('c6040b0a508a6b74d7113f8e375fcaf93ec6f2875504953f30e2882e58e22f954bd4027a7d9ab8ac41abef266039e5834fdaf4ce2a69d5d98acf3bbdd54f04b6'
+            'bf0f4a7e04220a407400f89226ecc1f798cc43035f2538cc8860e5088e1f84140baf0d4b0b28f66e4b802d4d6925769a1297c24e1ba39c1c093902b2931781a5')
+
+build() {
+  cd $pkgname-$pkgver
+  ./autogen.sh
+  ./configure --prefix=/usr
+  make
+}
+
+package() {
+  # libglvnd needs mesa for indirect rendering
+  depends=('libxext' 'mesa' 'opengl-driver')
+
+  cd $pkgname-$pkgver
+  make DESTDIR="$pkgdir" install
+
+  install -Dm644 ../LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
diff --git a/abs/core/libglvnd/__changelog b/abs/core/libglvnd/__changelog
new file mode 100644
index 0000000..99dab7b
--- /dev/null
+++ b/abs/core/libglvnd/__changelog
@@ -0,0 +1 @@
+PKGBUILD: change python dep to python2
diff --git a/abs/extra/libglvnd/LICENSE b/abs/extra/libglvnd/LICENSE
deleted file mode 100644
index 57bc4f4..0000000
--- a/abs/extra/libglvnd/LICENSE
+++ /dev/null
@@ -1,26 +0,0 @@
-Copyright (c) 2013, NVIDIA CORPORATION.
-
-Permission is hereby granted, free of charge, to any person obtaining a
-copy of this software and/or associated documentation files (the
-"Materials"), to deal in the Materials without restriction, including
-without limitation the rights to use, copy, modify, merge, publish,
-distribute, sublicense, and/or sell copies of the Materials, and to
-permit persons to whom the Materials are furnished to do so, subject to
-the following conditions:
-
-The above copyright notice and this permission notice shall be included
-unaltered in all copies or substantial portions of the Materials.
-Any additions, deletions, or changes to the original source files
-must be clearly indicated in accompanying documentation.
-
-If only executable code is distributed, then the accompanying
-documentation must state that "this software is based in part on the
-work of the Khronos Group."
-
-THE MATERIALS ARE PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
-EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
-MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
-IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
-CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT,
-TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
-MATERIALS OR THE USE OR OTHER DEALINGS IN THE MATERIALS.
\ No newline at end of file
diff --git a/abs/extra/libglvnd/PKGBUILD b/abs/extra/libglvnd/PKGBUILD
deleted file mode 100644
index e589b42..0000000
--- a/abs/extra/libglvnd/PKGBUILD
+++ /dev/null
@@ -1,33 +0,0 @@
-# $Id: PKGBUILD 249779 2015-10-27 00:47:25Z eric $
-# Maintainer: Felix Yan <felixonmars@archlinux.org>
-
-pkgname=libglvnd
-pkgver=1.0.0
-pkgrel=1
-pkgdesc="The GL Vendor-Neutral Dispatch library"
-arch=('x86_64')
-url="https://github.com/NVIDIA/libglvnd"
-license=('custom:BSD-like')
-makedepends=('libxext' 'libx11' 'glproto' 'python2')
-provides=('libgl' 'libegl' 'libgles')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/NVIDIA/libglvnd/archive/v$pkgver.tar.gz"
-        LICENSE)
-sha512sums=('c6040b0a508a6b74d7113f8e375fcaf93ec6f2875504953f30e2882e58e22f954bd4027a7d9ab8ac41abef266039e5834fdaf4ce2a69d5d98acf3bbdd54f04b6'
-            'bf0f4a7e04220a407400f89226ecc1f798cc43035f2538cc8860e5088e1f84140baf0d4b0b28f66e4b802d4d6925769a1297c24e1ba39c1c093902b2931781a5')
-
-build() {
-  cd $pkgname-$pkgver
-  ./autogen.sh
-  ./configure --prefix=/usr
-  make
-}
-
-package() {
-  # libglvnd needs mesa for indirect rendering
-  depends=('libxext' 'mesa' 'opengl-driver')
-
-  cd $pkgname-$pkgver
-  make DESTDIR="$pkgdir" install
-
-  install -Dm644 ../LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
-}
diff --git a/abs/extra/libglvnd/__changelog b/abs/extra/libglvnd/__changelog
deleted file mode 100644
index 99dab7b..0000000
--- a/abs/extra/libglvnd/__changelog
+++ /dev/null
@@ -1 +0,0 @@
-PKGBUILD: change python dep to python2
-- 
cgit v0.12