From 616f8b211ed7e269a46930e7bfe04a69b369aed0 Mon Sep 17 00:00:00 2001
From: Cecil <knoppmyth@gmail.com>
Date: Tue, 20 Dec 2011 22:01:32 -0800
Subject: Removed unfinished transcoder and ensured symlinks get removed once
 package is removed.

---
 abs/extra/mythexport/PKGBUILD           |   5 +-
 abs/extra/mythexport/linhes2.diff       | 563 ++++++++++++++++++++++++++++++++
 abs/extra/mythexport/mythexport.install |   3 +
 3 files changed, 569 insertions(+), 2 deletions(-)
 create mode 100644 abs/extra/mythexport/linhes2.diff

diff --git a/abs/extra/mythexport/PKGBUILD b/abs/extra/mythexport/PKGBUILD
index 73a18cd..8756857 100644
--- a/abs/extra/mythexport/PKGBUILD
+++ b/abs/extra/mythexport/PKGBUILD
@@ -3,12 +3,13 @@
 
 pkgname=mythexport
 pkgver=2.2.3
-pkgrel=6
+pkgrel=7
 pkgdesc="Export MythTV recording to portable media players"
 arch=('i686' 'x86_64')
 license=('GPL3')
 depends=('atomicparsley' 'perl-config-simple' 'perl-net-upnp' 'perl-xml-rss'
-         'perl-proc-daemon' 'perl-proc-pid-file' 'perl-html-template' 'handbrake-cli')
+         'perl-proc-daemon' 'perl-proc-pid-file' 'perl-html-template' 'handbrake-cli'
+	 'tablet-encode' 'mencoder')
 optdepends=('lighttpd: For web based interaction')
 url="http://www.ubuntuupdates.org/mythexport"
 source=(https://launchpad.net/ubuntu/precise/+source/${pkgname}/${pkgver}-0ubuntu2/+files/${pkgname}_${pkgver}.orig.tar.gz
diff --git a/abs/extra/mythexport/linhes2.diff b/abs/extra/mythexport/linhes2.diff
new file mode 100644
index 0000000..8a1cee6
--- /dev/null
+++ b/abs/extra/mythexport/linhes2.diff
@@ -0,0 +1,563 @@
+diff -ruaN mythexport-2.2.3.orig//etc/apache2/sites-available/mythexport.conf mythexport-2.2.3/etc/apache2/sites-available/mythexport.conf
+--- mythexport-2.2.3.orig//etc/apache2/sites-available/mythexport.conf	2011-04-26 06:04:09.000000000 +0000
++++ mythexport-2.2.3/etc/apache2/sites-available/mythexport.conf	1970-01-01 00:00:00.000000000 +0000
+@@ -1,19 +0,0 @@
+-<Directory "/var/www/mythexport">
+-        AllowOverride None
+-        Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
+-        Order allow,deny
+-        Allow from all
+-        <Files *.cgi>
+-            SetHandler cgi-script
+-            Options +ExecCGI
+-        </Files>
+-		
+-        DirectoryIndex file.cgi
+-        # Turned off as we are now hosting up more than just a RSS feed
+-        #RewriteEngine on
+-        #RewriteRule ^([A-Za-z0-9-_]+)/?$ mythexportRSS.cgi?podcastName=$1 [L]
+-</Directory>
+-<Directory "/var/www/.mythtv">
+-        AllowOverride None
+-        Deny from all
+-</Directory>
+diff -ruaN mythexport-2.2.3.orig//etc/mythtv/mythexport/mythexport.cfg mythexport-2.2.3/etc/mythtv/mythexport/mythexport.cfg
+--- mythexport-2.2.3.orig//etc/mythtv/mythexport/mythexport.cfg	1970-01-01 00:00:00.000000000 +0000
++++ mythexport-2.2.3/etc/mythtv/mythexport/mythexport.cfg	2011-12-21 05:54:19.000000000 +0000
+@@ -0,0 +1,2 @@
++dir=/myth/mythexport
++
+diff -ruaN mythexport-2.2.3.orig//usr/share/mythexport/configs/Android.pm mythexport-2.2.3/usr/share/mythexport/configs/Android.pm
+--- mythexport-2.2.3.orig//usr/share/mythexport/configs/Android.pm	1970-01-01 00:00:00.000000000 +0000
++++ mythexport-2.2.3/usr/share/mythexport/configs/Android.pm	2011-12-21 05:54:19.000000000 +0000
+@@ -0,0 +1,28 @@
++#!/usr/bin/perl 
++
++package Android;
++
++use ExportBase;
++
++our @ISA = qw(ExportBase);
++
++my $description = "Handbrake MPEG4 output for Android devices.";
++my $devices = "Android";
++my $notes = "";
++my $version = "1.0";
++
++sub new{
++    my $class = shift;
++    my $self = $class->SUPER::new(shift, shift, $description, $devices, $notes, $version);
++    bless $self, $class;
++    return $self;
++}
++
++sub export{
++    my( $self ) = @_;
++
++    system("HandBrakeCLI -i \'$self->{_inputFile}\' -o '$self->{_outputFile}$self->{_extension}\' -f mp4 -w 480 -l 320 --deinterlace=\"slow\" -e x264 -x cabac=0:deblock=1,0:analyse=0x1,0x111:bitrate=416:psy_rd=1.0,0.0:chroma_me=1:chroma_qp_offset=-2:threads=3:nr=0:keyint=250:keyint_min=25:scenecut=40:bitrate=416:ratetol=1.0:qcomp=0.60:qpmin=10:qpmax=51:qpstep=4:cplxblur=20.0:qblur=0.5 -a 1 -E faac -B 96 -R 44.1 -6 stereo -D 1 -v -2 -T");
++
++}
++
++1;
+diff -ruaN mythexport-2.2.3.orig//usr/share/mythexport/configs/AppleTV.pm mythexport-2.2.3/usr/share/mythexport/configs/AppleTV.pm
+--- mythexport-2.2.3.orig//usr/share/mythexport/configs/AppleTV.pm	1970-01-01 00:00:00.000000000 +0000
++++ mythexport-2.2.3/usr/share/mythexport/configs/AppleTV.pm	2011-12-21 05:54:19.000000000 +0000
+@@ -0,0 +1,28 @@
++#!/usr/bin/perl 
++
++package AppleTV;
++
++use ExportBase;
++
++our @ISA = qw(ExportBase);
++
++my $description = "HandBrake's settings for the AppleTV and 2009's iPhone and iPod Touch lineup. Provides a good balance between quality and file size, and pushes the devices to their limits. Includes Dolby Digital 5.1 AC3 sound for the AppleTV.";
++my $devices = "AppleTV";
++my $notes = "";
++my $version = "1.0";
++
++sub new{
++    my $class = shift;
++    my $self = $class->SUPER::new(shift, shift, $description, $devices, $notes, $version);
++    bless $self, $class;
++    return $self;
++}
++
++sub export{
++    my( $self ) = @_;
++
++    system("HandBrakeCLI -i \'$self->{_inputFile}\' -o \'$self->{_outputFile}$self->{_extension}\' --preset=\"AppleTV\"");
++
++}
++
++1;
+diff -ruaN mythexport-2.2.3.orig//usr/share/mythexport/configs/AppleTV2.pm mythexport-2.2.3/usr/share/mythexport/configs/AppleTV2.pm
+--- mythexport-2.2.3.orig//usr/share/mythexport/configs/AppleTV2.pm	1970-01-01 00:00:00.000000000 +0000
++++ mythexport-2.2.3/usr/share/mythexport/configs/AppleTV2.pm	2011-12-21 05:54:19.000000000 +0000
+@@ -0,0 +1,28 @@
++#!/usr/bin/perl 
++
++package AppleTV2;
++
++use ExportBase;
++
++our @ISA = qw(ExportBase);
++
++my $description = "HandBrake's preset for the Apple TV (2nd gen) is optimized for viewing on its 1280x720 display.";
++my $devices = "AppleTV2";
++my $notes = "";
++my $version = "1.0";
++
++sub new{
++    my $class = shift;
++    my $self = $class->SUPER::new(shift, shift, $description, $devices, $notes, $version);
++    bless $self, $class;
++    return $self;
++}
++
++sub export{
++    my( $self ) = @_;
++
++    system("HandBrakeCLI -i \'$self->{_inputFile}\' -o \'$self->{_outputFile}$self->{_extension}\' --preset=\"AppleTV 2\"");
++
++}
++
++1;
+diff -ruaN mythexport-2.2.3.orig//usr/share/mythexport/configs/Classic.pm mythexport-2.2.3/usr/share/mythexport/configs/Classic.pm
+--- mythexport-2.2.3.orig//usr/share/mythexport/configs/Classic.pm	1970-01-01 00:00:00.000000000 +0000
++++ mythexport-2.2.3/usr/share/mythexport/configs/Classic.pm	2011-12-21 05:54:19.000000000 +0000
+@@ -0,0 +1,28 @@
++#!/usr/bin/perl 
++
++package Classic;
++
++use ExportBase;
++
++our @ISA = qw(ExportBase);
++
++my $description = "HandBrake's traditional, faster, lower-quality settings.";
++my $devices = "";
++my $notes = "";
++my $version = "1.0";
++
++sub new{
++    my $class = shift;
++    my $self = $class->SUPER::new(shift, shift, $description, $devices, $notes, $version);
++    bless $self, $class;
++    return $self;
++}
++
++sub export{
++    my( $self ) = @_;
++
++    system("HandBrakeCLI -i \'$self->{_inputFile}\' -o \'$self->{_outputFile}$self->{_extension}\' --preset=\"Classic\"");
++
++}
++
++1;
+diff -ruaN mythexport-2.2.3.orig//usr/share/mythexport/configs/HighProfile.pm mythexport-2.2.3/usr/share/mythexport/configs/HighProfile.pm
+--- mythexport-2.2.3.orig//usr/share/mythexport/configs/HighProfile.pm	1970-01-01 00:00:00.000000000 +0000
++++ mythexport-2.2.3/usr/share/mythexport/configs/HighProfile.pm	2011-12-21 05:54:19.000000000 +0000
+@@ -0,0 +1,28 @@
++#!/usr/bin/perl 
++
++package HighProfile;
++
++use ExportBase;
++
++our @ISA = qw(ExportBase);
++
++my $description = "HandBrake's general-purpose preset for High Profile H.264 video, with all the bells and whistles.";
++my $devices = "";
++my $notes = "";
++my $version = "1.0";
++
++sub new{
++    my $class = shift;
++    my $self = $class->SUPER::new(shift, shift, $description, $devices, $notes, $version);
++    bless $self, $class;
++    return $self;
++}
++
++sub export{
++    my( $self ) = @_;
++
++    system("HandBrakeCLI -i \'$self->{_inputFile}\' -o \'$self->{_outputFile}$self->{_extension}\' --preset=\"High Profile\"");
++
++}
++
++1;
+diff -ruaN mythexport-2.2.3.orig//usr/share/mythexport/configs/NIT.pm mythexport-2.2.3/usr/share/mythexport/configs/NIT.pm
+--- mythexport-2.2.3.orig//usr/share/mythexport/configs/NIT.pm	1970-01-01 00:00:00.000000000 +0000
++++ mythexport-2.2.3/usr/share/mythexport/configs/NIT.pm	2011-12-21 05:54:19.000000000 +0000
+@@ -0,0 +1,28 @@
++#!/usr/bin/perl 
++
++package NIT;
++
++use ExportBase;
++
++our @ISA = qw(ExportBase);
++
++my $description = "High Quality export for Nokia Internet Tablets (used BeyondPod).";
++my $devices = "N770, N800 and N900";
++my $notes = "Tested fine on Andriod phones and tablets.";
++my $version = "1.0";
++
++sub new{
++    my $class = shift;
++    my $self = $class->SUPER::new(shift, shift, $description, $devices, $notes, $version);
++    bless $self, $class;
++    return $self;
++}
++
++sub export{
++    my( $self ) = @_;
++
++    system("/usr/bin/tablet-encode -q -p mplayer \'$self->{_inputFile}\' \'$self->{_outputFile}$self->{_extension}\'");
++
++}
++
++1;
+diff -ruaN mythexport-2.2.3.orig//usr/share/mythexport/configs/NIT900.pm mythexport-2.2.3/usr/share/mythexport/configs/NIT900.pm
+--- mythexport-2.2.3.orig//usr/share/mythexport/configs/NIT900.pm	1970-01-01 00:00:00.000000000 +0000
++++ mythexport-2.2.3/usr/share/mythexport/configs/NIT900.pm	2011-12-21 05:54:19.000000000 +0000
+@@ -0,0 +1,28 @@
++#!/usr/bin/perl 
++
++package NIT900;
++
++use ExportBase;
++
++our @ISA = qw(ExportBase);
++
++my $description = "High Quality export for N900.";
++my $devices = "N900";
++my $notes = "Tested fine on Andriod phones and tablets (used BeyondPod).";
++my $version = "1.0";
++
++sub new{
++    my $class = shift;
++    my $self = $class->SUPER::new(shift, shift, $description, $devices, $notes, $version);
++    bless $self, $class;
++    return $self;
++}
++
++sub export{
++    my( $self ) = @_;
++
++    system("/usr/bin/tablet-encode -q -p n900 \'$self->{_inputFile}\' \'$self->{_outputFile}$self->{_extension}\'");
++
++}
++
++1;
+diff -ruaN mythexport-2.2.3.orig//usr/share/mythexport/configs/Normal.pm mythexport-2.2.3/usr/share/mythexport/configs/Normal.pm
+--- mythexport-2.2.3.orig//usr/share/mythexport/configs/Normal.pm	1970-01-01 00:00:00.000000000 +0000
++++ mythexport-2.2.3/usr/share/mythexport/configs/Normal.pm	2011-12-21 05:54:19.000000000 +0000
+@@ -0,0 +1,28 @@
++#!/usr/bin/perl 
++
++package Normal;
++
++use ExportBase;
++
++our @ISA = qw(ExportBase);
++
++my $description = "HandBrake's normal, default settings.";
++my $devices = "";
++my $notes = "";
++my $version = "1.0";
++
++sub new{
++    my $class = shift;
++    my $self = $class->SUPER::new(shift, shift, $description, $devices, $notes, $version);
++    bless $self, $class;
++    return $self;
++}
++
++sub export{
++    my( $self ) = @_;
++
++    system("HandBrakeCLI -i \'$self->{_inputFile}\' -o \'$self->{_outputFile}$self->{_extension}\' --preset=\"Normal\"");
++
++}
++
++1;
+diff -ruaN mythexport-2.2.3.orig//usr/share/mythexport/configs/PortableH264HighRes.pm mythexport-2.2.3/usr/share/mythexport/configs/PortableH264HighRes.pm
+--- mythexport-2.2.3.orig//usr/share/mythexport/configs/PortableH264HighRes.pm	2011-04-26 06:04:09.000000000 +0000
++++ mythexport-2.2.3/usr/share/mythexport/configs/PortableH264HighRes.pm	1970-01-01 00:00:00.000000000 +0000
+@@ -1,28 +0,0 @@
+-#!/usr/bin/perl 
+-
+-package PortableH264HighRes;
+-
+-use ExportBase;
+-
+-our @ISA = qw(ExportBase);
+-
+-my $description = "High Resolution (800x400) Portable H264 Settings.";
+-my $devices = "High Resolution Android Devices (example Droid, Evo, N1), iPod Touch, iPhone, iPad";
+-my $notes = "Requires AAC, <a href=\"https://help.ubuntu.com/community/Medibuntu\">activate Medibuntu</a>";
+-my $version = "1.0";
+-
+-sub new{
+-    my $class = shift;
+-    my $self = $class->SUPER::new(shift, shift, $description, $devices, $notes, $version);
+-    bless $self, $class;
+-    return $self;
+-}
+-
+-sub export{
+-    my( $self ) = @_;
+-
+-    system("ffmpeg -i \'$self->{_inputFile}\' -y -pass 1 -an -vcodec libx264 -vpre slowfirstpass -vpre ipod640 -b 1500kb -bt 1000kb -threads 0 -s 800x480 -aspect 16:9 -f ipod \'$self->{_outputFile}$self->{_extension}\' && ffmpeg -i \'$self->{_inputFile}\' -y -pass 2 -vcodec libx264 -vpre hq -vpre ipod640 -b 1500kb -bt 1000kb -threads 0 -s 800x480 -acodec libfaac -ab 192kb -ac 2 -aspect 16:9 -f ipod \'$self->{_outputFile}$self->{_extension}\'");
+-
+-}
+-
+-1;
+diff -ruaN mythexport-2.2.3.orig//usr/share/mythexport/configs/PortableH264LowRes.pm mythexport-2.2.3/usr/share/mythexport/configs/PortableH264LowRes.pm
+--- mythexport-2.2.3.orig//usr/share/mythexport/configs/PortableH264LowRes.pm	2011-04-26 06:04:09.000000000 +0000
++++ mythexport-2.2.3/usr/share/mythexport/configs/PortableH264LowRes.pm	1970-01-01 00:00:00.000000000 +0000
+@@ -1,28 +0,0 @@
+-#!/usr/bin/perl 
+-
+-package PortableH264LowRes;
+-
+-use ExportBase;
+-
+-our @ISA = qw(ExportBase);
+-
+-my $description = "Low Resolution (480x320) Portable H264 Settings.";
+-my $devices = "Low Resolution Android Devices (example HTC Hero), iPod Classic, iPod Nano";
+-my $notes = "Requires AAC, <a href=\"https://help.ubuntu.com/community/Medibuntu\">activate Medibuntu</a>";
+-my $version = "1.0";
+-
+-sub new{
+-    my $class = shift;
+-    my $self = $class->SUPER::new(shift, shift, $description, $devices, $notes, $version);
+-    bless $self, $class;
+-    return $self;
+-}
+-
+-sub export{
+-    my( $self ) = @_;
+-
+-    system("ffmpeg -i \'$self->{_inputFile}\' -y -pass 1 -an -vcodec libx264 -vpre slowfirstpass -vpre ipod320 -b 1500kb -bt 1000kb -threads 0 -s 480x320 -aspect 16:9 -f ipod \'$self->{_outputFile}$self->{_extension}\' && ffmpeg -i \'$self->{_inputFile}\' -y -pass 2 -vcodec libx264 -vpre hq -vpre ipod320 -b 1500kb -bt 1000kb -threads 0 -s 480x320 -acodec libfaac -ab 192kb -ac 2 -aspect 16:9 -f ipod \'$self->{_outputFile}$self->{_extension}\'");
+-
+-}
+-
+-1;
+diff -ruaN mythexport-2.2.3.orig//usr/share/mythexport/configs/Universal.pm mythexport-2.2.3/usr/share/mythexport/configs/Universal.pm
+--- mythexport-2.2.3.orig//usr/share/mythexport/configs/Universal.pm	1970-01-01 00:00:00.000000000 +0000
++++ mythexport-2.2.3/usr/share/mythexport/configs/Universal.pm	2011-12-21 05:54:19.000000000 +0000
+@@ -0,0 +1,28 @@
++#!/usr/bin/perl 
++
++package Universal;
++
++use ExportBase;
++
++our @ISA = qw(ExportBase);
++
++my $description = "HandBrake's universally compatible, full resolution settings for all current Apple devices";
++my $devices = "iPod (6G and up), iPhone, AppleTV, and Macs.";
++my $notes = "";
++my $version = "1.0";
++
++sub new{
++    my $class = shift;
++    my $self = $class->SUPER::new(shift, shift, $description, $devices, $notes, $version);
++    bless $self, $class;
++    return $self;
++}
++
++sub export{
++    my( $self ) = @_;
++
++    system("HandBrakeCLI -i \'$self->{_inputFile}\' -o \'$self->{_outputFile}$self->{_extension}\' --preset=\"Universal\"");
++
++}
++
++1;
+diff -ruaN mythexport-2.2.3.orig//usr/share/mythexport/configs/iPad.pm mythexport-2.2.3/usr/share/mythexport/configs/iPad.pm
+--- mythexport-2.2.3.orig//usr/share/mythexport/configs/iPad.pm	1970-01-01 00:00:00.000000000 +0000
++++ mythexport-2.2.3/usr/share/mythexport/configs/iPad.pm	2011-12-21 05:54:19.000000000 +0000
+@@ -0,0 +1,28 @@
++#!/usr/bin/perl 
++
++package iPad;
++
++use ExportBase;
++
++our @ISA = qw(ExportBase);
++
++my $description = "HandBrake's preset for the iPad is optimized for viewing on its 1024x768 display";
++my $devices = "iPad";
++my $notes = "";
++my $version = "1.0";
++
++sub new{
++    my $class = shift;
++    my $self = $class->SUPER::new(shift, shift, $description, $devices, $notes, $version);
++    bless $self, $class;
++    return $self;
++}
++
++sub export{
++    my( $self ) = @_;
++
++    system("HandBrakeCLI -i \'$self->{_inputFile}\' -o \'$self->{_outputFile}$self->{_extension}\' --preset=\"iPad\"");
++
++}
++
++1;
+diff -ruaN mythexport-2.2.3.orig//usr/share/mythexport/configs/iPhone.pm mythexport-2.2.3/usr/share/mythexport/configs/iPhone.pm
+--- mythexport-2.2.3.orig//usr/share/mythexport/configs/iPhone.pm	1970-01-01 00:00:00.000000000 +0000
++++ mythexport-2.2.3/usr/share/mythexport/configs/iPhone.pm	2011-12-21 05:54:19.000000000 +0000
+@@ -0,0 +1,28 @@
++#!/usr/bin/perl 
++
++package iPhone;
++
++use ExportBase;
++
++our @ISA = qw(ExportBase);
++
++my $description = "HandBrake's settings for all iPhones and iPod Touches going back to the original iPhone 2G.";
++my $devices = "iPhone and iPod Touch";
++my $notes = "";
++my $version = "1.0";
++
++sub new{
++    my $class = shift;
++    my $self = $class->SUPER::new(shift, shift, $description, $devices, $notes, $version);
++    bless $self, $class;
++    return $self;
++}
++
++sub export{
++    my( $self ) = @_;
++
++    system("HandBrakeCLI -i \'$self->{_inputFile}\' -o \'$self->{_outputFile}$self->{_extension}\' --preset=\"iPhone & iPod Touch\"");
++
++}
++
++1;
+diff -ruaN mythexport-2.2.3.orig//usr/share/mythexport/configs/iPhone4.pm mythexport-2.2.3/usr/share/mythexport/configs/iPhone4.pm
+--- mythexport-2.2.3.orig//usr/share/mythexport/configs/iPhone4.pm	1970-01-01 00:00:00.000000000 +0000
++++ mythexport-2.2.3/usr/share/mythexport/configs/iPhone4.pm	2011-12-21 05:54:19.000000000 +0000
+@@ -0,0 +1,28 @@
++#!/usr/bin/perl 
++
++package iPhone4;
++
++use ExportBase;
++
++our @ISA = qw(ExportBase);
++
++my $description = "HandBrake's preset for the iPhone 4 is optimized for viewing on its 960x480 display.";
++my $devices = "iPhone 4";
++my $notes = "";
++my $version = "1.0";
++
++sub new{
++    my $class = shift;
++    my $self = $class->SUPER::new(shift, shift, $description, $devices, $notes, $version);
++    bless $self, $class;
++    return $self;
++}
++
++sub export{
++    my( $self ) = @_;
++
++    system("HandBrakeCLI -i \'$self->{_inputFile}\' -o \'$self->{_outputFile}$self->{_extension}\' --preset=\"iPhone 4\"");
++
++}
++
++1;
+diff -ruaN mythexport-2.2.3.orig//usr/share/mythexport/configs/iPod.pm mythexport-2.2.3/usr/share/mythexport/configs/iPod.pm
+--- mythexport-2.2.3.orig//usr/share/mythexport/configs/iPod.pm	1970-01-01 00:00:00.000000000 +0000
++++ mythexport-2.2.3/usr/share/mythexport/configs/iPod.pm	2011-12-21 05:54:19.000000000 +0000
+@@ -0,0 +1,28 @@
++#!/usr/bin/perl 
++
++package iPod;
++
++use ExportBase;
++
++our @ISA = qw(ExportBase);
++
++my $description = "HandBrake's low resolution settings, optimized for great playback on the iPod screen, with smaller file size. ";
++my $devices = "iPod (5G and up)";
++my $notes = "";
++my $version = "1.0";
++
++sub new{
++    my $class = shift;
++    my $self = $class->SUPER::new(shift, shift, $description, $devices, $notes, $version);
++    bless $self, $class;
++    return $self;
++}
++
++sub export{
++    my( $self ) = @_;
++
++    system("HandBrakeCLI -i \'$self->{_inputFile}\' -o \'$self->{_outputFile}$self->{_extension}\' --preset=\"iPod\"");
++
++}
++
++1;
+diff -ruaN mythexport-2.2.3.orig//usr/share/mythtv/mythexport/images/powered_apache_80x15_2.png mythexport-2.2.3/usr/share/mythtv/mythexport/images/powered_apache_80x15_2.png
+--- mythexport-2.2.3.orig//usr/share/mythtv/mythexport/images/powered_apache_80x15_2.png	2011-04-26 06:04:09.000000000 +0000
++++ mythexport-2.2.3/usr/share/mythtv/mythexport/images/powered_apache_80x15_2.png	1970-01-01 00:00:00.000000000 +0000
+@@ -1,5 +0,0 @@
+-�PNG
+-
+-���
IHDR���P�������������	pHYs����������tIME�	81�u����*IDAT��fff������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������ggg����������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������f��������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������>>>������$���-(		������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������*)*zzz

	����
+-�*?7
YG
))������������������������������������������������e���������������e������������e������f������e������������e���������������e������������e���������		��������������������������������������������������+���.̴��"L<9. 
+-�������������������������������������������e������e������e������������e��������������������������������e�����������������������d���������������������������������������������234?���ױ���������,)�#��	����0�6="4";;���������������������������e������������������������������������������������������e������������e���������������e���������������������������������������������������������������E@=�2/�����;�������������.��������� �D�Y';<������������������������������������������������������������������������������������e������������������������������������������������������������������������������	!���t�»����O�������������������".������68K��������������������������������e�������������f���f������������e����������������e���������e������������e������		���������������������������������fff�����������������������������������������������������%�1�������������������������������������������������������������������������������������������������������������������������������������������������f��ggg���������������������������7���������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������f�����������������������������������������������������������������������������������������������������������������������������������������������������������������fff���������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������O�*������IEND�B`�
+\ No newline at end of file
+diff -ruaN mythexport-2.2.3.orig//usr/share/mythtv/mythexport/images/powered_mysql_80x15_2.png mythexport-2.2.3/usr/share/mythtv/mythexport/images/powered_mysql_80x15_2.png
+--- mythexport-2.2.3.orig//usr/share/mythtv/mythexport/images/powered_mysql_80x15_2.png	2011-04-26 06:04:09.000000000 +0000
++++ mythexport-2.2.3/usr/share/mythtv/mythexport/images/powered_mysql_80x15_2.png	1970-01-01 00:00:00.000000000 +0000
+@@ -1,3 +0,0 @@
+-�PNG
+-
+-���
IHDR���P�������������gAMA�����OX2���tEXtSoftware�Adobe ImageReadyq�e<���IDATx�bLKKcI� �X�x�̙p���"�n���]��Z���� �p�mzz:@���	}���矿+���yV���'+K�����1&2fN���?��H���'����ʳ����&�ڗ����p�ڲ�����Ą)�i����t������~���dgnб{/J������1� �j0��BU�ĂU�XV���g���|�@.0'Ow🾹vӱ�`;"��sZ���5�P� D���ԯ��$Gӈ�ţ�7����F��ĄU�FUf����}����Lߧ�t�:C|�:��2�D�<���9X�}�yj!A'vr�G�jL;x	%1015�Z�;r�Ϋ�G2ē��4�F<�)��_��1 �XpIHps���	��	�Yjm�x��՘�&�hAӈ�(0Mfc�O���ĄKb�Ż��|�⑦�Go?���/�N�(x���9��Hօg`\��g�$�L��<L��#�����������x9�����&�,��x���h���z^`��OZ��*i���/��XS`� �p&i	~�o?�=s����É�:�3��J���i1�A��� �p&�`cճ�^���C����×�R�J�Ӣ�W��]����o�V� �p�00G�i�i�;i��=zUF�W��.맧D7_��}􊞴p��r�m0��bi�%���U�A3����IEND�B`�
+\ No newline at end of file
+diff -ruaN mythexport-2.2.3.orig//usr/share/mythtv/mythexport/images/powered_ubuntu_80x15_2.png mythexport-2.2.3/usr/share/mythtv/mythexport/images/powered_ubuntu_80x15_2.png
+--- mythexport-2.2.3.orig//usr/share/mythtv/mythexport/images/powered_ubuntu_80x15_2.png	2011-04-26 06:04:09.000000000 +0000
++++ mythexport-2.2.3/usr/share/mythtv/mythexport/images/powered_ubuntu_80x15_2.png	1970-01-01 00:00:00.000000000 +0000
+@@ -1,4 +0,0 @@
+-�PNG
+-
+-���
IHDR���P�������������	pHYs���������eIDAT�cLKKcI����a�̙#ķ���,�������ȈL�|���֭"��ll�t��]6h}����a��祃�.���뻇|�g�d���IO$�؞���:î9��6���M�1��?.#>5�L��q�*�ZD��_��rm�?�2Ʃع���:V�s�]֞�������a��Y�D"���]��#��kDM#��[�����3v�����9����e����Y#���ȸ���[,���D�A��������
+-�4�2�����<;�ĉ��]��ͯd�Oa�0cd����?D��%�'�0;;��S.���AS��������<����ۗ|�_����+D�ݜE��ڔ���J3�d����[\&���H����$8����xwΏ}��}���>�Z�����ܜCS�x�#�-��p�BD�$����'i�I���r�I�1--
k���������xE�mY���D�BNM��0r	L�U��!��Vq����````dd�����6ި�?_��902_���+�&IK E�L�Z��Aoo//FFƿoo�RaU��mi�ˈF2�1W�|̀q����hl���5r����IEND�B`�
+\ No newline at end of file
+diff -ruaN mythexport-2.2.3.orig//usr/share/mythtv/mythexport/player.cgi mythexport-2.2.3/usr/share/mythtv/mythexport/player.cgi
+--- mythexport-2.2.3.orig//usr/share/mythtv/mythexport/player.cgi	2011-04-26 06:04:09.000000000 +0000
++++ mythexport-2.2.3/usr/share/mythtv/mythexport/player.cgi	2011-12-21 05:54:19.000000000 +0000
+@@ -29,7 +29,7 @@
+     my $query_handle = $connect->prepare($query);
+     $query_handle->execute($id)  || die "Unable to query mythexport table";
+ 
+-    $content = "<p>This page is a work in progress, it may work for your Anroid device or iPhone.<br />";
++    $content = "<p>This page is a work in progress, it may work for your Android device or iPhone.<br />";
+ 
+     while ( my $file = $query_handle->fetchrow_array() ) {
+ 	    $content .= "<video width=\"480\" height=\"320\" autobuffer controls onClick=\"this.play();\">
+diff -ruaN mythexport-2.2.3.orig//usr/share/mythtv/mythexport/template/template.tmpl mythexport-2.2.3/usr/share/mythtv/mythexport/template/template.tmpl
+--- mythexport-2.2.3.orig//usr/share/mythtv/mythexport/template/template.tmpl	2011-04-26 06:04:09.000000000 +0000
++++ mythexport-2.2.3/usr/share/mythtv/mythexport/template/template.tmpl	2011-12-21 05:54:19.000000000 +0000
+@@ -32,11 +32,5 @@
+ 	<div id="content">
+ 		<TMPL_VAR NAME=CONTENT>
+         <div class="clear">&nbsp;</div>
+-	</div>
+-	<div id="buttons">
+-			<a title="Powered By Ubuntu" href="http://www.ubuntu.com"><img src="images/powered_ubuntu_80x15_2.png" alt="Powered By Ubuntu" width="80" height="15" /></a>
+-			<a title="Powered By Apache" href="http://www.apache.org/"><img src="images/powered_apache_80x15_2.png" alt="Powered By Apache" width="80" height="15" /></a>
+-			<a title="Powered By MySQL" href="http://www.mysql.com"><img src="images/powered_mysql_80x15_2.png" alt="Powered By MySQL" width="80" height="15" /></a>
+-    </div>
+ </body>
+ </html>
diff --git a/abs/extra/mythexport/mythexport.install b/abs/extra/mythexport/mythexport.install
index 361f1e5..9bd1213 100644
--- a/abs/extra/mythexport/mythexport.install
+++ b/abs/extra/mythexport/mythexport.install
@@ -82,6 +82,9 @@ post_remove() {
   echo "==> Forcing re-read of lighttpd's configuration file."
   echo ""
     /sbin/sv hup /service/lighttpd
+  rm -fr /data/srv/httpd/htdocs/mythexport
+  rm -fr /usr/share/mythtv/mythexport/video
+  rm -fr /srv/http/.mythtv/config.xml
 }
 
 
-- 
cgit v0.12