From 80650b0d4c91464a65f0f7c76fba242a74524ba7 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Wed, 23 Jun 2010 16:35:30 -0500
Subject: linhes-scripts: Update shootscreens.sh and shootscreens-mythtv.sh to
 use the osd_cat.cfg

---
 abs/core-testing/linhes-scripts/PKGBUILD           |  6 +++---
 .../linhes-scripts/shootscreens-mythtv.sh          | 14 ++++++++++---
 abs/core-testing/linhes-scripts/shootscreens.sh    | 23 ++++++++++++++--------
 3 files changed, 29 insertions(+), 14 deletions(-)

diff --git a/abs/core-testing/linhes-scripts/PKGBUILD b/abs/core-testing/linhes-scripts/PKGBUILD
index 377cb60..e77d22a 100644
--- a/abs/core-testing/linhes-scripts/PKGBUILD
+++ b/abs/core-testing/linhes-scripts/PKGBUILD
@@ -3,7 +3,7 @@
 
 pkgname=linhes-scripts
 pkgver=1
-pkgrel=75
+pkgrel=76
 pkgdesc="Various scripts that help to make LinHES, LinHES."
 arch=('i686' 'x86_64')
 license=('GPL2')
@@ -57,10 +57,10 @@ build() {
   cp pause_mythcommflag $startdir/pkg/etc/logrotate.d/
 }
 md5sums=('f56985b2d602e11dc1e10d3e7848b2a5'
-         '623b6e9ba6cc4a19771005e750f337a7'
+         '9a2181cdc0bc9cc8b42101f19620def8'
          '9ae2cd7a0c42d57ad8b5f515d7d60196'
          '1274bad3fb7296f00acd2d44804bad14'
-         'b4f858834ea92418208ab496ca39ad32'
+         '47225fa9b6c953d56f6ede84d921a300'
          '6b6e7d34a4bda6d608d150039adefd07'
          '3fe554dbbf7d09e1f9925032ba888bf5'
          '18263972b6326e140bbef0bb7dfa2da9'
diff --git a/abs/core-testing/linhes-scripts/shootscreens-mythtv.sh b/abs/core-testing/linhes-scripts/shootscreens-mythtv.sh
index db01147..111b980 100755
--- a/abs/core-testing/linhes-scripts/shootscreens-mythtv.sh
+++ b/abs/core-testing/linhes-scripts/shootscreens-mythtv.sh
@@ -1,11 +1,19 @@
 #! /bin/bash 
-# available sizes: 34, 25, 24, 20, 18, 17, 14, 12, 11, 10
-export FONT="-adobe-helvetica-bold-*-*-*-34-*-*-*-*-*-*-*"
+
+. /etc/osd_cat.cfg || {
+	color=yellow
+	outline=2
+	outlinecolour=black
+	shadow=0
+	shadowcolour=black
+	font="-adobe-helvetica-bold-*-*-*-34-*-*-*-*-*-*-*"
+}
+
 echo "This could take several minutes," > /tmp/screens
 echo "depending on your hardware and the" >> /tmp/screens
 echo "number and type of videos you have." >> /tmp/screens
 echo "It will only work on videos scanned" >> /tmp/screens
 echo "with Video Manager." >> /tmp/screens 
-cat /tmp/screens | osd_cat --font=$FONT --shadow=3 --pos=middle --align=centre --offset=200 --color=yellow --delay=0 &
+cat /tmp/screens | osd_cat --pos=middle --align=center --delay=0 --offset=200 --color=$color --outline=$outline --outlinecolour=$outlinecolour --shadow=$shadow --shadowcolour=$shadowcolour --font=$font &
 shootscreens.sh 1
 /bin/rm -f /tmp/screens
\ No newline at end of file
diff --git a/abs/core-testing/linhes-scripts/shootscreens.sh b/abs/core-testing/linhes-scripts/shootscreens.sh
index 7b1260c..bb45252 100755
--- a/abs/core-testing/linhes-scripts/shootscreens.sh
+++ b/abs/core-testing/linhes-scripts/shootscreens.sh
@@ -10,6 +10,14 @@
 
 if [ "$1" == "1" ]; then
     OSD=1
+    . /etc/osd_cat.cfg || {
+        color=yellow
+        outline=2
+        outlinecolour=black
+        shadow=0
+        shadowcolour=black
+        font="-adobe-helvetica-bold-*-*-*-34-*-*-*-*-*-*-*"
+    }
 else
     OSD=0
 fi
@@ -23,15 +31,14 @@ fi
     increment=$(expr 100 / $vidcount)
     for vid in `mysql -u root mythconverg -B -e "select filename from videometadata where coverfile=\"No Cover\";" | grep -v -e "^filename$"`
     do
-      if [ $OSD == 1 ]; then
-	osd_cat --barmode=percentage --percentage=$percentage --pos=middle --align=center --color=white --text="Generating Video Thumbnails..." --font=$FONT --shadow=3 --color=yellow --delay=0 &
-	percentage=$(expr $percentage + $increment)
-      fi
-
-      screenshooter.sh -v $vid
+    	if [ $OSD == 1 ]; then
+            osd_cat --barmode=percentage --percentage=$percentage --pos=middle --align=center --text="Generating Video Thumbnails..." --delay=0 --color=$color --outline=$outline --outlinecolour=$outlinecolour --shadow=$shadow --shadowcolour=$shadowcolour --font=$font &
+            percentage=$(expr $percentage + $increment)
+        fi
+        screenshooter.sh -v $vid
     done
     if [ $OSD == 1 ]; then
-	killall -9 osd_cat
-	osd_cat --barmode=percentage --percentage=100 --pos=middle --align=center --color=white --text="Video Thumbnails Generated!" --font=$FONT --shadow=3 --color=yellow --delay=3 &
+        killall -9 osd_cat
+        osd_cat --barmode=percentage --percentage=100 --pos=middle --align=center --text="Video Thumbnails Generated!" --delay=3 --color=$color --outline=$outline --outlinecolour=$outlinecolour --shadow=$shadow --shadowcolour=$shadowcolour --font=$font &
     fi
 }
\ No newline at end of file
-- 
cgit v0.12