From 539c98e47e9dd196494f5508692aaac0b38c20e4 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Tue, 29 Sep 2020 01:53:51 +0000
Subject: libcap-ng: update to 0.8

---
 abs/extra/libcap-ng/PKGBUILD | 46 ++++++++++++++++++++++++++++----------------
 1 file changed, 29 insertions(+), 17 deletions(-)

diff --git a/abs/extra/libcap-ng/PKGBUILD b/abs/extra/libcap-ng/PKGBUILD
index 1e3544b..f05caf3 100644
--- a/abs/extra/libcap-ng/PKGBUILD
+++ b/abs/extra/libcap-ng/PKGBUILD
@@ -1,30 +1,42 @@
-# $Id: PKGBUILD 139367 2011-10-01 18:59:37Z ibiru $
-# Maintainer: Ionut Biru <ibiru@archlinux.org>
+# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
+# Contributor: Ionut Biru <ibiru@archlinux.org>
 # Contributor: Gerardo Exequiel Pozzi <vmlinuz386@yahoo.com.ar>
 
 pkgname=libcap-ng
-pkgver=0.6.6
+pkgver=0.8
 pkgrel=1
-pkgdesc="A library intended to make programming with POSIX capabilities much easier than the traditional libcap"
-arch=('i686' 'x86_64')
-url="http://people.redhat.com/sgrubb/libcap-ng/"
-license=('GPL2' 'LGPL2.1')
+pkgdesc='Library making programming with POSIX capabilities easier than traditional libcap'
+url='https://people.redhat.com/sgrubb/libcap-ng/'
+arch=('x86_64')
+license=('LGPL2.1')
 depends=('glibc')
-options=('!libtool')
-source=(http://people.redhat.com/sgrubb/$pkgname/$pkgname-$pkgver.tar.gz)
-md5sums=('eb71f967cecb44b4342baac98ef8cb0f')
+provides=('libcap-ng.so')
+source=(https://github.com/stevegrubb/libcap-ng/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz)
+sha512sums=('47b079849ee051544e74b006bcfff1f7965c79099db52f39f49e3f138137748712df2ef88f3fbd9715d44d9f2d118593f557dba1ede45a0168e7c813a4e65f46')
+b2sums=('e31be8b3f3879f5a266c9ca2893353c84b628833d923992f3aaedfca5ca60b7a5d3beceb4144911ebc311c5cbb7bcf442e5221aa2bbf494d5eac9ef11d253909')
 
-build() {
-  cd $srcdir/$pkgname-$pkgver
+prepare() {
+  cd ${pkgname}-${pkgver}
+  autoreconf -fiv
+}
 
-  ./configure --prefix=/usr --enable-static=no --with-python=no
+build() {
+  cd ${pkgname}-${pkgver}
+  ./configure \
+    --prefix=/usr \
+    --enable-static=no \
+    -with-python=no
   make
 }
 
-package() {
-  cd $srcdir/$pkgname-$pkgver
+check() {
+  cd ${pkgname}-${pkgver}
+  make check
+}
 
-  make DESTDIR=$pkgdir install
+package() {
+  cd ${pkgname}-${pkgver}
+  make DESTDIR="${pkgdir}" install
 }
 
-# vim:set ts=2 sw=2 et:
+# vim: ts=2 sw=2 et:
-- 
cgit v0.12