From 60884ca433bf67e0ddd4da7688372715cdf3c7ea Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Wed, 29 Nov 2017 20:37:05 +0000
Subject: mythdb-initial: changes for new mythtv networking options

---
 abs/core/mythdb-initial/PKGBUILD   |  8 ++++----
 abs/core/mythdb-initial/custom.sql | 28 ++++++++++++++++++++--------
 abs/core/mythdb-initial/mc.sql     |  2 +-
 3 files changed, 25 insertions(+), 13 deletions(-)

diff --git a/abs/core/mythdb-initial/PKGBUILD b/abs/core/mythdb-initial/PKGBUILD
index 3a30309..f17a98f 100755
--- a/abs/core/mythdb-initial/PKGBUILD
+++ b/abs/core/mythdb-initial/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=mythdb-initial
 pkgver=8.5
-pkgrel=2
+pkgrel=3
 pkgdesc="setup the initial mythtv database for linhes"
 url=""
 license=()
@@ -11,7 +11,7 @@ replaces=()
 backup=()
 install=mythdb.install
 source=(mc.sql permissions.sql custom.sql )
-arch=('i686' 'x86_64')
+arch=('x86_64')
 package() {
   cd $srcdir
   mkdir -p $pkgdir/data/database
@@ -20,6 +20,6 @@ package() {
   cp $srcdir/custom.sql  $pkgdir/data/database/custom.sql
 }
 
-md5sums=('127e6f5c66011552c952331c4eedcecc'
+md5sums=('fb6be5fd1f77fd4211e9727061e2dca5'
          'ad0e57ac5e7c3677808a670e16634bba'
-         '1701d4b347aebe6cee63408c90cd7a74')
+         'e4f890e4569547737e534bbdb17aef7b')
diff --git a/abs/core/mythdb-initial/custom.sql b/abs/core/mythdb-initial/custom.sql
index 7c97589..094273f 100644
--- a/abs/core/mythdb-initial/custom.sql
+++ b/abs/core/mythdb-initial/custom.sql
@@ -32,18 +32,29 @@ INSERT INTO `settings` (`value`, `data`, `hostname`) VALUES
 
 -- Clear out old values because mysql is mysql
 DELETE from settings where value in
-('WOLbackendReconnectWaitTime','AutoStartFrontend',
- 'AllowQuitShutdown','BackendServerIP'
- 'BackendServerIP6','HaltCommand'
- 'RebootCommand','Theme'
+('WOLbackendReconnectWaitTime',
+ 'StorageScheduler',
+ 'AutoStartFrontend',
+ 'AllowQuitShutdown',
+ 'AllowConnFromAll',
+ 'ListenOnAllIps',
+ 'BackendServerIP',
+ 'BackendServerIP6',
+ 'HaltCommand',
+ 'RebootCommand',
+ 'Theme',
+ 'ThemePainter',
  'LircSocket');
 
 INSERT INTO `settings` (`value`, `data`, `hostname`) VALUES
- ('WOLbackendReconnectWaitTime','5',NULL);
+ ('WOLbackendReconnectWaitTime','5',NULL)
+ ('StorageScheduler','Combination',NULL);
 
 INSERT INTO `settings` (`value`, `data`, `hostname`) VALUES
  ('AutoStartFrontend'     ,'1'                             , 'apheleia'),
  ('AllowQuitShutdown'     ,'4'                             , 'apheleia'),
+ ('AllowConnFromAll'      ,'0'                             , 'apheleia'),
+ ('ListenOnAllIps'        ,'0'                             , 'apheleia'),
  ('BackendServerIP'       ,'127.0.0.1'                     , 'apheleia'),
  ('BackendServerIP6'      ,'::1'                           , 'apheleia'),
  ('HaltCommand'           ,'sudo /sbin/halt'               , 'apheleia'),
@@ -67,7 +78,6 @@ INSERT INTO `settings` (`value`, `data`, `hostname`) VALUES
 
 
 -- MythVideo old local dir..replaced by storage groups, but should set values to null
-
 INSERT INTO `settings` (`value`, `data`, `hostname`) VALUES
 ('ScreenShotPath'              ,''  , 'apheleia'),
 ('VideoStartupDir'             ,''  , 'apheleia'),
@@ -106,7 +116,9 @@ INSERT INTO `settings` (`value`, `data`, `hostname`) VALUES
 
 -- Clear out old values because mysql is mysql
 DELETE from settings where value in
-('OverrideExitMenu','NetworkControlEnabled''SecurityPin',
+('OverrideExitMenu',
+ 'NetworkControlEnabled',
+ 'SecurityPin',
  'BackendStopCommand',
  'BackendStartCommand');
 
@@ -171,7 +183,7 @@ INSERT INTO `settings` (`value`, `data`, `hostname`) VALUES
 ('HOSTOSsize',      '5'    ,   'apheleia'),
 ('HOSTrootfstype',  'ext4' ,   'apheleia'),
 ('HOSTHOMEsize',    '5'    ,   'apheleia'),
-('HOSTDatabasesize','2'    ,   'apheleia'),
+('HOSTDatabasesize','3'    ,   'apheleia'),
 ('HostUseSWAP',     '1'    ,   'apheleia'),
 ('HostUseALLdata',  '1'    ,   'apheleia'),
 ('HOSTdatafstype',  'xfs'  ,   'apheleia');
diff --git a/abs/core/mythdb-initial/mc.sql b/abs/core/mythdb-initial/mc.sql
index ca9c09b..c0343f0 100644
--- a/abs/core/mythdb-initial/mc.sql
+++ b/abs/core/mythdb-initial/mc.sql
@@ -2205,7 +2205,7 @@ CREATE TABLE `settings` (
 
 LOCK TABLES `settings` WRITE;
 /*!40000 ALTER TABLE `settings` DISABLE KEYS */;
-INSERT INTO `settings` VALUES ('mythfilldatabaseLastRunStart','',NULL),('mythfilldatabaseLastRunEnd','',NULL),('mythfilldatabaseLastRunStatus','',NULL),('DataDirectMessage','',NULL),('HaveRepeats','0',NULL),('DBSchemaVer','1348',NULL),('WebBrowserZoomLevel','1','apheleia'),('Language','en_US',NULL),('Country','US',NULL),('FreqTable','us-bcast',NULL),('ISO639Language0','eng',NULL),('ISO639Language1','eng',NULL),('TVFormat','NTSC',NULL),('VbiFormat','NTSC Closed Caption',NULL),('DateFormat','ddd MMM d yyyy','apheleia'),('MythArchiveDateFormat','%a %b %d %Y','apheleia'),('MythArchiveTimeFormat','%I:%M %p','apheleia'),('MythArchiveVideoFormat','NTSC','apheleia'),('ShortDateFormat','M/d','apheleia'),('TimeFormat','h:mm AP','apheleia'),('BackupDBLastRunStart','2017-09-18 03:10:10',NULL),('BackupDBLastRunEnd','2017-09-18 03:10:11',NULL),('HardwareProfileEnabled','0',NULL),('BackendServerIP','127.0.0.1','apheleia'),('BackendServerIP6','::1','apheleia'),('AllowLinkLocal','1','apheleia'),('BackendServerPort','6543','apheleia'),('BackendStatusPort','6544','apheleia'),('MasterServerIP','127.0.0.1',NULL),('MasterServerPort','6543',NULL),('MasterBackendOverride','1',NULL),('DeletesFollowLinks','0',NULL),('TruncateDeletesSlowly','0','apheleia'),('HDRingbufferSize','9400',NULL),('StorageScheduler','BalancedFreeSpace',NULL),('UPnP/WMPSource','0',NULL),('DisableAutomaticBackup','0',NULL),('DisableFirewireReset','0','apheleia'),('EITTransportTimeout','5',NULL),('EITCrawIdleStart','60',NULL),('blockSDWUwithoutClient','1',NULL),('idleWaitForRecordingTime','15',NULL),('StartupSecsBeforeRecording','120',NULL),('WakeupTimeFormat','hh:mm yyyy-MM-dd',NULL),('ServerHaltCommand','sudo /sbin/halt -p',NULL),('WOLbackendConnectRetry','5',NULL),('BackendStopCommand','killall mythbackend',NULL),('BackendStartCommand','mythbackend',NULL),('JobQueueMaxSimultaneousJobs','1','apheleia'),('JobQueueCheckFrequency','60','apheleia'),('JobQueueWindowStart','00:00','apheleia'),('JobQueueWindowEnd','23:59','apheleia'),('JobQueueCPU','0','apheleia'),('JobAllowMetadata','1','apheleia'),('JobAllowCommFlag','1','apheleia'),('JobAllowTranscode','1','apheleia'),('JobAllowUserJob1','0','apheleia'),('JobAllowUserJob2','0','apheleia'),('JobAllowUserJob3','0','apheleia'),('JobAllowUserJob4','0','apheleia'),('JobsRunOnRecordHost','0',NULL),('AutoCommflagWhileRecording','0',NULL),('JobQueueCommFlagCommand','mythcommflag',NULL),('JobQueueTranscodeCommand','mythtranscode',NULL),('AutoTranscodeBeforeAutoCommflag','0',NULL),('SaveTranscoding','0',NULL),('UserJobDesc1','User Job #1',NULL),('UserJobDesc2','User Job #2',NULL),('UserJobDesc3','User Job #3',NULL),('UserJobDesc4','User Job #4',NULL),('MythFillEnabled','1',NULL),('MythFillDatabasePath','mythfilldatabase',NULL),('MythFillMaxHour','23',NULL),('MythFillGrabberSuggestsTime','1',NULL),('DateFormat','ddd MMM d yyyy','apheleia'),('MythArchiveDateFormat','%a %b %d %Y','apheleia'),('MythArchiveTimeFormat','%I:%M %p','apheleia'),('MythArchiveVideoFormat','NTSC','apheleia'),('ShortDateFormat','M/d','apheleia'),('TimeFormat','h:mm AP','apheleia'),('WebBrowserZoomLevel','1','apheleia'),('ImageStorageGroupName','Images',NULL),('ImageSortOrder','0',NULL),('ImageShowHiddenFiles','0',NULL),('ImageSlideShowTime','3500',NULL),('ImageTransitionType','1',NULL),('ImageTransitionTime','1000',NULL),('MasterServerName','apheleia',NULL),('BackendServerAddr','127.0.0.1','apheleia');
+INSERT INTO `settings` VALUES ('mythfilldatabaseLastRunStart','',NULL),('mythfilldatabaseLastRunEnd','',NULL),('mythfilldatabaseLastRunStatus','',NULL),('DataDirectMessage','',NULL),('HaveRepeats','0',NULL),('DBSchemaVer','1348',NULL),('Language','en_US',NULL),('Country','US',NULL),('FreqTable','us-bcast',NULL),('ISO639Language0','eng',NULL),('ISO639Language1','eng',NULL),('TVFormat','NTSC',NULL),('VbiFormat','NTSC Closed Caption',NULL),('BackupDBLastRunStart','2017-09-18 03:10:10',NULL),('BackupDBLastRunEnd','2017-09-18 03:10:11',NULL),('HardwareProfileEnabled','0',NULL),('BackendServerIP','127.0.0.1','apheleia'),('BackendServerIP6','::1','apheleia'),('AllowLinkLocal','1','apheleia'),('BackendServerPort','6543','apheleia'),('BackendStatusPort','6544','apheleia'),('MasterServerIP','127.0.0.1',NULL),('MasterServerPort','6543',NULL),('MasterBackendOverride','1',NULL),('DeletesFollowLinks','0',NULL),('TruncateDeletesSlowly','0','apheleia'),('HDRingbufferSize','9400',NULL),('StorageScheduler','BalancedFreeSpace',NULL),('UPnP/WMPSource','0',NULL),('DisableAutomaticBackup','0',NULL),('DisableFirewireReset','0','apheleia'),('EITTransportTimeout','5',NULL),('EITCrawIdleStart','60',NULL),('blockSDWUwithoutClient','1',NULL),('idleWaitForRecordingTime','15',NULL),('StartupSecsBeforeRecording','120',NULL),('WakeupTimeFormat','hh:mm yyyy-MM-dd',NULL),('ServerHaltCommand','sudo /sbin/halt -p',NULL),('WOLbackendConnectRetry','5',NULL),('BackendStopCommand','killall mythbackend',NULL),('BackendStartCommand','mythbackend',NULL),('JobQueueMaxSimultaneousJobs','1','apheleia'),('JobQueueCheckFrequency','60','apheleia'),('JobQueueWindowStart','00:00','apheleia'),('JobQueueWindowEnd','23:59','apheleia'),('JobQueueCPU','0','apheleia'),('JobAllowMetadata','1','apheleia'),('JobAllowCommFlag','1','apheleia'),('JobAllowTranscode','1','apheleia'),('JobAllowUserJob1','0','apheleia'),('JobAllowUserJob2','0','apheleia'),('JobAllowUserJob3','0','apheleia'),('JobAllowUserJob4','0','apheleia'),('JobsRunOnRecordHost','0',NULL),('AutoCommflagWhileRecording','0',NULL),('JobQueueCommFlagCommand','mythcommflag',NULL),('JobQueueTranscodeCommand','mythtranscode',NULL),('AutoTranscodeBeforeAutoCommflag','0',NULL),('SaveTranscoding','0',NULL),('UserJobDesc1','User Job #1',NULL),('UserJobDesc2','User Job #2',NULL),('UserJobDesc3','User Job #3',NULL),('UserJobDesc4','User Job #4',NULL),('MythFillEnabled','1',NULL),('MythFillDatabasePath','mythfilldatabase',NULL),('MythFillMaxHour','23',NULL),('MythFillGrabberSuggestsTime','1',NULL),('DateFormat','ddd MMM d yyyy','apheleia'),('MythArchiveDateFormat','%a %b %d %Y','apheleia'),('MythArchiveTimeFormat','%I:%M %p','apheleia'),('MythArchiveVideoFormat','NTSC','apheleia'),('ShortDateFormat','M/d','apheleia'),('TimeFormat','h:mm AP','apheleia'),('WebBrowserZoomLevel','1','apheleia'),('ImageStorageGroupName','Images',NULL),('ImageSortOrder','0',NULL),('ImageShowHiddenFiles','0',NULL),('ImageSlideShowTime','3500',NULL),('ImageTransitionType','1',NULL),('ImageTransitionTime','1000',NULL),('MasterServerName','apheleia',NULL),('BackendServerAddr','127.0.0.1','apheleia');
 /*!40000 ALTER TABLE `settings` ENABLE KEYS */;
 UNLOCK TABLES;
 
-- 
cgit v0.12