From 51665a2b73e708c35d1f4e523f0ecf22eb544597 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Mon, 23 Apr 2012 20:42:07 -0500
Subject: runit-scripts: remotes:run: fix cmds so runit controls correct
 command. refs#821

---
 abs/core/runit-scripts/PKGBUILD                          |  2 +-
 abs/core/runit-scripts/runitscripts/services/remotes/run | 15 ++++++++-------
 2 files changed, 9 insertions(+), 8 deletions(-)

diff --git a/abs/core/runit-scripts/PKGBUILD b/abs/core/runit-scripts/PKGBUILD
index da205a5..c625da4 100755
--- a/abs/core/runit-scripts/PKGBUILD
+++ b/abs/core/runit-scripts/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=runit-scripts
 pkgver=2.1.1
-pkgrel=59
+pkgrel=60
 pkgdesc="collection of startup scripts for runit"
 url="http://smarden.org/runit/"
 license="BSD"
diff --git a/abs/core/runit-scripts/runitscripts/services/remotes/run b/abs/core/runit-scripts/runitscripts/services/remotes/run
index 35d3f80..9d46b0e 100755
--- a/abs/core/runit-scripts/runitscripts/services/remotes/run
+++ b/abs/core/runit-scripts/runitscripts/services/remotes/run
@@ -68,21 +68,21 @@ then
     CMD="/usr/sbin/lircd -r -n  --driver=commandir"
     printhl "   Using commandir"
     echo $CMD >>$LOG
-    exec $CMD >>$LOG 2>>$LOG
+    $CMD >>$LOG 2>>$LOG
 elif [ x$HostBlasterType = xiguanaIR-usb -o x$ReceiverType = xiguanaIR-usb ]
 then
     sv start igdaemon
     CMD="/usr/sbin/lircd -r -n  --driver=iguanaIR"
     printhl "       Using iguanaIR usb"
     echo $CMD >>$LOG
-    exec $CMD >>$LOG 2>>$LOG
+    $CMD >>$LOG 2>>$LOG
 elif [ x$ReceiverType = "xSiliconDust_HDHR" ]
 then
     # if using the SiliconDust_HDHR as an I/R Receiver
     CMD="/usr/sbin/lircd -H udp -d 5000 -n"
     printhl "   Using SiliconDust on port 5000"
     echo $CMD >>$LOG
-    exec $CMD >>$LOG 2>>$LOG
+    $CMD >>$LOG 2>>$LOG
 else
     LASTCMD=""
 
@@ -91,7 +91,7 @@ else
         CMD="/usr/sbin/lircd -r -d /dev/lirc$i --output=/var/run/lirc/lircd$i --pidfile=/var/run/lircd$i.pid --listen=876$i"
         printhl "   Device $i"
         echo $CMD >>$LOG
-        exec $CMD >>$LOG 2>>$LOG
+        $CMD >>$LOG 2>>$LOG
         LASTCMD="--connect=localhost:876$i   $LASTCMD    "
     done
 
@@ -102,13 +102,14 @@ else
         #program must not terminate.
 
         stat_runit "Starting remotes from /etc/remote.run"
-        echo "Starting remotes from /etc/remote.run" >>$LOG
-        exec /etc/remote.run    $LASTCMD >>$LOG 2>>$LOG
+        LCMD="/etc/remote.run    $LASTCMD"
+        echo "Starting remotes from $LCMD" >>$LOG
+        exec $LCMD >>$LOG 2>>$LOG
     else
         echo "Disable in kernel remote driver" >>$LOG
         in_kernel_support "disable"
         LCMD="/usr/sbin/lircd -r -n -d /dev/lirc0 --output /var/run/lirc/lircd  $LASTCMD"
-        echo $LCMD >>$LOG
+        echo "Starting remotes from $LCMD" >>$LOG
         exec $LCMD >>$LOG 2>>$LOG
     fi
 fi
-- 
cgit v0.12