From 8c1bbc2206ef188000c2c5c0cc4e8c11d6322ea7 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sat, 12 May 2012 17:09:49 -0500
Subject: local-website: rename index.html -> index.htm.  This is needed to
 automate making it the main website. This will work in conjuction with
 switch-web.sh, which is part of LinHES-system

---
 abs/core/local-website/PKGBUILD          |   2 +-
 abs/core/local-website/htdocs/index.htm  | 113 +++++++++++++++++++++++++++++++
 abs/core/local-website/htdocs/index.html | 113 -------------------------------
 3 files changed, 114 insertions(+), 114 deletions(-)
 create mode 100644 abs/core/local-website/htdocs/index.htm
 delete mode 100755 abs/core/local-website/htdocs/index.html

diff --git a/abs/core/local-website/PKGBUILD b/abs/core/local-website/PKGBUILD
index 71f90ae..82bf025 100644
--- a/abs/core/local-website/PKGBUILD
+++ b/abs/core/local-website/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=local-website
 pkgver=2
-pkgrel=29
+pkgrel=30
 pkgdesc="Contents of http://localhost"
 arch=(i686 x86_64)
 license=('GPL')
diff --git a/abs/core/local-website/htdocs/index.htm b/abs/core/local-website/htdocs/index.htm
new file mode 100644
index 0000000..04dff38
--- /dev/null
+++ b/abs/core/local-website/htdocs/index.htm
@@ -0,0 +1,113 @@
+<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
+<html>
+<head>
+    <base href="/linhes/">
+    <title>Welcome to LinHES!</title>
+
+    <meta http-equiv="content-type" content="text/html; charset=utf-8">
+    <meta name="robots" content="noindex, nofollow">
+
+    <script type="text/javascript" src="/linhes/js/prototype.js"></script>
+    <script type="text/javascript" src="/linhes/js/prototip/prototip.js"></script>
+    <link rel="stylesheet" type="text/css" href="/linhes/js/prototip/prototip.css">
+
+    <script type="text/javascript" src="/linhes/js/utils.js"></script>
+    <script type="text/javascript" src="/linhes/js/AC_OETags.js"></script>
+    <script type="text/javascript" src="/linhes/js/table_sort.js"></script>
+
+    <link rel="stylesheet" type="text/css" href="/linhes/default/style.css">
+    <link rel="stylesheet" type="text/css" href="/linhes/default/header.css">
+    <link rel="stylesheet" type="text/css" href="/linhes/default/menus.css">
+    <link rel="stylesheet" type="text/css" href="/linhes/default/programming.css">
+
+    <link rel="stylesheet" type="text/css" href="/linhes/default/welcome.css">
+</head>
+
+<body>
+<div id="page_header" style="position:relative; text-align:center;">
+    <div id="logo_box">
+        <a id="LinHES_logo" href="/">
+        <img src="/header.png" alt="Tux with a Remote" class="body">
+        </a>
+    </div>
+</div>
+
+<table width="100%" border="0" cellspacing="2" cellpadding="0">
+<tr>
+    <td colspan="2" class="menu menu_border_t menu_border_b">
+        <table class="body" width="100%" border="0" cellspacing="2" cellpadding="2">
+            <td align="center">
+                <a href="http://linhes.org" <b>The Linux Home Entertainment System Release 7</b></a>
+            </td>
+        </table>
+    </td>
+</tr>
+</table>
+
+
+<script type="text/javascript">
+//<!--
+
+    var visible_module = 'media';
+    function show_module_info(module) {
+        if (visible_module == module)
+            return;
+    // Change the outline on the list item
+        $('module_'+ visible_module).removeClassName('selected');
+        $('module_'+ module).addClassName('selected');
+    // Show and hide the appropriate info boxes
+        $('info_' + visible_module).hide();
+        $('info_' + visible_module).addClassName('hidden');
+        $('info_' + module).show();
+        $('info_' + module).removeClassName('hidden');
+    // Keep track of what's visible now
+        visible_module = module;
+    }
+
+// -->
+</script>
+
+<div id="modules" class="clearfix">
+
+    <div id="module_names">
+    <ul>
+        <li id="module_media" class="selected" onmouseover="show_module_info('media')">Media</li>
+        <li id="module_status" onmouseover="show_module_info('status')">Status</li>
+        <li id="module_help" onmouseover="show_module_info('help')">Help</li>
+    </ul>
+    </div>
+
+    <div id="module_info">
+        <div id="info_media">
+            <ul>
+                <li><a href="/mythweb/">MythWeb</a> - MythWeb provides a frontend for scheduling and managing recordings on your MythBox from a web browser.<br></li>
+                <li><a href="/remote/index.html">MythTV Web Remote</a><br></li>
+<!-- not working right now                <li><a href="/fuppes.php" target="_blank">FUPPES</a> - UPnP Media Server. Install via the Service Menu.<br></li> -->
+                <li><a href="/mediaserv.php" target="_blank">Mediaserv</a> - On-demand transcoding server for videos. Mediaserv is designed to transcode video in a format playable on the Nokia Internet Tablets.  However it works well at transcoding and streaming to any device that will playback AVIs (think streaming to any browser!). By default, your TV recordings (pretty) and video directory are linked. If you want Mediaserv to stream contents from a network share: ln -s /path/to/share /myth/mediaserv/media/<br></li>
+<!-- not working right now                <li><a href="/mythweb/data/mp3player.html">Radio</a> - Music in MythMusic must be encoded as MP3s.<br></li> -->
+                <li><a href="/mythexport/setup.cgi">MythExport</a> - PERL daemon used to transcode records and provides an RSS feed.<br></li> 
+            </ul>
+        </div>
+        <div id="info_status" class="hidden">
+            <ul>
+                <li><a href="/rrd/index-rrd.html">RRDTool</a> - A system monitoring tool.</li>
+                <li><a href="/monitorix/">Monitorix</a> - A lightweight system monitoring tool.<br></li>
+                <li><a href="http://fah-web.stanford.edu/cgi-bin/main.py?qtype=teampage&amp;teamnum=50975">KnoppMyth Folding@home Team Status</a></li>
+                <li><a href="/foldingathome/">My Folding@home Status</a></li>
+            </ul>
+        </div>
+        <div id="info_help" class="hidden">
+            <ul>
+                <li><a href="http://www.mythtv.org/docs/">MythTV Documentation</a></li>
+                <li><a href="/mythtv-doc/keys.txt">MythTV Default Keybindings</a></li>
+                <li><a href="http://www.mythtv.org/support">MythTV Support</a></li>
+                <li><a href="http://www.schedulesdirect.org/">Schedules Direct</a> - Provides U.S./Canadian TV listing data.<br></li>
+                <li><a href="/linhes.html">LinHES</a> - Describes how "The Project Leader" setup multiple systems to form <b>Lin</b>ux <b>H</b>ome <b>E</b>ntertainment <b>S</b>ystem.<br></li>
+                <li><a href="http://forum.linhes.org">LinHES Forum</a></li>
+                <li><a href="http://linhes.org/wiki">LinHES Wiki</a></li>
+                <li><a href="http://linhes.org/projects/linhes/issues">LinHES Bug Tracker</a></li>
+            </ul>
+        </div>
+    </div>
+</body>
+</html>
diff --git a/abs/core/local-website/htdocs/index.html b/abs/core/local-website/htdocs/index.html
deleted file mode 100755
index 04dff38..0000000
--- a/abs/core/local-website/htdocs/index.html
+++ /dev/null
@@ -1,113 +0,0 @@
-<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
-<html>
-<head>
-    <base href="/linhes/">
-    <title>Welcome to LinHES!</title>
-
-    <meta http-equiv="content-type" content="text/html; charset=utf-8">
-    <meta name="robots" content="noindex, nofollow">
-
-    <script type="text/javascript" src="/linhes/js/prototype.js"></script>
-    <script type="text/javascript" src="/linhes/js/prototip/prototip.js"></script>
-    <link rel="stylesheet" type="text/css" href="/linhes/js/prototip/prototip.css">
-
-    <script type="text/javascript" src="/linhes/js/utils.js"></script>
-    <script type="text/javascript" src="/linhes/js/AC_OETags.js"></script>
-    <script type="text/javascript" src="/linhes/js/table_sort.js"></script>
-
-    <link rel="stylesheet" type="text/css" href="/linhes/default/style.css">
-    <link rel="stylesheet" type="text/css" href="/linhes/default/header.css">
-    <link rel="stylesheet" type="text/css" href="/linhes/default/menus.css">
-    <link rel="stylesheet" type="text/css" href="/linhes/default/programming.css">
-
-    <link rel="stylesheet" type="text/css" href="/linhes/default/welcome.css">
-</head>
-
-<body>
-<div id="page_header" style="position:relative; text-align:center;">
-    <div id="logo_box">
-        <a id="LinHES_logo" href="/">
-        <img src="/header.png" alt="Tux with a Remote" class="body">
-        </a>
-    </div>
-</div>
-
-<table width="100%" border="0" cellspacing="2" cellpadding="0">
-<tr>
-    <td colspan="2" class="menu menu_border_t menu_border_b">
-        <table class="body" width="100%" border="0" cellspacing="2" cellpadding="2">
-            <td align="center">
-                <a href="http://linhes.org" <b>The Linux Home Entertainment System Release 7</b></a>
-            </td>
-        </table>
-    </td>
-</tr>
-</table>
-
-
-<script type="text/javascript">
-//<!--
-
-    var visible_module = 'media';
-    function show_module_info(module) {
-        if (visible_module == module)
-            return;
-    // Change the outline on the list item
-        $('module_'+ visible_module).removeClassName('selected');
-        $('module_'+ module).addClassName('selected');
-    // Show and hide the appropriate info boxes
-        $('info_' + visible_module).hide();
-        $('info_' + visible_module).addClassName('hidden');
-        $('info_' + module).show();
-        $('info_' + module).removeClassName('hidden');
-    // Keep track of what's visible now
-        visible_module = module;
-    }
-
-// -->
-</script>
-
-<div id="modules" class="clearfix">
-
-    <div id="module_names">
-    <ul>
-        <li id="module_media" class="selected" onmouseover="show_module_info('media')">Media</li>
-        <li id="module_status" onmouseover="show_module_info('status')">Status</li>
-        <li id="module_help" onmouseover="show_module_info('help')">Help</li>
-    </ul>
-    </div>
-
-    <div id="module_info">
-        <div id="info_media">
-            <ul>
-                <li><a href="/mythweb/">MythWeb</a> - MythWeb provides a frontend for scheduling and managing recordings on your MythBox from a web browser.<br></li>
-                <li><a href="/remote/index.html">MythTV Web Remote</a><br></li>
-<!-- not working right now                <li><a href="/fuppes.php" target="_blank">FUPPES</a> - UPnP Media Server. Install via the Service Menu.<br></li> -->
-                <li><a href="/mediaserv.php" target="_blank">Mediaserv</a> - On-demand transcoding server for videos. Mediaserv is designed to transcode video in a format playable on the Nokia Internet Tablets.  However it works well at transcoding and streaming to any device that will playback AVIs (think streaming to any browser!). By default, your TV recordings (pretty) and video directory are linked. If you want Mediaserv to stream contents from a network share: ln -s /path/to/share /myth/mediaserv/media/<br></li>
-<!-- not working right now                <li><a href="/mythweb/data/mp3player.html">Radio</a> - Music in MythMusic must be encoded as MP3s.<br></li> -->
-                <li><a href="/mythexport/setup.cgi">MythExport</a> - PERL daemon used to transcode records and provides an RSS feed.<br></li> 
-            </ul>
-        </div>
-        <div id="info_status" class="hidden">
-            <ul>
-                <li><a href="/rrd/index-rrd.html">RRDTool</a> - A system monitoring tool.</li>
-                <li><a href="/monitorix/">Monitorix</a> - A lightweight system monitoring tool.<br></li>
-                <li><a href="http://fah-web.stanford.edu/cgi-bin/main.py?qtype=teampage&amp;teamnum=50975">KnoppMyth Folding@home Team Status</a></li>
-                <li><a href="/foldingathome/">My Folding@home Status</a></li>
-            </ul>
-        </div>
-        <div id="info_help" class="hidden">
-            <ul>
-                <li><a href="http://www.mythtv.org/docs/">MythTV Documentation</a></li>
-                <li><a href="/mythtv-doc/keys.txt">MythTV Default Keybindings</a></li>
-                <li><a href="http://www.mythtv.org/support">MythTV Support</a></li>
-                <li><a href="http://www.schedulesdirect.org/">Schedules Direct</a> - Provides U.S./Canadian TV listing data.<br></li>
-                <li><a href="/linhes.html">LinHES</a> - Describes how "The Project Leader" setup multiple systems to form <b>Lin</b>ux <b>H</b>ome <b>E</b>ntertainment <b>S</b>ystem.<br></li>
-                <li><a href="http://forum.linhes.org">LinHES Forum</a></li>
-                <li><a href="http://linhes.org/wiki">LinHES Wiki</a></li>
-                <li><a href="http://linhes.org/projects/linhes/issues">LinHES Bug Tracker</a></li>
-            </ul>
-        </div>
-    </div>
-</body>
-</html>
-- 
cgit v0.12