From 388802c13f058c355dc60c2a0516d11d892e4447 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Tue, 21 Aug 2012 19:12:55 -0500
Subject: zip 3.0  rebuild

---
 abs/extra/zip/ChangeLog                |  5 ----
 abs/extra/zip/PKGBUILD                 | 44 +++++++++++++----------------
 abs/extra/zip/zip-3.0-build.patch      | 34 -----------------------
 abs/extra/zip/zip-3.0-exec-stack.patch | 20 -------------
 abs/extra/zip/zip-3.0-no-crypt.patch   | 51 ----------------------------------
 abs/extra/zip/zip-3.0-pic.patch        | 12 --------
 6 files changed, 20 insertions(+), 146 deletions(-)
 delete mode 100644 abs/extra/zip/ChangeLog
 delete mode 100644 abs/extra/zip/zip-3.0-build.patch
 delete mode 100644 abs/extra/zip/zip-3.0-exec-stack.patch
 delete mode 100644 abs/extra/zip/zip-3.0-no-crypt.patch
 delete mode 100644 abs/extra/zip/zip-3.0-pic.patch

diff --git a/abs/extra/zip/ChangeLog b/abs/extra/zip/ChangeLog
deleted file mode 100644
index 29ec4d1..0000000
--- a/abs/extra/zip/ChangeLog
+++ /dev/null
@@ -1,5 +0,0 @@
-
-2008-07-27  Douglas Soares de Andrade  <douglas@archlinux.org>
-	
-	* Updating for i686: 3.0
-
diff --git a/abs/extra/zip/PKGBUILD b/abs/extra/zip/PKGBUILD
index 30cec8b..dca1103 100644
--- a/abs/extra/zip/PKGBUILD
+++ b/abs/extra/zip/PKGBUILD
@@ -1,32 +1,28 @@
-# $Id: PKGBUILD 6705 2008-07-27 14:04:19Z douglas $
-# Maintainer: dorphell <dorphell@archlinux.org>
+# $Id: PKGBUILD 149604 2012-02-08 19:38:19Z pierre $
+# Maintainer:
+# Contributor: dorphell <dorphell@archlinux.org>
 
 pkgname=zip
 pkgver=3.0
-pkgrel=1
+_pkgver=30
+pkgrel=3
 pkgdesc="Creates PKZIP-compatible .zip files"
-arch=(i686 x86_64)
-url="http://www.info-zip.org/pub/infozip/Zip.html"
-depends=('glibc')
-makedepends=('unzip')
-source=(ftp://ftp.info-zip.org/pub/infozip/src/zip30.zip
-        ftp://ftp.info-zip.org/pub/infozip/src/zcrypt.zip
-	zip-3.0-build.patch	  zip-3.0-no-crypt.patch
-	zip-3.0-exec-stack.patch  zip-3.0-pic.patch
-	)
-
-
-md5sums=('e88492c8abd68fa9cfba72bc08757dba'
-         '0c969ba1661183b041a142945ed2710e')
+arch=('i686' 'x86_64')
+url="http://www.info-zip.org/Zip.html"
+license=('BSD')
+depends=('bzip2')
+options=('!makeflags')
+source=("ftp://ftp.info-zip.org/pub/infozip/src/${pkgname}${_pkgver}.zip")
+md5sums=('e88492c8abd68fa9cfba72bc08757dba')
 
 build() {
-   cd $startdir/src/${pkgname}30
-#   echo "A"| unzip ../zcrypt.zip
-   patch -p1 < $startdir/src/zip-3.0-build.patch	  
-   patch -p0 < $startdir/src/zip-3.0-no-crypt.patch || return 1
-  patch -p1 < $startdir/src/zip-3.0-exec-stack.patch  
-  patch -p0 < $startdir/src/zip-3.0-pic.patch
+   cd "${srcdir}/${pkgname}${_pkgver}"
+   make -f unix/Makefile LOCAL_ZIP="$CFLAGS" prefix=/usr generic_gcc
+}
 
-   make -f unix/Makefile LOCAL_ZIP="$CFLAGS" prefix=/usr generic_gcc || return 1
-   make -f unix/Makefile INSTALL=`which install` prefix=$startdir/pkg/usr install
+package() {
+   cd "${srcdir}/${pkgname}${_pkgver}"
+   make -f unix/Makefile INSTALL=/bin/install prefix=${pkgdir}/usr \
+     MANDIR=${pkgdir}/usr/share/man/man1 install
+   install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/$pkgname/LICENSE
 }
diff --git a/abs/extra/zip/zip-3.0-build.patch b/abs/extra/zip/zip-3.0-build.patch
deleted file mode 100644
index 880b49e..0000000
--- a/abs/extra/zip/zip-3.0-build.patch
+++ /dev/null
@@ -1,34 +0,0 @@
---- zip/unix/configure
-+++ zip/unix/configure
-@@ -18,7 +18,7 @@
- 
- CC=${1-cc}
- CFLAGS=${2-"-I. -DUNIX"}
--LFLAGS1=''
-+LFLAGS1="${LDFLAGS}"
- LFLAGS2=''
- LN="ln -s"
- 
-@@ -118,7 +118,7 @@ _EOF_
- fi
- 
- # optimization flags
--if test -n "${CFLAGS_OPT}"; then
-+if false; then
-   CFLAGS="${CFLAGS} ${CFLAGS_OPT}"
-   CFLAGS_BZ="${CFLAGS_BZ} ${CFLAGS_OPT}"
- fi
-@@ -220,13 +220,6 @@ fi
- echo Check for the C preprocessor
- # on SVR4, cc -E does not produce correct assembler files. Need /lib/cpp.
- CPP="${CC} -E"
--# solaris as(1) needs -P, maybe others as well ?
--[ -f /usr/ccs/lib/cpp ] && CPP="/usr/ccs/lib/cpp -P"
--[ -f /usr/lib/cpp ] && CPP=/usr/lib/cpp
--[ -f /lib/cpp ] && CPP=/lib/cpp
--[ -f /usr/bin/cpp ] && CPP=/usr/bin/cpp
--[ -f /xenix ] && CPP="${CC} -E"
--[ -f /lynx.os ] && CPP="${CC} -E"
- 
- echo "#include <stdio.h>" > conftest.c
- $CPP conftest.c >/dev/null 2>/dev/null || CPP="${CC} -E"
diff --git a/abs/extra/zip/zip-3.0-exec-stack.patch b/abs/extra/zip/zip-3.0-exec-stack.patch
deleted file mode 100644
index 2eb1acf..0000000
--- a/abs/extra/zip/zip-3.0-exec-stack.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- zip-2.31/crc_i386.S
-+++ zip-2.31/crc_i386.S
-@@ -238,3 +238,7 @@
- #endif /* i386 || _i386 || _I386 || __i386 */
- 
- #endif /* !USE_ZLIB && !CRC_TABLE_ONLY */
-+
-+#if defined __ELF__ && defined __linux__
-+.section .note.GNU-stack,"",@progbits
-+#endif
---- zip-2.31/match.S
-+++ zip-2.31/match.S
-@@ -405,3 +405,7 @@
- #endif /* i386 || _I386 || _i386 || __i386  */
- 
- #endif /* !USE_ZLIB */
-+
-+#if defined __ELF__ && defined __linux__
-+.section .note.GNU-stack,"",@progbits
-+#endif
diff --git a/abs/extra/zip/zip-3.0-no-crypt.patch b/abs/extra/zip/zip-3.0-no-crypt.patch
deleted file mode 100644
index 301c289..0000000
--- a/abs/extra/zip/zip-3.0-no-crypt.patch
+++ /dev/null
@@ -1,51 +0,0 @@
---- zip.c
-+++ zip.c
-@@ -3452,6 +3452,9 @@ char **argv;            /* command line tokens */
- 
-   /* Key not yet specified.  If needed, get/verify it now. */
-   if (key_needed) {
-+#if !CRYPT
-+    ZIPERR(ZE_PARMS, "encryption not supported");
-+#else /* CRYPT */
-     if ((key = malloc(IZ_PWLEN+1)) == NULL) {
-       ZIPERR(ZE_MEM, "was getting encryption password");
-     }
-@@ -3478,6 +3481,7 @@ char **argv;            /* command line tokens */
-     if (r) {
-       ZIPERR(ZE_PARMS, "password verification failed");
-     }
-+#endif
-   }
-   if (key) {
-     /* if -P "" could get here */
---- zipcloak.c
-+++ zipcloak.c
-@@ -744,6 +744,28 @@ struct option_struct far options[] = {
- 
- int main OF((void));
- 
-+void zipmessage_nl(a, nl)
-+ZCONST char *a;
-+int nl;
-+{
-+}
-+
-+void zipmessage(a, b)
-+ZCONST char *a, *b;
-+{
-+}
-+
-+int set_filetype(out_path)
-+  char *out_path;
-+{
-+}
-+
-+int rename_split(temp_name, out_path)
-+  char *temp_name;
-+  char *out_path;
-+{
-+}
-+
- void zipwarn(msg1, msg2)
- ZCONST char  *msg1, *msg2;
- {
diff --git a/abs/extra/zip/zip-3.0-pic.patch b/abs/extra/zip/zip-3.0-pic.patch
deleted file mode 100644
index d37e5ed..0000000
--- a/abs/extra/zip/zip-3.0-pic.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- unix/configure
-+++ unix/configure
-@@ -29,6 +29,9 @@
- echo Check if we can use asm code
- OBJA=""
- OCRCU8=""
-+piclib="$(echo | $CPP -dM $CFLAGS - | grep -i __pic__)"
-+echo "Checking if compiler wants to create pic code"
-+[ "$piclib" == "" ] && \
- if eval "$CPP match.S > _match.s 2>/dev/null"; then
-   if test ! -s _match.s || grep error < _match.s > /dev/null; then
-     :
-- 
cgit v0.12