From b9463e0085b6fbf110f0c71143eca3f5c7fa61e5 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Mon, 19 Aug 2013 14:26:25 -0500
Subject: snappy: initial inclusion. dep of chromium 28.

---
 abs/extra/snappy/PKGBUILD | 42 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 42 insertions(+)
 create mode 100644 abs/extra/snappy/PKGBUILD

diff --git a/abs/extra/snappy/PKGBUILD b/abs/extra/snappy/PKGBUILD
new file mode 100644
index 0000000..ef03f35
--- /dev/null
+++ b/abs/extra/snappy/PKGBUILD
@@ -0,0 +1,42 @@
+# $Id$
+# Maintainer: Dave Reisner <dreisner@archlinux.org>
+# Contributor: Antony Male <antony dot male at geemail dot com>>
+
+pkgname=snappy
+pkgver=1.1.0
+pkgrel=1
+pkgdesc='A fast compressor/decompressor library'
+arch=('i686' 'x86_64')
+url="http://code.google.com/p/snappy/"
+license=('BSD')
+depends=('glibc' 'gcc-libs')
+checkdepends=('zlib')
+options=('!libtool')
+source=("http://snappy.googlecode.com/files/$pkgname-$pkgver.tar.gz")
+md5sums=('c8f3ef29b5281e78f4946b2d739cea4f')
+
+build() {
+  cd "$pkgname-$pkgver"
+
+  # compile without assertions
+  CXXFLAGS+=\ -DNDEBUG
+
+  ./configure --prefix=/usr
+  make
+}
+
+check() {
+  # compile without assertions
+  CXXFLAGS+=\ -DNDEBUG
+
+  make -C "$pkgname-$pkgver" check
+}
+
+package() {
+  cd "$pkgname-$pkgver"
+
+  make DESTDIR="$pkgdir" install
+  install -m644 -D COPYING "$pkgdir/usr/share/licenses/snappy/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et:
-- 
cgit v0.12