From 736dbd2eadc1189248711c6ba4daab907708c772 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Sat, 29 Dec 2018 22:31:57 +0000
Subject: libdvdnav: update to 6.0.0. closes #1030

---
 abs/core/libdvdnav/PKGBUILD                       | 20 +++++++++-------
 abs/core/libdvdnav/fix-crash-describe_title.patch | 29 -----------------------
 2 files changed, 11 insertions(+), 38 deletions(-)
 delete mode 100644 abs/core/libdvdnav/fix-crash-describe_title.patch

diff --git a/abs/core/libdvdnav/PKGBUILD b/abs/core/libdvdnav/PKGBUILD
index 4bd01d5..d4bf282 100644
--- a/abs/core/libdvdnav/PKGBUILD
+++ b/abs/core/libdvdnav/PKGBUILD
@@ -1,25 +1,27 @@
-# $Id$
 # Maintainer: Jan de Groot <jgc@archlinux.org>
 # Contributor: Arjan <arjan@archlinux.org>
 # contributor Sarah Hay <sarahhay@mb.sympatico.ca>
 
 pkgname=libdvdnav
-pkgver=5.0.3
+pkgver=6.0.0
 pkgrel=1
 pkgdesc="The library for xine-dvdnav plugin."
-arch=('i686' 'x86_64')
+arch=('x86_64')
 license=('GPL')
-url="http://dvdnav.mplayerhq.hu/"
+url="https://www.videolan.org/developers/libdvdnav.html"
 depends=('libdvdread')
 makedepends=('git')
-source=(git+https://code.videolan.org/videolan/libdvdnav.git#tag=$pkgver
-        fix-crash-describe_title.patch)
-sha256sums=('SKIP'
-            '6a8e9c777dd9dbfa8a7f981796bd7a60412e3a5c7a8400253c567d956412c64b')
+_commit=dcb9109e45ccd304ec82a7c7bf46cca63620adf9  # tags/6.0.0^0
+source=("git+https://code.videolan.org/videolan/libdvdnav.git#commit=$_commit")
+sha256sums=('SKIP')
+
+pkgver() {
+  cd $pkgname
+  git describe --tags | sed -e 's/-/+/g'
+}
 
 prepare() {
   cd $pkgname
-  patch -Np1 -i ../fix-crash-describe_title.patch
   autoreconf -fi
 }
 
diff --git a/abs/core/libdvdnav/fix-crash-describe_title.patch b/abs/core/libdvdnav/fix-crash-describe_title.patch
deleted file mode 100644
index 1c07336..0000000
--- a/abs/core/libdvdnav/fix-crash-describe_title.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From 8a270d6dd40ac43c98c948fe9d10e5bcb4aa3d41 Mon Sep 17 00:00:00 2001
-From: Jean-Baptiste Kempf <jb@videolan.org>
-Date: Tue, 1 Sep 2015 16:00:59 +0200
-Subject: [PATCH] Fix crashes with some DVDs on describe_title
-
-This is a stop-over, but the actual issue is not fixed
----
- src/searching.c |    5 +++++
- 1 file changed, 5 insertions(+)
-
-diff --git a/src/searching.c b/src/searching.c
-index 70c0f85..f638b61 100644
---- a/src/searching.c
-+++ b/src/searching.c
-@@ -644,6 +644,11 @@ uint32_t dvdnav_describe_title_chapters(dvdnav_t *this, int32_t title, uint64_t
-   if(!tmp)
-     goto fail;
- 
-+  if(!ptt) {
-+      printerr("ptt NULL");
-+      goto fail;
-+  }
-+
-   length = 0;
-   for(i=0; i<parts; i++) {
-     uint32_t cellnr, endcellnr;
--- 
-1.7.10.4
-
-- 
cgit v0.12