From 8b08e5b127670b6d5fa7170477754fc3144cb309 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Thu, 30 Aug 2012 20:35:17 -0500
Subject: Merge remote-tracking branch 'origin/testing' into testing

# By Britney Fransen (4) and others
# Via Britney Fransen
* origin/testing:
  dvb-firmware: add xc5000c firmware. change xc5000 modprobe options. closes #844
  v4l-dvb: update to snapshot from 20120828. refs #844
  LinHES-system: update myth_status.py to work with tuners in error. closes #843
  curlftpfs: Initial Inclusion.
  linhes-scripts: minor changes to myth2mkv
  mythtv:Bumped to latest fixes. Added ./configure items to close #842.
  LinHES-config:7.4 rdt 9th anniversary release.

Conflicts:
	abs/core/LinHES-config/LinHES-release
	abs/core/LinHES-config/PKGBUILD
	abs/core/LinHES-system/PKGBUILD
	abs/core/mythtv/stable-0.25/mythtv/PKGBUILD
---
 abs/core/LinHES-system/myth_status.py       |  16 ++++++++-------
 abs/core/dvb-firmware/PKGBUILD              |   6 +++---
 abs/core/dvb-firmware/dvb-firmware.tar.bz2  | Bin 13819768 -> 13836324 bytes
 abs/core/dvb-firmware/xc5000.conf           |   4 +++-
 abs/core/v4l-dvb/PKGBUILD                   |   2 +-
 abs/extra/community/curlftpfs/PKGBUILD      |  30 ++++++++++++++++++++++++++++
 abs/extra/community/curlftpfs/ioerror.patch |  11 ++++++++++
 7 files changed, 57 insertions(+), 12 deletions(-)
 create mode 100644 abs/extra/community/curlftpfs/PKGBUILD
 create mode 100644 abs/extra/community/curlftpfs/ioerror.patch

diff --git a/abs/core/LinHES-system/myth_status.py b/abs/core/LinHES-system/myth_status.py
index 4637b90..b4f4375 100644
--- a/abs/core/LinHES-system/myth_status.py
+++ b/abs/core/LinHES-system/myth_status.py
@@ -60,13 +60,15 @@ for i in a:
     type = results[0][0]
     hostname = results[0][1]
     id = i
-    c=be.getCurrentRecording(i)
-    if c.title ==  None:
-        current_recording = "Idle"
-    else:
-        current_recording = "Recording %s" %c.title
-    print "    Tuner %s (%s) on %s : %s " %(id, type, hostname, current_recording)
-
+    try:
+        c=be.getCurrentRecording(i)
+        if c.title ==  None:
+            current_recording = "Idle"
+        else:
+            current_recording = "Recording %s" %c.title
+        print "    Tuner %s (%s) on %s : %s " %(id, type, hostname, current_recording)
+    except:
+        print "    Tuner %s (%s) on %s : %s " %(id, type, hostname, "Tuner Error")
 
 print ""
 print "Upcoming Recordings (Next %s scheduled):" %(num_upcoming)
diff --git a/abs/core/dvb-firmware/PKGBUILD b/abs/core/dvb-firmware/PKGBUILD
index bbe5031..a9fc3e3 100644
--- a/abs/core/dvb-firmware/PKGBUILD
+++ b/abs/core/dvb-firmware/PKGBUILD
@@ -3,7 +3,7 @@
 
 pkgname=dvb-firmware
 pkgver=1
-pkgrel=16
+pkgrel=17
 pkgdesc="Firmware for DVB cards"
 replaces=('hd3000firmware')
 arch=('i586' 'i686' 'x86_64')
@@ -17,5 +17,5 @@ build() {
   mkdir -p ${pkgdir}/etc/modprobe.d/
   install -D -m644 "${srcdir}/xc5000.conf" "${pkgdir}/etc/modprobe.d/"
 }
-md5sums=('32e19e3f9f849e667c6f7db1186180b9'
-         'e3e7c5da698fb79aee7a135bdb9b7c5c')
+md5sums=('2307b2e9ce2da591d64ed611b79ecf17'
+         '08c7619f37757f0d6191866701212575')
diff --git a/abs/core/dvb-firmware/dvb-firmware.tar.bz2 b/abs/core/dvb-firmware/dvb-firmware.tar.bz2
index e5b0d18..57019f5 100644
Binary files a/abs/core/dvb-firmware/dvb-firmware.tar.bz2 and b/abs/core/dvb-firmware/dvb-firmware.tar.bz2 differ
diff --git a/abs/core/dvb-firmware/xc5000.conf b/abs/core/dvb-firmware/xc5000.conf
index b1cf373..93b3ab4 100644
--- a/abs/core/dvb-firmware/xc5000.conf
+++ b/abs/core/dvb-firmware/xc5000.conf
@@ -1,4 +1,6 @@
 #   xc5000
 #   Disable power cycling and firmware reloads
 #
-options xc5000 no_poweroff=1
+#   When v4l-dvb is installed no_poweroff=1 is no longer needed.
+#
+#options xc5000 no_poweroff=1
diff --git a/abs/core/v4l-dvb/PKGBUILD b/abs/core/v4l-dvb/PKGBUILD
index 36e4609..ac150bb 100644
--- a/abs/core/v4l-dvb/PKGBUILD
+++ b/abs/core/v4l-dvb/PKGBUILD
@@ -2,7 +2,7 @@
 
 pkgname=v4l-dvb
 _kernver=`uname -r`
-pkgver=20120407
+pkgver=20120828
 pkgrel=1
 pkgdesc="V4L-DVB device drivers (newer than those included in kernel26)"
 arch=('i686' 'x86_64')
diff --git a/abs/extra/community/curlftpfs/PKGBUILD b/abs/extra/community/curlftpfs/PKGBUILD
new file mode 100644
index 0000000..242e28f
--- /dev/null
+++ b/abs/extra/community/curlftpfs/PKGBUILD
@@ -0,0 +1,30 @@
+# $Id$
+# Maintainer: Chris Brannon <cmbrannon79@gmail.com>
+# Contributor: Allan McRae <mcrae_allan@hotmail.com>
+# Contributor: Philip Nilsson <leffeman@gmail.com>
+
+pkgname=curlftpfs
+pkgver=0.9.2
+pkgrel=4
+pkgdesc="A filesystem for acessing FTP hosts based on FUSE and libcurl."
+url="http://curlftpfs.sourceforge.net/"
+license=('GPL')
+depends=('curl>=7.15.4' 'fuse' 'glib2')
+makedepends=('pkgconfig>=0.9.0')
+arch=('i686' 'x86_64')
+source=(http://downloads.sourceforge.net/sourceforge/curlftpfs/$pkgname-$pkgver.tar.gz
+        ioerror.patch)
+md5sums=('b452123f755114cd4461d56c648d9f12'
+         '7a8db686293463ba3148c7032871c883')
+
+build() {
+  cd "$srcdir/$pkgname-$pkgver"
+  patch -p1 < "$srcdir/ioerror.patch"
+  ./configure --prefix=/usr
+  make
+}
+
+package() {
+  cd "$srcdir/$pkgname-$pkgver"
+  make DESTDIR="$pkgdir" install
+}
diff --git a/abs/extra/community/curlftpfs/ioerror.patch b/abs/extra/community/curlftpfs/ioerror.patch
new file mode 100644
index 0000000..6ca1afb
--- /dev/null
+++ b/abs/extra/community/curlftpfs/ioerror.patch
@@ -0,0 +1,11 @@
+--- curlftpfs-0.9.2.orig/ftpfs.c	2008-04-30 03:05:47.000000000 +0400
++++ curlftpfs-0.9.2.orig/ftpfs.c	2011-01-20 20:33:38.000000000 +0300
+@@ -503,7 +503,7 @@ static void *ftpfs_write_thread(void *da
+   
+   curl_easy_setopt_or_die(fh->write_conn, CURLOPT_URL, fh->full_path);
+   curl_easy_setopt_or_die(fh->write_conn, CURLOPT_UPLOAD, 1);
+-  curl_easy_setopt_or_die(fh->write_conn, CURLOPT_INFILESIZE, -1);
++  curl_easy_setopt_or_die(fh->write_conn, CURLOPT_INFILESIZE, (curl_off_t)-1);
+   curl_easy_setopt_or_die(fh->write_conn, CURLOPT_READFUNCTION, write_data_bg);
+   curl_easy_setopt_or_die(fh->write_conn, CURLOPT_READDATA, fh);
+   curl_easy_setopt_or_die(fh->write_conn, CURLOPT_LOW_SPEED_LIMIT, 1);
-- 
cgit v0.12