From 338a478507e9c1c535fb149b04cc81000627c340 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sat, 27 Mar 2010 22:37:15 -0500
Subject: runit-script: add logic for using SiliconDust_HDHR as receiver

For now this option will cause separate blasters/transmitters to stop working.

refs #622
---
 abs/core-testing/runit-scripts/PKGBUILD                        | 2 +-
 abs/core-testing/runit-scripts/runitscripts/services/lircd/run | 7 +++++++
 2 files changed, 8 insertions(+), 1 deletion(-)

diff --git a/abs/core-testing/runit-scripts/PKGBUILD b/abs/core-testing/runit-scripts/PKGBUILD
index c391b0c..a8087bd 100755
--- a/abs/core-testing/runit-scripts/PKGBUILD
+++ b/abs/core-testing/runit-scripts/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=runit-scripts
 pkgver=1.8.0
-pkgrel=116
+pkgrel=117
 pkgdesc="collection of startup scripts for runit"
 url="http://smarden.org/runit/"
 license="BSD"
diff --git a/abs/core-testing/runit-scripts/runitscripts/services/lircd/run b/abs/core-testing/runit-scripts/runitscripts/services/lircd/run
index 014563c..3ff8af3 100755
--- a/abs/core-testing/runit-scripts/runitscripts/services/lircd/run
+++ b/abs/core-testing/runit-scripts/runitscripts/services/lircd/run
@@ -96,6 +96,13 @@ else
         printhl "       Using iguanaIR usb"
         #echo $CMD
         $CMD >>$LOG 2>>$LOG
+
+    elif [ x$ReceiverType = "xSiliconDust_HDHR" ]
+    then
+        # if using the SiliconDust_HDHR as an I/R Receiver
+        printhl "   Using SiliconDust on port 5000"
+        CMD="/usr/sbin/lircd -H udp -d 5000 -n"
+        exec $CMD >>$LOG 2>>$LOG
     else
         LASTCMD=""
 
-- 
cgit v0.12