From 98169e32bb1ceb02382a0eb23e9444a28d51c1bc Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sun, 21 Mar 2010 14:58:57 -0500
Subject: mythtv: modify pretty script to check for mythlink or mythrename

closes 637

Note only made the change to pretty, did not rebuild pkgs
---
 abs/core-testing/mythtv/stable-0.22/mythtv/PKGBUILD |  9 +++++++--
 abs/core-testing/mythtv/stable-0.22/mythtv/pretty   | 11 ++++++++++-
 abs/core-testing/mythtv/trunk/mythtv/PKGBUILD       |  5 +++++
 abs/core-testing/mythtv/trunk/mythtv/pretty         | 11 ++++++++++-
 4 files changed, 32 insertions(+), 4 deletions(-)

diff --git a/abs/core-testing/mythtv/stable-0.22/mythtv/PKGBUILD b/abs/core-testing/mythtv/stable-0.22/mythtv/PKGBUILD
index 87dbbb5..4718d8d 100755
--- a/abs/core-testing/mythtv/stable-0.22/mythtv/PKGBUILD
+++ b/abs/core-testing/mythtv/stable-0.22/mythtv/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=mythtv
 pkgver=0.22
-pkgrel=22012
+pkgrel=22013
 pkgdesc="A personal video recorder for Linux"
 url="http://www.mythtv.org"
 license="GPL"
@@ -100,4 +100,9 @@ build() {
 	mkdir -p $startdir/pkg/etc/cron.hourly/
 	install -m0755 $startdir/src/pretty $startdir/pkg/etc/cron.hourly/
 }
-
+md5sums=('7ef6de58240e7aad389a0b13d91b1cf6'
+         '2babd4b8e146a7538d18dcd55695b0be'
+         'aa50bfa75ceceb0bdd5c1e4508690693'
+         'f735805a80b0d1180dee01f9df1b7004'
+         'f407d6af23e74a49540755420f84fa58'
+         'f944c51c40208fdb3d8e3dd3d8c60bf3')
diff --git a/abs/core-testing/mythtv/stable-0.22/mythtv/pretty b/abs/core-testing/mythtv/stable-0.22/mythtv/pretty
index 1cfc57b..8b0e051 100755
--- a/abs/core-testing/mythtv/stable-0.22/mythtv/pretty
+++ b/abs/core-testing/mythtv/stable-0.22/mythtv/pretty
@@ -1,2 +1,11 @@
 #!/bin/bash
-su - mythtv -c "perl /usr/share/mythtv/contrib/user_jobs/mythrename.pl --link /myth/pretty"
+#!/bin/bash
+if [ -f /usr/share/mythtv/contrib/user_jobs/mythlink.pl ]
+then
+        su - mythtv -c "perl /usr/share/mythtv/contrib/user_jobs/mythlink.pl --link /myth/pretty"
+elif [ -f /usr/share/mythtv/contrib/user_jobs/mythrename.pl ]
+then
+        su - mythtv -c "perl /usr/share/mythtv/contrib/user_jobs/mythrename.pl --link /myth/pretty"a
+fi
+
+
diff --git a/abs/core-testing/mythtv/trunk/mythtv/PKGBUILD b/abs/core-testing/mythtv/trunk/mythtv/PKGBUILD
index 2a6f2a4..8d27f31 100755
--- a/abs/core-testing/mythtv/trunk/mythtv/PKGBUILD
+++ b/abs/core-testing/mythtv/trunk/mythtv/PKGBUILD
@@ -89,3 +89,8 @@ build() {
 	install -m0755 $startdir/src/pretty $startdir/pkg/etc/cron.hourly/
 }
 
+md5sums=('7ef6de58240e7aad389a0b13d91b1cf6'
+         '2babd4b8e146a7538d18dcd55695b0be'
+         'f735805a80b0d1180dee01f9df1b7004'
+         'f407d6af23e74a49540755420f84fa58'
+         'f944c51c40208fdb3d8e3dd3d8c60bf3')
diff --git a/abs/core-testing/mythtv/trunk/mythtv/pretty b/abs/core-testing/mythtv/trunk/mythtv/pretty
index 1cfc57b..8b0e051 100755
--- a/abs/core-testing/mythtv/trunk/mythtv/pretty
+++ b/abs/core-testing/mythtv/trunk/mythtv/pretty
@@ -1,2 +1,11 @@
 #!/bin/bash
-su - mythtv -c "perl /usr/share/mythtv/contrib/user_jobs/mythrename.pl --link /myth/pretty"
+#!/bin/bash
+if [ -f /usr/share/mythtv/contrib/user_jobs/mythlink.pl ]
+then
+        su - mythtv -c "perl /usr/share/mythtv/contrib/user_jobs/mythlink.pl --link /myth/pretty"
+elif [ -f /usr/share/mythtv/contrib/user_jobs/mythrename.pl ]
+then
+        su - mythtv -c "perl /usr/share/mythtv/contrib/user_jobs/mythrename.pl --link /myth/pretty"a
+fi
+
+
-- 
cgit v0.12