From 18d5b0d34e3319ff989588a36165b95d3d45683c Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Thu, 4 Aug 2011 17:10:40 -0500
Subject: mplayer: Bump to latest. refs #647

---
 abs/core/mplayer/PKGBUILD        | 107 +++++++++++++++++++++++----------------
 abs/core/mplayer/__changlog      |   1 +
 abs/core/mplayer/mplayer.desktop |   2 +-
 abs/core/mplayer/mplayer.install |  11 ++++
 4 files changed, 75 insertions(+), 46 deletions(-)
 create mode 100644 abs/core/mplayer/__changlog
 create mode 100644 abs/core/mplayer/mplayer.install

diff --git a/abs/core/mplayer/PKGBUILD b/abs/core/mplayer/PKGBUILD
index 945a798..27cd4fb 100644
--- a/abs/core/mplayer/PKGBUILD
+++ b/abs/core/mplayer/PKGBUILD
@@ -1,55 +1,72 @@
-# $Id: PKGBUILD 97113 2010-10-26 14:11:03Z ibiru $
+# $Id$
 # Maintainer : Ionut Biru <ibiru@archlinux.org>
 # Contributor: Hugo Doria <hugo@archlinux.org>
 
-pkgname=mplayer
-pkgver=32492
+pkgbase=mplayer
+pkgname=('mplayer' 'mencoder')
+pkgver=33805
 pkgrel=2
-pkgdesc="A movie player for linux"
 arch=('i686' 'x86_64')
-depends=('libxxf86dga' 'libxxf86vm' 'libmad' 'cdparanoia' 'libxinerama' 'sdl' 'lame' 'libtheora' 'xvidcore' 'libmng' 'libxss'
-         'libgl' 'smbclient' 'aalib' 'jack' 'libcaca' 'x264' 'faac' 'lirc-utils' 'ttf-dejavu' 'libxvmc' 'enca' 'libvdpau>=0.4'
-         'opencore-amr' 'libdca' 'a52dec' 'schroedinger' 'libvpx')
+makedepends=('libxxf86dga' 'libxxf86vm' 'libmad' 'cdparanoia' 'libxinerama' 'sdl' 'lame' 'libtheora' 'xvidcore' 'libmng' 'libxss' 'libgl' 'smbclient'
+'aalib' 'jack' 'libcaca' 'x264' 'faac' 'faad2' 'lirc-utils'  'libxvmc' 'enca' 'libvdpau' 'opencore-amr' 'libdca' 'a52dec' 'schroedinger' 'libvpx'
+'fribidi' 'unzip' 'mesa' 'live-media' 'yasm' 'git' 'fontconfig' 'mpg123' 'ladspa' 'libass')
 license=('GPL')
 url="http://www.mplayerhq.hu/"
-makedepends=('unzip' 'mesa' 'live-media>=2010.01.13' 'yasm')
-backup=('etc/mplayer/codecs.conf' 'etc/mplayer/input.conf')
-source=(ftp://ftp.archlinux.org/other/${pkgname}/${pkgname}-${pkgver}.tar.xz mplayer.desktop mplayer.png)
-md5sums=('01beb068608d3977fbb84b0b28935cee'
-         '647b9f4ab5284a7fef3f84f992214e77'
-         'd00874ccc644b7f43d6ef1c942fcef28')
+options=(!buildflags !emptydirs)
+source=(ftp://ftp.archlinux.org/other/${pkgname}/${pkgname}-${pkgver}.tar.xz mplayer.desktop)
+md5sums=('512a0309ba5979a41ae93b740f4592f4'
+         'c0d6ef795cf6de48e3b87ff7c23f0319')
 
 build() {
-  # Custom CFLAGS break the mplayer build
-  unset CFLAGS LDFLAGS
-
-  cd ${srcdir}/${pkgname}
-
-  ./configure --prefix=/usr \
-      --enable-runtime-cpudetection \
-      --disable-gui \
-      --disable-arts \
-      --disable-liblzo \
-      --disable-speex \
-      --disable-openal \
-      --disable-fribidi \
-      --disable-libdv \
-      --disable-musepack \
-      --disable-esd \
-      --disable-mga \
-      --enable-xvmc \
-      --language=all \
-      --confdir=/etc/mplayer
-
-  [ "$CARCH" = "i686" ] &&  sed 's|-march=i486|-march=i686|g' -i config.mak
-
-  make
-  make -j1 DESTDIR=${pkgdir} install
-  install -Dm644 etc/{codecs.conf,input.conf,example.conf} ${pkgdir}/etc/mplayer/
-  install -dm755 ${pkgdir}/usr/share/mplayer/
-  ln -s /usr/share/fonts/TTF/DejaVuSans.ttf ${pkgdir}/usr/share/mplayer/subfont.ttf
-  rm -rf ${pkgdir}/usr/share/mplayer/font
-  #desktop file  FS#14770
-  install -Dm644 ${srcdir}/mplayer.desktop ${pkgdir}/usr/share/applications/mplayer.desktop
-  install -Dm644 ${srcdir}/mplayer.png ${pkgdir}/usr/share/pixmaps/mplayer.png
+    cd ${srcdir}/${pkgname}
+
+    ./configure --prefix=/usr \
+        --enable-runtime-cpudetection \
+        --disable-gui \
+        --disable-arts \
+        --disable-liblzo \
+        --disable-speex \
+        --disable-openal \
+        --disable-libdv \
+        --disable-musepack \
+        --disable-esd \
+        --disable-mga \
+        --disable-ass-internal \
+        --disable-pulse \
+        --enable-xvmc \
+        --language=all \
+        --confdir=/etc/mplayer
+    [ "$CARCH" = "i686" ] &&  sed 's|-march=i486|-march=i686|g' -i config.mak
+
+    make
+}
+
+package_mplayer() {
+    pkgdesc="A movie player for linux"
+    install=mplayer.install
+    backup=('etc/mplayer/codecs.conf' 'etc/mplayer/input.conf')
+    depends=('desktop-file-utils' 'ttf-dejavu' 'enca' 'libxss' 'a52dec' 'libvpx' 'lirc-utils' 'x264' 'libmng' 'libdca' 'aalib' 'lame' 'fontconfig'  'libgl'
+    'libxinerama' 'libvdpau' 'smbclient' 'xvidcore' 'opencore-amr' 'jack' 'cdparanoia' 'libmad' 'sdl' 'libtheora' 'libcaca' 'libxxf86dga' 'fribidi'
+    'libjpeg' 'faac' 'faad2' 'libxvmc' 'schroedinger' 'mpg123' 'libass')
+
+    cd ${srcdir}/${pkgbase}
+
+    make DESTDIR=${pkgdir} install-mplayer  install-mplayer-man
+    install -Dm644 etc/{codecs.conf,input.conf,example.conf} ${pkgdir}/etc/mplayer/
+    install -dm755 ${pkgdir}/usr/share/mplayer/
+    ln -s /usr/share/fonts/TTF/DejaVuSans.ttf ${pkgdir}/usr/share/mplayer/subfont.ttf
+    rm -rf ${pkgdir}/usr/share/mplayer/font
+    #desktop file  FS#14770
+    install -Dm644 ${srcdir}/mplayer.desktop ${pkgdir}/usr/share/applications/mplayer.desktop
+    install -Dm644 etc/mplayer.png ${pkgdir}/usr/share/pixmaps/mplayer.png
+}
+
+package_mencoder() {
+    pkgdesc="Free command line video decoding, encoding and filtering tool"
+    depends=('enca' 'a52dec' 'libvpx' 'x264' 'libmng' 'libdca' 'bzip2' 'lame' 'alsa-lib' 'fontconfig' 'giflib' 'libpng' 'smbclient' 'xvidcore' 'opencore-amr' 'cdparanoia'
+    'libmad' 'libtheora' 'fribidi' 'libjpeg' 'faac' 'faad2' 'schroedinger' 'mpg123' 'libass')
+
+    cd ${srcdir}/${pkgbase}
+    make DESTDIR=${pkgdir} install-mencoder install-mencoder-man
+    find $pkgdir/usr/share/man -name 'mplayer.1' -exec bash -c 'mv "$1" "${1/mplayer/mencoder}"' _ {} \;
 }
diff --git a/abs/core/mplayer/__changlog b/abs/core/mplayer/__changlog
new file mode 100644
index 0000000..fdf7dab
--- /dev/null
+++ b/abs/core/mplayer/__changlog
@@ -0,0 +1 @@
+-disable pulse and remove libpulse deps in PKGBUILD
diff --git a/abs/core/mplayer/mplayer.desktop b/abs/core/mplayer/mplayer.desktop
index e3229d0..07acea1 100644
--- a/abs/core/mplayer/mplayer.desktop
+++ b/abs/core/mplayer/mplayer.desktop
@@ -14,7 +14,7 @@ Comment[zh]=多媒体播放器
 Comment[pl]=Odtwarzaj filmy i muzykę
 Icon=mplayer
 TryExec=mplayer
-Exec=mplayer -really-quiet %F
+Exec=mplayer %F
 Terminal=false
 NoDisplay=true
 Categories=GTK;AudioVideo;Audio;Video;Player;TV;
diff --git a/abs/core/mplayer/mplayer.install b/abs/core/mplayer/mplayer.install
new file mode 100644
index 0000000..660593c
--- /dev/null
+++ b/abs/core/mplayer/mplayer.install
@@ -0,0 +1,11 @@
+post_install() {
+    update-desktop-database -q
+}
+
+post_upgrade() {
+    post_install
+}
+
+post_remove() {
+    post_install
+}
-- 
cgit v0.12