From 73d83d38ae62c60b22d72f241f02a916daaf1d6c Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Thu, 15 Dec 2016 20:27:34 +0000
Subject: autofs: update to 5.1.2

---
 abs/extra/autofs/PKGBUILD    | 31 +++++++++++++++++--------------
 abs/extra/autofs/__changelog |  1 +
 2 files changed, 18 insertions(+), 14 deletions(-)
 create mode 100644 abs/extra/autofs/__changelog

diff --git a/abs/extra/autofs/PKGBUILD b/abs/extra/autofs/PKGBUILD
index 0618dae..ce58b2e 100644
--- a/abs/extra/autofs/PKGBUILD
+++ b/abs/extra/autofs/PKGBUILD
@@ -1,28 +1,34 @@
-# $Id: PKGBUILD 103218 2013-12-30 14:30:57Z lfleischer $
-# Maintainer: Lukas Fleischer <archlinux at cryptocrack dot de>
+# Maintainer: Lukas Fleischer <lfleischer@archlinux.org>
 # Contributor: Andrea Scarpino <andrea@archlinux.org>
 # Contributor: Dale Blount <dale@archlinux.org>
 # Contributor: Manolis Tzanidakis
 
 pkgname=autofs
-pkgver=5.0.8
+pkgver=5.1.2
 pkgrel=1
 pkgdesc='A kernel-based automounter for Linux.'
 arch=('i686' 'x86_64')
-url='http://freshmeat.net/projects/autofs'
+url='https://www.kernel.org/pub/linux/daemons/autofs/'
 license=('GPL2')
 depends=('libxml2')
 makedepends=('libldap' 'krb5' 'kmod')
 optdepends=('krb5: for LDAP support')
-backup=('etc/default/autofs'
-        'etc/autofs/auto.master'
-        'etc/autofs/auto.misc')
+backup=('etc/autofs/auto.master'
+        'etc/autofs/auto.misc'
+        'etc/autofs/auto.net'
+        'etc/autofs/auto.smb'
+        'etc/autofs/autofs.conf'
+        'etc/autofs/autofs_ldap_auth.conf'
+        'etc/default/autofs')
 options=(!makeflags)
-source=("http://www.kernel.org/pub/linux/daemons/${pkgname}/v5/${pkgname}-${pkgver}.tar.xz")
-sha256sums=('32c41fb4e3439f18400468e84dc82fbbd4b14156bef6b9a7f09196ecd9299d52')
+source=("https://www.kernel.org/pub/linux/daemons/${pkgname}/v5/${pkgname}-${pkgver}.tar."{xz,sign})
+sha256sums=('88b7de39088aead983e02072a7b753d5ee52ce419c8913f7a3d4ff5521313f0c'
+            'SKIP')
+validpgpkeys=('CD0A6E3CBB6768800B0736A8E7677380F54FD8A9') # Ian Kent
 
 prepare() {
   cd "${srcdir}/${pkgname}-${pkgver}"
+
   sed -i -e 's|/etc/auto.misc|/etc/autofs/auto.misc|' \
          -e 's|/etc/auto.master.d|/etc/autofs/auto.master.d|' samples/auto.master
 }
@@ -30,9 +36,8 @@ prepare() {
 build() {
   cd "${srcdir}/${pkgname}-${pkgver}"
 
-  ./configure --prefix=/usr --sysconfdir=/etc/autofs --sbindir=/usr/bin \
-    --with-mapdir=/etc/autofs --without-hesiod \
-    --enable-ignore-busy --with-systemd
+  ./configure --prefix=/usr --sysconfdir=/etc/autofs --sbindir=/usr/bin --with-mapdir=/etc/autofs \
+    --without-hesiod --enable-ignore-busy --with-systemd
   make
 }
 
@@ -43,5 +48,3 @@ package() {
   rm -r "$pkgdir/run"
   install -dm755 "$pkgdir/etc/autofs/auto.master.d"
 }
-
-# vim:set ts=2 sw=2 et:
diff --git a/abs/extra/autofs/__changelog b/abs/extra/autofs/__changelog
new file mode 100644
index 0000000..e37323f
--- /dev/null
+++ b/abs/extra/autofs/__changelog
@@ -0,0 +1 @@
+PKGBUILD: remove sssd dep and opt dep
-- 
cgit v0.12