From d4ee25271f6b1e271a3487f3c2273aae9b200c61 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Thu, 2 Dec 2010 21:02:35 +0000
Subject: individual xorg utils

---
 abs/core/xorg-x11perf/PKGBUILD               | 23 +++++++++
 abs/core/xorg-xcursorgen/PKGBUILD            | 23 +++++++++
 abs/core/xorg-xcursorgen/xorg-xkill/PKGBUILD | 23 +++++++++
 abs/core/xorg-xpr/PKGBUILD                   | 26 ++++++++++
 abs/core/xorg-xpr/copyright.patch            | 75 ++++++++++++++++++++++++++++
 abs/core/xorg-xwd/PKGBUILD                   | 23 +++++++++
 abs/core/xorg-xwud/PKGBUILD                  | 23 +++++++++
 7 files changed, 216 insertions(+)
 create mode 100644 abs/core/xorg-x11perf/PKGBUILD
 create mode 100644 abs/core/xorg-xcursorgen/PKGBUILD
 create mode 100644 abs/core/xorg-xcursorgen/xorg-xkill/PKGBUILD
 create mode 100644 abs/core/xorg-xpr/PKGBUILD
 create mode 100644 abs/core/xorg-xpr/copyright.patch
 create mode 100644 abs/core/xorg-xwd/PKGBUILD
 create mode 100644 abs/core/xorg-xwud/PKGBUILD

diff --git a/abs/core/xorg-x11perf/PKGBUILD b/abs/core/xorg-x11perf/PKGBUILD
new file mode 100644
index 0000000..8f5d144
--- /dev/null
+++ b/abs/core/xorg-x11perf/PKGBUILD
@@ -0,0 +1,23 @@
+# $Id: $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+
+pkgname=xorg-x11perf
+pkgver=1.5.2
+pkgrel=1
+pkgdesc="Simple X server performance benchmarker"
+arch=(i686 x86_64)
+url="http://xorg.freedesktop.org/"
+license=('custom')
+depends=('libx11' 'libxmu' 'libxrender' 'libxft' 'libxext')
+makedepends=('xorg-util-macros')
+source=(http://xorg.freedesktop.org/archive/individual/app/x11perf-${pkgver}.tar.bz2)
+sha1sums=('ca693d23cd343df51baac76e693e769ce5ef6a30')
+
+build() {
+  cd "${srcdir}/x11perf-${pkgver}"
+  ./configure --prefix=/usr
+  make
+  make DESTDIR="${pkgdir}" install
+  install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+  install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"
+}
diff --git a/abs/core/xorg-xcursorgen/PKGBUILD b/abs/core/xorg-xcursorgen/PKGBUILD
new file mode 100644
index 0000000..c2a5ba5
--- /dev/null
+++ b/abs/core/xorg-xcursorgen/PKGBUILD
@@ -0,0 +1,23 @@
+# $Id: $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+
+pkgname=xorg-xcursorgen
+pkgver=1.0.4
+pkgrel=1
+pkgdesc="Create an X cursor file from PNG images"
+arch=(i686 x86_64)
+url="http://xorg.freedesktop.org/"
+license=('custom')
+depends=('libx11' 'libxcursor' 'libpng')
+makedepends=('xorg-util-macros')
+source=(http://xorg.freedesktop.org/archive/individual/app/xcursorgen-${pkgver}.tar.bz2)
+sha1sums=('244c180aae8cc07175b93f314d5bbbf24171658a')
+
+build() {
+  cd "${srcdir}/xcursorgen-${pkgver}"
+  ./configure --prefix=/usr
+  make
+  make DESTDIR="${pkgdir}" install
+  install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+  install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"
+}
diff --git a/abs/core/xorg-xcursorgen/xorg-xkill/PKGBUILD b/abs/core/xorg-xcursorgen/xorg-xkill/PKGBUILD
new file mode 100644
index 0000000..10f354d
--- /dev/null
+++ b/abs/core/xorg-xcursorgen/xorg-xkill/PKGBUILD
@@ -0,0 +1,23 @@
+# $Id: $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+
+pkgname=xorg-xkill
+pkgver=1.0.3
+pkgrel=1
+pkgdesc="Kill a client by its X resource"
+arch=(i686 x86_64)
+url="http://xorg.freedesktop.org/"
+license=('custom')
+depends=('libx11' 'libxmu')
+makedepends=('xorg-util-macros')
+source=(http://xorg.freedesktop.org/archive/individual/app/xkill-${pkgver}.tar.bz2)
+sha1sums=('bab7b9c7f3bc053d743eb339cf5fa496bace57e5')
+
+build() {
+  cd "${srcdir}/xkill-${pkgver}"
+  ./configure --prefix=/usr
+  make
+  make DESTDIR="${pkgdir}" install
+  install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+  install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"
+}
diff --git a/abs/core/xorg-xpr/PKGBUILD b/abs/core/xorg-xpr/PKGBUILD
new file mode 100644
index 0000000..63a7b59
--- /dev/null
+++ b/abs/core/xorg-xpr/PKGBUILD
@@ -0,0 +1,26 @@
+# $Id: $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+
+pkgname=xorg-xpr
+pkgver=1.0.3
+pkgrel=1
+pkgdesc="Print an X window dump from xwd"
+arch=(i686 x86_64)
+url="http://xorg.freedesktop.org/"
+license=('custom')
+depends=('libx11' 'libxmu')
+makedepends=('xorg-util-macros')
+source=(http://xorg.freedesktop.org/archive/individual/app/xpr-${pkgver}.tar.bz2
+        copyright.patch)
+sha1sums=('9dbd0ff136b612285e00d92d0c7675a4207b1c4a'
+          'd2649781330400b83cf3553d9cfd6e02dd93a2bd')
+
+build() {
+  cd "${srcdir}/xpr-${pkgver}"
+  patch -Np1 -i "${srcdir}/copyright.patch"
+  ./configure --prefix=/usr
+  make
+  make DESTDIR="${pkgdir}" install
+  install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+  install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"
+}
diff --git a/abs/core/xorg-xpr/copyright.patch b/abs/core/xorg-xpr/copyright.patch
new file mode 100644
index 0000000..18e7182
--- /dev/null
+++ b/abs/core/xorg-xpr/copyright.patch
@@ -0,0 +1,75 @@
+From 11569289123fb178e23fd1aa284e9fa10e6c1e8c Mon Sep 17 00:00:00 2001
+From: Alan Coopersmith <alan.coopersmith@oracle.com>
+Date: Fri, 06 Aug 2010 22:09:48 +0000
+Subject: Fill in COPYING file with copyright notices from source code
+
+Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
+---
+diff --git a/COPYING b/COPYING
+index 7f33cbf..0f9d8e0 100644
+--- a/COPYING
++++ b/COPYING
+@@ -1,12 +1,53 @@
+-This is a stub file.  This package has not yet had its complete licensing
+-information compiled.  Please see the individual source files for details on
+-your rights to use and modify this software.
+ 
+-Please submit updated COPYING files to the Xorg bugzilla:
++Copyright (c) 1985, 1988  X Consortium
+ 
+-https://bugs.freedesktop.org/enter_bug.cgi?product=xorg
++Permission is hereby granted, free of charge, to any person obtaining
++a copy of this software and associated documentation files (the
++"Software"), to deal in the Software without restriction, including
++without limitation the rights to use, copy, modify, merge, publish,
++distribute, sublicense, and/or sell copies of the Software, and to
++permit persons to whom the Software is furnished to do so, subject to
++the following conditions:
+ 
+-All licensing questions regarding this software should be directed at the
+-Xorg mailing list:
++The above copyright notice and this permission notice shall be included
++in all copies or substantial portions of the Software.
+ 
+-http://lists.freedesktop.org/mailman/listinfo/xorg
++THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
++OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
++MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
++IN NO EVENT SHALL THE X CONSORTIUM BE LIABLE FOR ANY CLAIM, DAMAGES OR
++OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
++ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
++OTHER DEALINGS IN THE SOFTWARE.
++
++Except as contained in this notice, the name of the X Consortium shall
++not be used in advertising or otherwise to promote the sale, use or
++other dealings in this Software without prior written authorization
++from the X Consortium.
++
++Copyright 1986 by Marvin Solomon and the University of Wisconsin
++
++Permission to use, copy, modify, and distribute this
++software and its documentation for any purpose and without
++fee is hereby granted, provided that the above copyright
++notice appear in all copies and that both that copyright
++notice and this permission notice appear in supporting
++documentation, and that the names of Marvin Solomon and
++the University of Wisconsin not be used in
++advertising or publicity pertaining to distribution of the
++software without specific, written prior permission.
++Neither Marvin Solomon nor the University of Wisconsin
++makes any representations about the suitability of
++this software for any purpose.  It is provided "as is"
++without express or implied warranty.
++
++Copyright (c) 1988 by Hewlett-Packard Company
++
++Permission to use, copy, modify, and distribute this software
++and its documentation for any purpose and without fee is hereby
++granted, provided that the above copyright notice appear in all
++copies and that both that copyright notice and this permission
++notice appear in supporting documentation, and that
++Hewlett-Packard not be used in advertising or publicity
++pertaining to distribution of the software without specific, written
++prior permission.
+--
+cgit v0.8.3-6-g21f6
diff --git a/abs/core/xorg-xwd/PKGBUILD b/abs/core/xorg-xwd/PKGBUILD
new file mode 100644
index 0000000..6586725
--- /dev/null
+++ b/abs/core/xorg-xwd/PKGBUILD
@@ -0,0 +1,23 @@
+# $Id: $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+
+pkgname=xorg-xwd
+pkgver=1.0.4
+pkgrel=1
+pkgdesc="X Window System image dumping utility"
+arch=(i686 x86_64)
+url="http://xorg.freedesktop.org/"
+license=('custom')
+depends=('libx11')
+makedepends=('xorg-util-macros')
+source=(http://xorg.freedesktop.org/archive/individual/app/xwd-${pkgver}.tar.bz2)
+sha1sums=('4ef4fd9072a507e9a1ee88ba1d28b314006cc109')
+
+build() {
+  cd "${srcdir}/xwd-${pkgver}"
+  ./configure --prefix=/usr
+  make
+  make DESTDIR="${pkgdir}" install
+  install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+  install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"
+}
diff --git a/abs/core/xorg-xwud/PKGBUILD b/abs/core/xorg-xwud/PKGBUILD
new file mode 100644
index 0000000..7ed437a
--- /dev/null
+++ b/abs/core/xorg-xwud/PKGBUILD
@@ -0,0 +1,23 @@
+# $Id: $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+
+pkgname=xorg-xwud
+pkgver=1.0.3
+pkgrel=1
+pkgdesc="X Window System image undumping utility"
+arch=(i686 x86_64)
+url="http://xorg.freedesktop.org/"
+license=('custom')
+depends=('libx11')
+makedepends=('xorg-util-macros')
+source=(http://xorg.freedesktop.org/archive/individual/app/xwud-${pkgver}.tar.bz2)
+sha1sums=('2e706d50c7039e3daa4963d36ab703e48aa652ed')
+
+build() {
+  cd "${srcdir}/xwud-${pkgver}"
+  ./configure --prefix=/usr
+  make
+  make DESTDIR="${pkgdir}" install
+  install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+  install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"
+}
-- 
cgit v0.12