From 9f2432479633a0167f4574118dd030332903a4fc Mon Sep 17 00:00:00 2001
From: James Meyer <jams@linhes.org>
Date: Fri, 10 Dec 2010 01:32:00 +0000
Subject: mythplugins: remove mythplugins from the name

---
 abs/core/mythtv/stable-0.24/mythplugins/PKGBUILD | 68 ++++++++++++------------
 abs/core/mythtv/stable-0.24/mythplugins/mtd      | 36 -------------
 2 files changed, 34 insertions(+), 70 deletions(-)
 delete mode 100644 abs/core/mythtv/stable-0.24/mythplugins/mtd

diff --git a/abs/core/mythtv/stable-0.24/mythplugins/PKGBUILD b/abs/core/mythtv/stable-0.24/mythplugins/PKGBUILD
index 85a7521..6970b71 100644
--- a/abs/core/mythtv/stable-0.24/mythplugins/PKGBUILD
+++ b/abs/core/mythtv/stable-0.24/mythplugins/PKGBUILD
@@ -2,19 +2,19 @@
 # Maintainer: Giovanni Scafora <giovanni@archlinux.org>
 
 pkgbase=mythplugins
-pkgname=('mythplugins-mytharchive'
-         'mythplugins-mythbrowser'
-         'mythplugins-mythgallery'
-         'mythplugins-mythgame'
-         'mythplugins-mythmusic'
-         'mythplugins-mythnetvision'
-         'mythplugins-mythnews'
-         'mythplugins-mythvideo'
-         'mythplugins-mythweather'
-         'mythplugins-mythweb'
-         'mythplugins-mythzoneminder')
+pkgname=('mytharchive'
+         'mythbrowser'
+         'mythgallery'
+         'mythgame'
+         'mythmusic'
+         'mythnetvision'
+         'mythnews'
+         'mythvideo'
+         'mythweather'
+         'mythweb'
+         'mythzoneminder')
 pkgver=0.24
-pkgrel=6
+pkgrel=8
 arch=('i686' 'x86_64')
 url="http://www.mythtv.org"
 license=('GPL')
@@ -51,94 +51,94 @@ build() {
   make || return 1
 }
 
-package_mythplugins-mytharchive() {
+package_mytharchive() {
   pkgdesc="MythTV plugin that lets you create DVDs from or archive your recorded shows"
   depends=("mythtv>=${pkgver}" 'libxmu' 'pil' 'dvdauthor')
-  replaces=('mytharchive')
+#  replaces=('mytharchive')
   cd "${srcdir}/${pkgbase}/mytharchive"
   make INSTALL_ROOT="${pkgdir}" install || return 1
 }
 
-package_mythplugins-mythbrowser() {
+package_mythbrowser() {
   pkgdesc="Mini web browser for MythTV"
   depends=("mythtv>=${pkgver}")
-  replaces=('mythbrowser')
+#  replaces=('mythbrowser')
   cd "${srcdir}/${pkgbase}/mythbrowser"
   make INSTALL_ROOT="${pkgdir}" install || return 1
 }
 
-package_mythplugins-mythgallery() {
+package_mythgallery() {
   pkgdesc="Image gallery plugin for MythTV"
   depends=("mythtv>=${pkgver}" 'libexif')
-  replaces=('mythgallery')
+#  replaces=('mythgallery')
   cd "${srcdir}/${pkgbase}/mythgallery"
   make INSTALL_ROOT="${pkgdir}" install || return 1
 }
 
-package_mythplugins-mythgame() {
+package_mythgame() {
   pkgdesc="Game emulator module for MythTV"
   depends=("mythtv>=${pkgver}" 'zlib')
-  replaces=('mythgame')
+#  replaces=('mythgame')
   cd "${srcdir}/${pkgbase}/mythgame"
   make INSTALL_ROOT="${pkgdir}" install || return 1
 }
 
-package_mythplugins-mythmusic() {
+package_mythmusic() {
   pkgdesc="Music playing plugin for MythTV"
   depends=("mythtv>=${pkgver}" 'flac' 'libvorbis' 'libcdaudio' 'cdparanoia' 'taglib' 'libvisual')
-  replaces=('mythmusic')
+#  replaces=('mythmusic')
   cd "${srcdir}/${pkgbase}/mythmusic"
   make INSTALL_ROOT="${pkgdir}" install || return 1
 }
 
-package_mythplugins-mythnetvision() {
+package_mythnetvision() {
   pkgdesc="MythNetvision plugin for MythTV"
   depends=("mythtv>=${pkgver}" 'python-pycurl' 'python-oauth')
-  replaces=('mythnetvision')
+#  replaces=('mythnetvision')
   cd "${srcdir}/${pkgbase}/mythnetvision"
   make INSTALL_ROOT="${pkgdir}" install || return 1
 }
 
-package_mythplugins-mythnews() {
+package_mythnews() {
   pkgdesc="News checking plugin for MythTV"
   depends=("mythtv>=${pkgver}")
-  replaces=('mythnews')
+#  replaces=('mythnews')
   cd "${srcdir}/${pkgbase}/mythnews"
   make INSTALL_ROOT="${pkgdir}" install || return 1
 }
 
-package_mythplugins-mythvideo() {
+package_mythvideo() {
   pkgdesc="Video playback and browsing plugin for MythTV"
   depends=("mythtv>=${pkgver}" 'mplayer' 'perl-xml-simple')
-  replaces=('mythvideo')
+#  replaces=('mythvideo')
   cd "${srcdir}/${pkgbase}/mythvideo"
   make INSTALL_ROOT="${pkgdir}" install || return 1
 }
 
-package_mythplugins-mythweather() {
+package_mythweather() {
   pkgdesc="Weather checking plugin for MythTV"
   depends=("mythtv>=${pkgver}" 'perl-xml-xpath' 'perl-image-size' 'perl-class-inspector' 'perl-datetime-format-iso8601')
-  replaces=('mythweather')
+#  replaces=('mythweather')
   cd "${srcdir}/${pkgbase}/mythweather"
   make INSTALL_ROOT="${pkgdir}" install || return 1
 }
 
-package_mythplugins-mythweb() {
+package_mythweb() {
   pkgdesc="Web interface for MythTV's backend"
   depends=("mythtv>=${pkgver}")
   optdepends=('php-apache'
               'lighttpd')
-  replaces=('mythweb')
+#  replaces=('mythweb')
   mkdir -p ${pkgdir}/data/srv/httpd/htdocs/mythweb/{image_cache,php_sessions}
   cp -r ${srcdir}/mythplugins/mythweb/* ${pkgdir}/data/srv/httpd/htdocs/mythweb || return 1
   chown -R http:http ${pkgdir}/data/srv/httpd/htdocs/mythweb
   chmod g+rw ${pkgdir}/data/srv/httpd/htdocs/mythweb/{image_cache,php_sessions,data}
 }
 
-package_mythplugins-mythzoneminder() {
+package_mythzoneminder() {
   pkgdesc="Allows for viewing of CCTV cameras through zoneminder"
   depends=("mythtv>=${pkgver}" zoneminder)
-  replaces=('mythzoneminder')
+#  replaces=('mythzoneminder')
 #  install=mythplugins-mythzoneminder.install
   cd "${srcdir}/${pkgbase}/mythzoneminder"
   make INSTALL_ROOT="${pkgdir}" install || return 1
diff --git a/abs/core/mythtv/stable-0.24/mythplugins/mtd b/abs/core/mythtv/stable-0.24/mythplugins/mtd
deleted file mode 100644
index 1f46dfe..0000000
--- a/abs/core/mythtv/stable-0.24/mythplugins/mtd
+++ /dev/null
@@ -1,36 +0,0 @@
-#!/bin/bash
-
-. /etc/rc.conf
-. /etc/rc.d/functions
-
-PID=`pidof -o %PPID /usr/bin/mtd`
-case "$1" in
-  start)
-    stat_busy "Starting Myth Transcoding Daemon"
-    [ -z "$PID" ] && /usr/bin/mtd -d
-    if [ $? -gt 0 ]; then
-      stat_fail
-    else
-      echo $PID > /var/run/mtd.pid
-      add_daemon mythtranscode
-      stat_done
-    fi
-    ;;
-  stop)
-    stat_busy "Stopping Myth Transcoding Daemon"
-    [ ! -z "$PID" ]  && kill $PID &>/dev/null
-    if [ $? -gt 0 ]; then
-      stat_fail
-    else
-      rm_daemon mtd 
-      stat_done
-    fi
-    ;;
-  restart)
-    $0 stop
-    $0 start
-    ;;
-  *)
-    echo "usage: $0 {start|stop|restart}"
-esac
-exit 0
-- 
cgit v0.12


From f9b90df04a227fb2607482bed9a2f56678d95d30 Mon Sep 17 00:00:00 2001
From: James Meyer <jams@linhes.org>
Date: Fri, 10 Dec 2010 01:32:14 +0000
Subject: mythtv: rebuild with python 2.6

---
 abs/core/mythtv/stable-0.24/mythtv/PKGBUILD | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/abs/core/mythtv/stable-0.24/mythtv/PKGBUILD b/abs/core/mythtv/stable-0.24/mythtv/PKGBUILD
index 5548edd..2fb4000 100755
--- a/abs/core/mythtv/stable-0.24/mythtv/PKGBUILD
+++ b/abs/core/mythtv/stable-0.24/mythtv/PKGBUILD
@@ -6,7 +6,7 @@
 
 pkgname=mythtv
 pkgver=0.24
-pkgrel=6
+pkgrel=8
 pkgdesc="A Homebrew PVR project"
 arch=('i686' 'x86_64')
 url="http://www.mythtv.org/"
-- 
cgit v0.12