From a2ab677040c35b12c2554f3b4aa1cbbdaaa336eb Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sun, 19 Oct 2014 18:10:03 -0500
Subject: LinHES-config:  fix remotes starting when it shouldn't.  This was due
 to not checking all the correct values for the blaster type

Fix upgrades for the new system images
---
 abs/core/LinHES-config/PKGBUILD      |  6 +++---
 abs/core/LinHES-config/mv_install.py | 18 +++++++++++++-----
 abs/core/LinHES-config/mv_ir.py      | 22 ++++++++++++----------
 3 files changed, 28 insertions(+), 18 deletions(-)

diff --git a/abs/core/LinHES-config/PKGBUILD b/abs/core/LinHES-config/PKGBUILD
index dfce8b7..f42ded1 100755
--- a/abs/core/LinHES-config/PKGBUILD
+++ b/abs/core/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-config
 pkgver=8.2
-pkgrel=10
+pkgrel=11
 conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev LinHes-config )
 pkgdesc="Install and configure your system"
 depends=('bc' 'libstatgrab' 'mysql-python' 'expect' 'curl' 'dnsutils' 'parted'
@@ -133,7 +133,7 @@ package() {
     install -o root -g root  -D -m 0755 blacklist_nouveau.conf $pkgdir/etc/modprobe.d/blacklist_nouveau.conf
 }
 
-md5sums=('c3304ee845d49a1f02b1efcbb9d85726'
+md5sums=('af15ebdfbbc3442626a807569a0db2a4'
          '3f6855b7bb860a44f96a972c2e80f497'
          'f6e9dd7bc6cf0aaa3bd203dab4cb79b9'
          '2596460462cf6c889cf8f95485537b20'
@@ -159,7 +159,7 @@ md5sums=('c3304ee845d49a1f02b1efcbb9d85726'
          'c0549457750c4f8e8038d904a0f3012a'
          '08dff9a1fc70c30bf4759e1821e824bd'
          'b845de3e05c1734cce4b9ac5e8f1baaf'
-         '6356c271bf6639002d4c59406250a1f6'
+         '885fcb99a0179d9704385e14aefd7af6'
          '8b7dce4a3a0a281fa6656aa8781a648e'
          '8903d2e17a6955ba59e6f17a65bfc082'
          '824e49d9b01fed295c704ab68908b464'
diff --git a/abs/core/LinHES-config/mv_install.py b/abs/core/LinHES-config/mv_install.py
index 20ec7bf..9556a0e 100644
--- a/abs/core/LinHES-config/mv_install.py
+++ b/abs/core/LinHES-config/mv_install.py
@@ -891,10 +891,13 @@ def copy_it(install_type):
     if ( install_type == "upgrade"):
         logging.info("Upgrading system")
 
-        cmdlist = ['rsync -arp --exclude /home --exclude /data/srv/mysql /image_mount/root/* /new_boot',
-                    'rsync -arp /image_mount/lib/* /new_boot/lib/',
-                    'rsync -arp /image_mount/usr /new_boot',
-                    'rsync -arp /image_mount/var /new_boot']
+        #cmdlist = ['rsync -arp --exclude /home --exclude /data/srv/mysql /image_mount/root/* /new_boot',
+                    #'rsync -arp /image_mount/lib/* /new_boot/lib/',
+                    #'rsync -arp /image_mount/usr /new_boot',
+                    #'rsync -arp /image_mount/var /new_boot']
+
+        cmdlist = ['rsync -arp  --exclude var-lib-pacman --exclude boot-orig  --exclude /home --exclude /data/srv/mysql /image_mount/* /new_boot']
+
 
         for cmd in cmdlist:
             #runcmd(cmd)
@@ -920,7 +923,7 @@ def copy_it(install_type):
     #needed to retain dhcp address between reboots.
     cp_and_log("/etc/dhcpcd.duid", data_config.MOUNTPOINT+"/etc/dhcpcd.duid")
     cp_and_log("/var/lib/dhcpcd/*.lease", data_config.MOUNTPOINT+"/var/lib/dhcpcd/")
-    
+
 #   General fixup
     cmd = "chmod 777 %s/tmp" %(data_config.MOUNTPOINT)
     runcmd(cmd)
@@ -1824,9 +1827,12 @@ def find_upgrade():
         cp_and_log(data_config.MOUNTPOINT+"/var/lib/alsa/", "/tmp/alsa")
         cp_and_log(data_config.MOUNTPOINT+"/var/lib/oss/", "/tmp/oss")
         cp_and_log("/tmp/etc/mdadm.conf", "/etc/mdadm.conf")
+        cp_and_log("/tmp/etc/dhcpcd.duid", "/etc/dhcpcd.duid")
+        
     else:
         logging.info("Could not find systemconfig file %s", srcfile)
         cp_and_log(data_config.MOUNTPOINT+"/etc/", "/tmp/etc/")
+        cp_and_log("/tmp/etc/dhcpcd.duid", "/etc/dhcpcd.duid")
         cp_and_log(data_config.MOUNTPOINT+"/var/lib/alsa/", "/tmp/alsa")
         cp_and_log("/tmp/etc/mdadm.conf", "/etc")
         timezone_to_db("/tmp/etc/timezone")
@@ -1989,6 +1995,8 @@ def upgrade(hostoptions):
     destfile = "%s/etc/mplayer/mplayer.conf" %(data_config.MOUNTPOINT)
     cp_and_log(srcfile, destfile)
 
+
+
     if not os.path.exists("/tmp/etc/KnoppMyth-version"):
         logging.debug("    standard upgrade,  restoring auth files")
         cp_and_log(data_config.MOUNTPOINT+"/etc.old/passwd", data_config.MOUNTPOINT+"/etc/passwd")
diff --git a/abs/core/LinHES-config/mv_ir.py b/abs/core/LinHES-config/mv_ir.py
index 1eae985..c4386cc 100755
--- a/abs/core/LinHES-config/mv_ir.py
+++ b/abs/core/LinHES-config/mv_ir.py
@@ -87,7 +87,9 @@ def include_file( incfile,filename):
 
 def setup_ir_remote(Remotetype,templates,mythhome,HostBlasterType,remotebucket):
     logging.debug("    Setup of remote type %s",Remotetype)
-    if Remotetype == "no_remote" and HostBlasterType == "None" :
+    #if Remotetype == "no_remote" and HostBlasterType == "None" :
+    HostBlasterType_values=["None",""]
+    if Remotetype == "no_remote" and (HostBlasterType in HostBlasterType_values)  :
         mv_common.remove_service("remotes")
     elif Remotetype == "tinker":
         pass #do nothing
@@ -139,7 +141,7 @@ def setup_ir_remote(Remotetype,templates,mythhome,HostBlasterType,remotebucket):
         #if remote has a special xbmc file, use it.
         xbmcfile= remote_path + "/xbmc.xml"
         userxmbcfile = mythhome+"/.xbmc/userdata/Lircmap.xml"
-        
+
         if os.path.exists(xbmcfile):
             logging.debug("     XBMC lirc file present")
             logging.info("    Setting up lirc for xbmc")
@@ -153,7 +155,7 @@ def setup_ir_remote(Remotetype,templates,mythhome,HostBlasterType,remotebucket):
                     os.mkdir(mythhome+"/.xbmc/userdata/")
                 except:
                     logging.debug("   Couldn't create .xbmc/userdata ")
-                    
+
                 try:
                     cmd = ''' chown -R mythtv %s/.xbmc''' %mythhome
                     mv_common.runcmd(cmd)
@@ -161,7 +163,7 @@ def setup_ir_remote(Remotetype,templates,mythhome,HostBlasterType,remotebucket):
                     mv_common.runcmd(cmd)
                 except:
                     logging.debug("   Couldn't change permissions for .xbmc")
-                    pass    
+                    pass
             try:
                     cmd = ''' rm -f %s''' %(userxmbcfile)
                     mv_common.runcmd(cmd)
@@ -171,12 +173,12 @@ def setup_ir_remote(Remotetype,templates,mythhome,HostBlasterType,remotebucket):
                 pass
         else:
             logging.debug("    XBMC lirc file %s not present" %xbmcfile)
-        
-            
-        
-        
-        
-        
+
+
+
+
+
+
 
         #remote has it's own modprobe.d/conf filename
         cmd = "rm  -f /etc/modprobe.d/mv_ir.conf"
-- 
cgit v0.12