From 87811cdd9e310bb99e2cddba97410584f1baaac5 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Mon, 6 Jul 2020 00:29:35 +0000
Subject: ncurses: update to 6.2

---
 abs/core/ncurses/PKGBUILD | 26 +++++++++++++-------------
 1 file changed, 13 insertions(+), 13 deletions(-)

diff --git a/abs/core/ncurses/PKGBUILD b/abs/core/ncurses/PKGBUILD
index 53e7682..2175cb3 100644
--- a/abs/core/ncurses/PKGBUILD
+++ b/abs/core/ncurses/PKGBUILD
@@ -1,36 +1,39 @@
-# $Id$
 # Maintainer:  Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
 # Contributor: Allan McRae <allan@archlinux.org>
 # Contributor: judd <jvinet@zeroflux.org>
 
 pkgname=ncurses
-pkgver=6.1
-pkgrel=3
+pkgver=6.2
+_pkgver=${pkgver/+/-}
+pkgrel=1
 pkgdesc='System V Release 4.0 curses emulation library'
 arch=(x86_64)
-url='http://invisible-island.net/ncurses/ncurses.html'
+url='https://invisible-island.net/ncurses/ncurses.html'
 license=(MIT)
 depends=(glibc gcc-libs)
 provides=(libncurses++w.so libformw.so libmenuw.so libpanelw.so libncursesw.so)
-#source=(http://invisible-mirror.net/archives/ncurses/current/ncurses-${_pkgver}.tgz{,.asc})
+replaces=(alacritty-terminfo)
 source=(https://ftp.gnu.org/pub/gnu/ncurses/ncurses-$pkgver.tar.gz{,.sig})
-md5sums=('98c889aaf8d23910d2b92d65be2e737a'
+#source=(http://invisible-mirror.net/archives/ncurses/current/ncurses-${_pkgver}.tgz{,.asc})
+md5sums=('e812da327b1c2214ac1aed440ea3ae8d'
          'SKIP')
 validpgpkeys=('C52048C0C0748FEE227D47A2702353E0F7E48EDB')  # Thomas Dickey
 
 build() {
-  cd $pkgname-$pkgver
+  cd $pkgname-$_pkgver
 
   ./configure --prefix=/usr --mandir=/usr/share/man \
     --with-pkg-config-libdir=/usr/lib/pkgconfig \
     --with-shared --with-normal --without-debug --without-ada \
-    --enable-widec --enable-pc-files --with-cxx-binding --with-cxx-shared
+    --enable-widec --enable-pc-files --with-cxx-binding --with-cxx-shared \
+    --with-manpage-format=normal
   make
 }
 
 package() {
-  cd $pkgname-$pkgver
+  cd $pkgname-$_pkgver
   make DESTDIR="$pkgdir" install
+  install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
 
   # fool packages looking to link to non-wide-character ncurses libraries
   for lib in ncurses ncurses++ form panel menu; do
@@ -41,13 +44,10 @@ package() {
   for lib in tic tinfo; do
     echo "INPUT(libncursesw.so.${pkgver:0:1})" > "$pkgdir/usr/lib/lib${lib}.so"
     ln -s libncursesw.so.${pkgver:0:1} "$pkgdir/usr/lib/lib${lib}.so.${pkgver:0:1}"
+    ln -s ncursesw.pc "$pkgdir/usr/lib/pkgconfig/${lib}.pc"
   done
 
   # some packages look for -lcurses during build
   echo 'INPUT(-lncursesw)' > "$pkgdir/usr/lib/libcursesw.so"
   ln -s libncurses.so "$pkgdir/usr/lib/libcurses.so"
-
-  # install license, rip it from the readme
-  install -d "$pkgdir/usr/share/licenses/$pkgname"
-  grep -B 100 '$Id' README > "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
 }
-- 
cgit v0.12