From 8d2502246e23a54a9552686b51c4d9c17aed0b37 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Tue, 27 Dec 2011 11:19:43 -0600
Subject: supplemental-web: process.py  add the command it's running to the top
 of the page. general cleanup of unused code

refs #805
---
 abs/core/supplemental-web/PKGBUILD            |  2 +-
 abs/core/supplemental-web/contents/process.py | 19 ++++++-------------
 2 files changed, 7 insertions(+), 14 deletions(-)

diff --git a/abs/core/supplemental-web/PKGBUILD b/abs/core/supplemental-web/PKGBUILD
index 4d38ac7..8fcd23b 100644
--- a/abs/core/supplemental-web/PKGBUILD
+++ b/abs/core/supplemental-web/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=supplemental-web
 pkgver=1.0
-pkgrel=13
+pkgrel=14
 arch=('i686')
 MVDIR=$startdir/pkg/usr/MythVantage
 install=supplemental-web.install
diff --git a/abs/core/supplemental-web/contents/process.py b/abs/core/supplemental-web/contents/process.py
index 1099817..c4f6170 100644
--- a/abs/core/supplemental-web/contents/process.py
+++ b/abs/core/supplemental-web/contents/process.py
@@ -100,6 +100,7 @@ def go_backup(myhost):
     myhostname = socket.gethostname()
     results="Nothing happened"
     command= "sudo /usr/LH/bin/lh_system_backup_job"
+    print command
     command2="sleep 1; /data/srv/hobbit/server/ext/hbnotes.py"
     results=os.popen(command,'r')
     os.popen(command2,'r')
@@ -124,25 +125,17 @@ def go_optimize(myhost):
     myhostname = socket.gethostname()
     if myhostname.strip() == myhost.strip():
        command="/usr/LH/bin/optimize_mythdb.py"
+       print command
        results=os.popen(command,'r')
     else:
         results='This host does not run a database'
     return  results
 
 def go_update(myhost,update_type):
-    myhostname = socket.gethostname()
-    if myhostname.strip() == myhost.strip():
-         cmd="sudo /usr/bin/update_system "
-         command=cmd + update_type
-
-    else:
-        cmd=" call pacman update_system "
-        cmd+=update_type
-        command="/usr/bin/func \"" + myhost.strip() + "*\"  " + cmd
-        print command
-
-        #print command
-
+    cmd=" call pacman update_system "
+    cmd+=update_type
+    command="/usr/bin/func \"" + myhost.strip() + "*\"  " + cmd
+    print command
     results=os.popen(command,'r')
     return  results
 
-- 
cgit v0.12