From e3e2804c1b462102cab62f7d9b7d7cc84c185c6b Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Sat, 16 Nov 2013 12:47:29 -0600
Subject: LinHES-system: misc_status_info.sh: fix log parsing. closes #939.
 refs #933.

remove myth .24 detection

remove LinHES-run as it isn't used anymore and was replaced by LinHES-session
---
 abs/core/LinHES-system/LinHES-run             | 149 --------------------------
 abs/core/LinHES-system/LinHES-session         |   7 +-
 abs/core/LinHES-system/PKGBUILD               |  15 ++-
 abs/core/LinHES-system/misc_status_info.sh    |   2 +-
 abs/core/LinHES-system/misc_which_recorder.pl |   6 +-
 abs/core/LinHES-system/mythfrontend-start     |   7 +-
 6 files changed, 13 insertions(+), 173 deletions(-)
 delete mode 100755 abs/core/LinHES-system/LinHES-run

diff --git a/abs/core/LinHES-system/LinHES-run b/abs/core/LinHES-system/LinHES-run
deleted file mode 100755
index 0de0feb..0000000
--- a/abs/core/LinHES-system/LinHES-run
+++ /dev/null
@@ -1,149 +0,0 @@
-#!/bin/sh
-exit 0
-################################################################
-#  WARNING THIS FILE IS DEPRECATED 
-#  any changes to this file must also be made to  LinHES-session
-#
-#
-###############################################################
-function msg(){
-    echo -e "$1"  | osd_cat --pos=middle --align=center --offset=200 --delay=5 --color=$color --outline=$outline --outlinecolour=$outlinecolour --shadow=$shadow --shadowcolour=$shadowcolour --font=$font &
-}
-
-. /etc/profile
-. /etc/systemconfig
-. /etc/unclutter.cfg || {
-	idle=1
-	jitter=200
-}
-. /etc/osd_cat.cfg || {
-	color=yellow
-	outline=2
-	outlinecolour=black
-	shadow=0
-	shadowcolour=black
-	font="-adobe-helvetica-bold-*-*-*-34-*-*-*-*-*-*-*"
-}
-#keylaunch &
-#/usr/bin/tilda &
-
-lsmod |cut -f1 -d" " |grep -q nvidia
-if [ $? = 0 ]
-then
-   /usr/bin/nvidia-settings --load-config-only
-fi
-
-#move mouse to corner
-xdotool mousemove 0 0 
-/usr/X11R6/bin/unclutter -root -idle $idle -jitter $jitter -noevents  &
-if [ x"$Screensavertype" = "xgscreensaver" ]
-then
-    gnome-screensaver &
-elif  [ x"$Screensavertype" = "xxscreensaver" ]
-then
-    xscreensaver  -no-splash &
-fi
-
-/usr/bin/xvattr -a XV_COLORKEY -v 0
-mtd &
-#/usr/bin/nvidia-settings -l
-#/usr/bin/nvidia-settings -a InitialPixmapPlacement=2
-
-if [ x$ShowTips = "x1" ]
-then
-    msg "Alt+h for help" &
-fi
-
-# Run any scripting that applies to special hardware.  These brand-specific commands that run
-# after Tweaker will, of course, override generic or hardware-specific settings.
-SpecialHardwareCommands() {
-    special_hardware_file=/myth/.special_hardware_type
-    special_hardware=`cat $special_hardware_file`
-
-    case $special_hardware in
-	dragon*)
-	    sudo -E twk_audio.pl --implement digital
-	    sudo -E twk_dragon.pl --implement all
-	    ;;
-	ausdragon*)
-	    ;;
-	*)
-	    # there are no brand-specific commands for configuring whatever
-	    # special hardware the user chose
-	    ;;
-    esac
-}
-
-#update apple trailers
-if [[ x$RunFrontend = x1 && -f ~/.configure ]]
-then
-    /usr/bin/php -q /usr/bin/myth_trailers_grabber > /home/mythtv/appletrailer.xml && /usr/bin/fix_aple_url.sh 2>/dev/null &
-fi
-
-
-if [ !  $SystemType = "Frontend_only" ]
-then
-    if [  -f ~/.configure ]
-    then
-	# Run Tweaker, which applies generic and hardware-specific settings
-	if [ ! -f ~/.no_meth ]
-	then
-            #remove tweaker cause it's broken and duplicates entries
-            #sudo -E tweaker.pl
-            #/bin/rm /tmp/fps # ??? clean up a temp file that will eventually be obsolete anyway
-            # Run any brand-specific commands, if necessary.
-            SpecialHardwareCommands
-        else
-	    rm -f ~/.no_meth
-	fi
-	sudo pacman -R --noconfirm myth2ipod myt2xvid3
-	sudo pacman -S --noconfirm myth2ipod myt2xvid3
-#	sudo ln -s /usr/share/mythtv/mythexport /data/srv/httpd/htdocs
-    sudo sv stop mythbackend
-    /usr/LH/bin/dtheme.sh
-    xterm -fn *18* -e sudo taskset -c 0 /usr/bin/mythtv-setup
-    sudo sv start mythbackend
-    sudo sv stop mythexport
-    sudo pacman -R --noconfirm mythexport
-    sudo pacman -S --noconfirm mythexport
-    sudo chown -R mythtv.mythtv /home/mythtv
-    nice -n 19 mythfilldatabase --quiet &
-    msg "Guide data is being loaded. \n Until this completes\n some shows will appear as unknown \n in the program guide."
-    rm ~/.configure
-    fi
-fi
-
-
-if [ x"$UseMythWelcome" = "x1" ]
-then
-    STARTCMD="/usr/bin/mythwelcome"
-else
-    if pacman -Q mythtv | grep -q 0.24
-    then
-        STARTCMD="/usr/bin/mythfrontend -d -l /var/log/mythtv/mythfrontend.log"
-    else
-        STARTCMD="/usr/bin/mythfrontend -d --syslog local6"
-    fi
-fi
-
-echo "====================================================================="
-echo "Starting $STARTCMD"
-firstboot.sh &
-
-if [ -f /tmp/nomfe ]
-then
-    exit 0
-else
-    if [ -f /tmp/debug ]
-    then
-        echo "using gbd/debug"
-        gdb /usr/bin/mythfrontend -x $MV_ROOT/mfegdbcommands.txt
-        mv gdb.txt gdb.txt.mythfrontend
-        sleep 10
-    else
-        killall -9 irexec
-        /usr/bin/irexec -d
-        $STARTCMD 2>&1
-    fi
-fi
-
diff --git a/abs/core/LinHES-system/LinHES-session b/abs/core/LinHES-system/LinHES-session
index a8c8c09..6badfab 100755
--- a/abs/core/LinHES-system/LinHES-session
+++ b/abs/core/LinHES-system/LinHES-session
@@ -286,12 +286,7 @@ function start_myth() {
     then
         STARTCMD="/usr/bin/mythwelcome"
     else
-        if pacman -Q mythtv | grep -q 0.24
-        then
-            STARTCMD="/usr/bin/mythfrontend -d -l /var/log/mythtv/mythfrontend.log"
-        else
-            STARTCMD="/usr/bin/mythfrontend $MYTH_ARGS"
-        fi
+        STARTCMD="/usr/bin/mythfrontend $MYTH_ARGS"
     fi
 
     echo "====================================================================="
diff --git a/abs/core/LinHES-system/PKGBUILD b/abs/core/LinHES-system/PKGBUILD
index 1cb2055..03b1c96 100755
--- a/abs/core/LinHES-system/PKGBUILD
+++ b/abs/core/LinHES-system/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-system
-pkgver=8.0
-pkgrel=39
+pkgver=8.1
+pkgrel=1
 arch=('i686' 'x86_64')
 install=system.install
 pkgdesc="Everything that makes LinHES an automated system"
@@ -12,7 +12,7 @@ depends=('linhes-sounds' 'xdotool' 'tilda' 'keylaunch'
         'handbrake-cli' 'mkvtoolnix' 'mplayer')
 backup=('etc/modprobe.d/alsa-base.conf')
 binfiles="LinHES-start optimize_mythdb.py myth_mtc.py myth_mtc.sh
- LinHES-run load-modules-mythvantage.sh unclutter-toggle.sh tvterm.sh
+ load-modules-mythvantage.sh unclutter-toggle.sh tvterm.sh
  mythfrontend-start set_windowmanager.sh myth_status.py myth_status.sh
  install_supplemental_service.sh get_airplay_key importfiles.sh
  lh_system_backup lh_system_backup_job lh_system_restore_job
@@ -72,17 +72,16 @@ package() {
 
 }
 
-md5sums=('5ee78704cab0e88ec58d1aab821fc1aa'
+md5sums=('95720bd676d0b05e89e1f6ae6e0b4e2d'
          'de32a1c50101265dd7f6ca5037f7a26a'
          'a875ee97f86e46f34a741c2bc455f894'
          '76b2637cac0452b3acdbeeb4e8a5474b'
          '781c977f8872543f033dad2caaf0458e'
          '6f5b757524d905b5d2420519a88edc93'
-         '4b4585ccba30595cf958d202997c57f7'
          'dc3eef2a624754e16805d72bbe488b67'
          '617af86b901538817ebdcaf646248dc5'
          '542e670e78d117657f93141e9689f54d'
-         '41951459ea9d2b0567be521b67e6285a'
+         '8da6a7f1703a002f84e66629e847d8a6'
          'bb72ab230c7a71706285bd0f31a4fb1f'
          'a8c79014423a95b41908fbe74ba83a6e'
          '962a3e9eaba2d1466251b7ab0956705d'
@@ -107,9 +106,9 @@ md5sums=('5ee78704cab0e88ec58d1aab821fc1aa'
          'b7febd04f64fe21e8cfbb888219b0b31'
          '06a628469051237943b7c874f2e29b8a'
          '8fe86aa9109a285aedce3c8658952bbb'
-         '45f46d1f9193c8dde18e56369ec29a1e'
+         '3300ea8b02e4fb8bd3409df348de6e16'
          '145b1da6ce501b3ce38ea415a576bf2d'
-         '116b0f62ed4e8dd6e437930deeb6e49e'
+         'b51c93ad9f3717a616d92899f6bfde76'
          '17f678d37187be0f12d67f64e40429c6'
          'bacc813b48bafcc6fe906e5969930501'
          '8e02efe1ad0df9a179075147eebb05b9'
diff --git a/abs/core/LinHES-system/misc_status_info.sh b/abs/core/LinHES-system/misc_status_info.sh
index 14a972c..a75b144 100755
--- a/abs/core/LinHES-system/misc_status_info.sh
+++ b/abs/core/LinHES-system/misc_status_info.sh
@@ -12,7 +12,7 @@
 
 # Get Encoder that was used for recordings from the backend log
 firstrun=1
-loglist=`find /var/log/ -name *_mythbackend.*.log*`
+loglist=`find /var/log/ -name *_mythbackend*.log*`
 for i in `ls -t $loglist`
 do
     if [ $firstrun -eq 1 ]; then
diff --git a/abs/core/LinHES-system/misc_which_recorder.pl b/abs/core/LinHES-system/misc_which_recorder.pl
index 6952b3f..2ad91b0 100755
--- a/abs/core/LinHES-system/misc_which_recorder.pl
+++ b/abs/core/LinHES-system/misc_which_recorder.pl
@@ -47,20 +47,20 @@ if ($log_file =~ /\.gz$/)
 {   
 #   read top down
 #    open($fh, "gunzip -c $log_file |") or die "Unable to open log file '$log_file', stopping:";   
+#   read bottom up
     open($fh, "gunzip -c $log_file |tac |") or die "Unable to open log file '$log_file', stopping:";   
 }
 else 
 {
 #   read top down
 #    open($fh, "<$log_file") or die "Unable to open log file '$log_file', stopping:";
+#   read bottom up
     open($fh, "tac $log_file |") or die "Unable to open log file '$log_file', stopping:";
 }
 
 while (<$fh>)
 {
-#   Myth .24 regex to find start of recording
-#    if (/^(.*)(?:\d(?: I )?|I.* -) (?:Started|Tuning) recording: (.*): channel (\d+) on cardid (\d+), sourceid (\d+)/)
-#   Myth .25 regex to find start of recording for digital and analog MPEG
+#   Myth .25 & .27 regex to find start of recording for digital and analog MPEG
     if (/^(\d+-\d+-\d+T\d+\:\d+\:\d+)(?:.*) (?:Started|Tuning) recording: (.*): channel (\d+) on cardid (\d+), sourceid (\d+)/ || /^(\d+-\d+-\d+T\d+\:\d+\:\d+)(?:.*) \(UpdateRecStatus\) Updating status for (.*)() on cardid (\d+) \(Will Record => Recording\)()/)
     {
         if ($mode eq "--noheader")
diff --git a/abs/core/LinHES-system/mythfrontend-start b/abs/core/LinHES-system/mythfrontend-start
index 5cfc9b7..320f960 100755
--- a/abs/core/LinHES-system/mythfrontend-start
+++ b/abs/core/LinHES-system/mythfrontend-start
@@ -3,12 +3,7 @@ PIDS=$(pidof mythfrontend)
 P_array=( $PIDS )
 let "instances = ${#P_array[*]}"  # Count elements.
 
-if pacman -Q mythtv | grep -q 0.24
-then
-    STARTCMD="/usr/bin/mythfrontend -d -l /var/log/mythtv/mythfrontend.log"
-else
-    STARTCMD="/usr/bin/mythfrontend -d --syslog local6"
-fi
+STARTCMD="/usr/bin/mythfrontend -d --syslog local6"
 
 if [ $instances -gt 0 ];
 then
-- 
cgit v0.12