From 9fedf92f0b8a104583fa829a84aa45979a3f492b Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Wed, 30 May 2018 21:04:01 +0000
Subject: perl-locale-gettext: update to 1.07

---
 abs/core/perl_modules/perl-locale-gettext/PKGBUILD | 25 +++++++++++++---------
 .../compatibility-with-POSIX-module.patch          | 10 ---------
 2 files changed, 15 insertions(+), 20 deletions(-)
 delete mode 100644 abs/core/perl_modules/perl-locale-gettext/compatibility-with-POSIX-module.patch

diff --git a/abs/core/perl_modules/perl-locale-gettext/PKGBUILD b/abs/core/perl_modules/perl-locale-gettext/PKGBUILD
index e2bb2e3..22fede7 100644
--- a/abs/core/perl_modules/perl-locale-gettext/PKGBUILD
+++ b/abs/core/perl_modules/perl-locale-gettext/PKGBUILD
@@ -1,27 +1,24 @@
-# $Id: PKGBUILD 160541 2012-06-02 10:27:56Z bluewind $
+# $Id$
 # Maintainer: Giovanni Scafora <giovanni@archlinux.org>
 # Contributor: Mark Rosenstand <mark@borkware.net>
 # Contributor: Paul Mattal <paul@archlinux.org>
 
 pkgname=perl-locale-gettext
-_realname=gettext
-pkgver=1.05
-pkgrel=9
+_realname=Locale-gettext
+pkgver=1.07
+pkgrel=5
 pkgdesc="Permits access from Perl to the gettext() family of functions"
-arch=('i686' 'x86_64')
+arch=('x86_64')
 license=('GPL' 'PerlArtistic')
 url="http://search.cpan.org/dist/${_realname}/"
 depends=('gettext' 'perl')
 options=(!emptydirs)
-source=("http://search.cpan.org/CPAN/authors/id/P/PV/PVANDRY/${_realname}-${pkgver}.tar.gz"
-        'compatibility-with-POSIX-module.patch')
-md5sums=('f3d3f474a1458f37174c410dfef61a46'
-         '854302f34d01a2f8ae739187788973dd')
+source=("http://search.cpan.org/CPAN/authors/id/P/PV/PVANDRY/${_realname}-${pkgver}.tar.gz")
+md5sums=('bc652758af65c24500f1d06a77415019')
 
 build() {
   cd "${srcdir}/${_realname}-${pkgver}"
 
-  patch -Np1 -i ${srcdir}/compatibility-with-POSIX-module.patch
   # install module in vendor directories.
   PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
   make
@@ -40,4 +37,12 @@ package() {
   # remove perllocal.pod and .packlist
   find "${pkgdir}" -name perllocal.pod -delete
   find "${pkgdir}" -name .packlist -delete
+
+# template start; name=perl-binary-module-dependency; version=1;
+if [[ $(find "$pkgdir/usr/lib/perl5/" -name "*.so") ]]; then
+	_perlver_min=$(perl -e '$v = $^V->{version}; print $v->[0].".".($v->[1]);')
+	_perlver_max=$(perl -e '$v = $^V->{version}; print $v->[0].".".($v->[1]+1);')
+	depends+=("perl>=$_perlver_min" "perl<$_perlver_max")
+fi
+# template end;
 }
diff --git a/abs/core/perl_modules/perl-locale-gettext/compatibility-with-POSIX-module.patch b/abs/core/perl_modules/perl-locale-gettext/compatibility-with-POSIX-module.patch
deleted file mode 100644
index ad67551..0000000
--- a/abs/core/perl_modules/perl-locale-gettext/compatibility-with-POSIX-module.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/gettext.pm	2005-05-31 20:11:16.000000000 -0700
-+++ b/gettext.pm	2009-10-07 12:39:42.000000000 -0700
-@@ -32,6 +32,7 @@
- =cut
- 
- use Carp;
-+use POSIX qw(:locale_h);
- 
- require Exporter;
- require DynaLoader;
-- 
cgit v0.12