From a26d28c380288d7c70a19bee81314a934df7c788 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Wed, 7 Dec 2011 13:22:18 -0600
Subject: keylaunch: first build.  Used to bind actions to hot keys.  This is
 needed to keep the linhes keybindings when not using fluxbox

---
 abs/core/keylaunch/PKGBUILD          | 19 ++++++++++++++++
 abs/core/keylaunch/example_rc        | 28 +++++++++++++++++++++++
 abs/core/keylaunch/keylaunch.install | 44 ++++++++++++++++++++++++++++++++++++
 3 files changed, 91 insertions(+)
 create mode 100644 abs/core/keylaunch/PKGBUILD
 create mode 100644 abs/core/keylaunch/example_rc
 create mode 100644 abs/core/keylaunch/keylaunch.install

diff --git a/abs/core/keylaunch/PKGBUILD b/abs/core/keylaunch/PKGBUILD
new file mode 100644
index 0000000..5ae239a
--- /dev/null
+++ b/abs/core/keylaunch/PKGBUILD
@@ -0,0 +1,19 @@
+pkgname=keylaunch
+pkgver=1.3.9
+pkgrel=2
+arch=('i686')
+pkgdesc="KeyLaunch is a small utility for binding commands to a hot key. "
+url="http://www.oroborus.org/"
+depends=(glibc)
+source=(http://ftp.debian.org/debian/pool/main/k/keylaunch/keylaunch_1.3.9.tar.gz example_rc)
+install=keylaunch.install
+
+build() {
+  cd $startdir/src/$pkgname-$pkgver
+  ./configure --prefix=/usr
+  make
+  make DESTDIR=$startdir/pkg install
+  install -D -m0755 ../example_rc $startdir/pkg/etc/keylaunchrc
+}
+md5sums=('710f68a3e7026b4139cc94ea790576c3'
+         '652de5f0db90f32c664c9698f865e07a')
diff --git a/abs/core/keylaunch/example_rc b/abs/core/keylaunch/example_rc
new file mode 100644
index 0000000..8b5ca34
--- /dev/null
+++ b/abs/core/keylaunch/example_rc
@@ -0,0 +1,28 @@
+# Copy to $HOME/.keylaunchrc
+#
+# Format:
+# key=...KeyName:Command
+#
+# ... No modifier
+# *.. Shift
+# .*. Ctrl
+# ..* Alt
+
+key=*..Return:xterm -fn *-18-*
+key=..*x:/usr/LH/bin/tvterm.sh 
+key=..*s:sudo /usr/bin/mythtv-setup
+key=..*u:/usr/LH/bin/unclutter-toggle.sh
+key=.**u:/usr/LH/bin/unclutter-toggle.sh
+key=..*h:/usr/MythVantage/bin/mythinstall -h
+key=..*m:/usr/LH/bin/mythfrontend-start
+
+
+key=.*1:/usr/MythVantage/bin/mythbeselect -stop
+key=.*.2:/usr/MythVantage/bin/mythbeselect -start
+key=.*.3:/usr/MythVantage/bin/mythbeselect -restart
+
+key=..*1:sudo sv start mythbackend
+key=..*2:sudo sv stop mythbackend
+key=..*3:sudo sv restart mythbackend
+
+
diff --git a/abs/core/keylaunch/keylaunch.install b/abs/core/keylaunch/keylaunch.install
new file mode 100644
index 0000000..42bc9eb
--- /dev/null
+++ b/abs/core/keylaunch/keylaunch.install
@@ -0,0 +1,44 @@
+# This is a default template for a post-install scriptlet.  You can
+# remove any functions you don't need (and this header).
+
+# arg 1:  the new package version
+pre_install() {
+  /bin/true
+}
+
+# arg 1:  the new package version
+post_install() {
+ MHOME=`cat /etc/passwd | grep "mythtv" | cut -d":" -f6`
+ if [ ! -e $MHOME/.keylaunchrc ]
+ then
+	echo "setting symlink for keylaunch"
+ 	ln -s /etc/keylaunchrc $MHOME/.keylaunchrc
+fi
+}
+
+# arg 1:  the new package version
+# arg 2:  the old package version
+pre_upgrade() {
+  /bin/true
+ 
+}
+
+# arg 1:  the new package version
+# arg 2:  the old package version
+post_upgrade() {
+  post_install
+}
+
+# arg 1:  the old package version
+pre_remove() {
+  /bin/true
+}
+
+# arg 1:  the old package version
+post_remove() {
+  /bin/true
+}
+
+op=$1
+shift
+$op $*
-- 
cgit v0.12