From 45112f62b9fdda88ee4ac0760ef728ec2b8f7c30 Mon Sep 17 00:00:00 2001
From: Michael Hanson <hansonorders@verizon.net>
Date: Thu, 9 Dec 2010 23:56:13 +0000
Subject: python-decorator: recompile

---
 .../python_modules/python-decorator/LICENSE.txt    | 26 +++++++++++++++++++
 abs/core/python_modules/python-decorator/PKGBUILD  | 30 ++++++++++++++++++++++
 2 files changed, 56 insertions(+)
 create mode 100644 abs/core/python_modules/python-decorator/LICENSE.txt
 create mode 100644 abs/core/python_modules/python-decorator/PKGBUILD

diff --git a/abs/core/python_modules/python-decorator/LICENSE.txt b/abs/core/python_modules/python-decorator/LICENSE.txt
new file mode 100644
index 0000000..a6a4929
--- /dev/null
+++ b/abs/core/python_modules/python-decorator/LICENSE.txt
@@ -0,0 +1,26 @@
+Copyright (c) 2007, Michele Simionato
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are
+met:
+
+  Redistributions of source code must retain the above copyright 
+  notice, this list of conditions and the following disclaimer.
+  Redistributions in bytecode form must reproduce the above copyright
+  notice, this list of conditions and the following disclaimer in
+  the documentation and/or other materials provided with the
+  distribution. 
+
+  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+  HOLDERS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
+  INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
+  BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS
+  OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
+  ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR
+  TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE
+  USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH
+  DAMAGE.
diff --git a/abs/core/python_modules/python-decorator/PKGBUILD b/abs/core/python_modules/python-decorator/PKGBUILD
new file mode 100644
index 0000000..5e2e8f5
--- /dev/null
+++ b/abs/core/python_modules/python-decorator/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Thomas Dziedzic < gostrc at gmail >
+# Contributor: Pierre Chapuis <catwell at archlinux dot us>
+
+pkgname=python-decorator
+pkgver=3.2.0
+pkgrel=3
+pkgdesc='Python Decorator module'
+arch=('any')
+url='http://pypi.python.org/pypi/decorator'
+license=('BSD')
+depends=('python2')
+source=("http://pypi.python.org/packages/source/d/decorator/decorator-${pkgver}.tar.gz"
+        'LICENSE.txt')
+md5sums=('6208cd51365083c168ab3a04426a646b'
+         '0ca76d2c707f09dbb04acc425ea1a08b')
+
+build() {
+  cd decorator-${pkgver}
+
+  python2 setup.py build
+}
+
+package() {
+  cd decorator-${pkgver}
+
+  python2 setup.py install --root=${pkgdir} --optimize=1
+
+  install -D -m644 ${srcdir}/LICENSE.txt \
+    ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
-- 
cgit v0.12