From b3766e376db18909653e2dabf4b37fc050ebad63 Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Wed, 11 Feb 2009 14:25:22 -0800
Subject: Need by splashy.

---
 abs/core-testing/which/PKGBUILD      | 18 +++++++++++-------
 abs/core-testing/which/which.install | 20 ++++++++++++++++++++
 2 files changed, 31 insertions(+), 7 deletions(-)
 create mode 100644 abs/core-testing/which/which.install

diff --git a/abs/core-testing/which/PKGBUILD b/abs/core-testing/which/PKGBUILD
index 3bd0175..065c870 100644
--- a/abs/core-testing/which/PKGBUILD
+++ b/abs/core-testing/which/PKGBUILD
@@ -1,20 +1,24 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
-# Maintainer: judd <jvinet@zeroflux.org>
+# $Id: PKGBUILD 12859 2008-09-22 17:33:50Z andyrtr $
+# Maintainer: Andreas Radke <andyrtr@archlinux.org>
+
 pkgname=which
-pkgver=2.19
-pkgrel=11
+pkgver=2.20
+pkgrel=1
 pkgdesc="A utility to show the full path of commands"
-arch=(i686 x86_64)
+arch=('i686' 'x86_64')
 url="http://www.xs4all.nl/~carlo17/which"
 license=('GPL3')
+install=which.install
 groups=('base')
-depends=('glibc')
+depends=('glibc' 'texinfo')
 source=(http://www.xs4all.nl/~carlo17/$pkgname/$pkgname-$pkgver.tar.gz)
-md5sums=('bbd094cec2444cd78befbc0cf09deea4')
+md5sums=('95be0501a466e515422cde4af46b2744')
 
 build() {
   cd $startdir/src/$pkgname-$pkgver
   ./configure --prefix=/usr
   make || return 1
   make DESTDIR=$startdir/pkg install
+
+  rm -f ${pkgdir}/usr/share/info/dir
 }
diff --git a/abs/core-testing/which/which.install b/abs/core-testing/which/which.install
new file mode 100644
index 0000000..899bd6f
--- /dev/null
+++ b/abs/core-testing/which/which.install
@@ -0,0 +1,20 @@
+infodir=/usr/share/info
+filelist=(which.info)
+
+post_install() {
+  for file in ${filelist[@]}; do
+    install-info $infodir/$file $infodir/dir 2> /dev/null
+  done
+}
+
+post_upgrade() {
+  post_install $1
+}
+
+pre_remove() {
+  for file in ${filelist[@]}; do
+    install-info --delete $infodir/$file $infodir/dir 2> /dev/null
+  done
+}
+
+# vim:set ts=2 sw=2 et:
-- 
cgit v0.12