From 6980e3d3f5dbc51bd787c2ad490dc7b3c160199c Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Mon, 26 Jan 2009 11:35:29 -0800
Subject: Initial PKGBUILD for Folding at Home.

---
 abs/extra-testing/community/foldingathome/PKGBUILD |  28 ++++++
 .../foldingathome/archpatch_foldingathome.diff     | 110 +++++++++++++++++++++
 .../community/foldingathome/foldingathome.install  |  30 ++++++
 3 files changed, 168 insertions(+)
 create mode 100644 abs/extra-testing/community/foldingathome/PKGBUILD
 create mode 100644 abs/extra-testing/community/foldingathome/archpatch_foldingathome.diff
 create mode 100755 abs/extra-testing/community/foldingathome/foldingathome.install

diff --git a/abs/extra-testing/community/foldingathome/PKGBUILD b/abs/extra-testing/community/foldingathome/PKGBUILD
new file mode 100644
index 0000000..411702c
--- /dev/null
+++ b/abs/extra-testing/community/foldingathome/PKGBUILD
@@ -0,0 +1,28 @@
+# Contributor: Jason Taylor <jftaylor21@gmail.com>
+# Contributor: seratne
+# Contributor: Nick B <Shirakawasuna at gmail _dot_com>
+
+pkgname=foldingathome
+pkgver=6.02
+pkgrel=1
+pkgdesc="Folding@Home is a distributed computing project which studies protein folding, misfolding, aggregation, and related diseases."
+arch=('i686')
+url="http://folding.stanford.edu/"
+license=('custom')
+depends=('bash')
+backup=('etc/conf.d/foldingathome')
+install=foldingathome.install
+source=(http://www.stanford.edu/group/pandegroup/folding/release/FAH$pkgver-Linux.tgz
+	archpatch_foldingathome.diff)
+md5sums=('112b3d66909050f1bb990993a1464cb9'
+         '02f4ca64d552b442d484c51fa5f4228a')
+
+build() {
+  cd $startdir/src/
+  patch -p1 <archpatch_foldingathome.diff
+  install -D -c -m755 fah6 $startdir/pkg/opt/fah/fah6 || return 1
+  install -D -c -m755 $startdir/src/foldingathome.rc.d $startdir/pkg/etc/rc.d/foldingathome || return 1
+  install -D -c -m644 $startdir/src/foldingathome.conf.d $startdir/pkg/etc/conf.d/foldingathome || return 1
+  install -D -m644 foldingathome.license $startdir/pkg/usr/share/licenses/$pkgname/COPYING
+  
+}
diff --git a/abs/extra-testing/community/foldingathome/archpatch_foldingathome.diff b/abs/extra-testing/community/foldingathome/archpatch_foldingathome.diff
new file mode 100644
index 0000000..73410f1
--- /dev/null
+++ b/abs/extra-testing/community/foldingathome/archpatch_foldingathome.diff
@@ -0,0 +1,110 @@
+diff -Naur blank/foldingathome.conf.d 6.02-1/foldingathome.conf.d
+--- blank/foldingathome.conf.d	1969-12-31 16:00:00.000000000 -0800
++++ 6.02-1/foldingathome.conf.d	2008-08-21 16:59:05.000000000 -0700
+@@ -0,0 +1,12 @@
++#
++# Optional user settings for foldingathome daemon
++#
++# If you prefer not to run fah as root then you can identifer a current or
++# specially created user here.
++
++FAH_USER=""
++
++# If you wish to associate this user with a specific group you can enter the
++# group name here.  If left blank the default is "users".
++
++FAH_GRP=""
+diff -Naur blank/foldingathome.license 6.02-1/foldingathome.license
+--- blank/foldingathome.license	1969-12-31 16:00:00.000000000 -0800
++++ 6.02-1/foldingathome.license	2008-08-21 16:59:27.000000000 -0700
+@@ -0,0 +1,26 @@
++Folding@Home distributed computing client
++Copyright 2001-2007. Stanford University. All Rights Reserved. 
++ 
++License Agreement:
++
++Please carefully read the following terms and conditions before using this software. Use of this software 
++indicates acceptance of this license agreement and disclaimer of all warranties. 
++
++Disclaimer of Warranty:
++
++IN NO EVENT SHALL STANFORD UNIVERSITY BE LIABLE TO ANY PARTY FOR DIRECT, INDIRECT, SPECIAL, INCIDENTAL, 
++OR CONSEQUENTIAL DAMAGES, INCLUDING LOST PROFITS, ARISING OUT OF THE USE OF THIS SOFTWARE AND ITS 
++DOCUMENTATION, EVEN IF STANFORD UNIVERSITY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. 
++STANFORD UNIVERSITY SPECIFICALLY DISCLAIMS ANY WARRANTIES, INCLUDING, BUT NOTLIMITED TO, THE IMPLIED 
++WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE SOFTWARE AND ACCOMPANYING 
++DOCUMENTATION PROVIDED HEREUNDER IS PROVIDED "AS IS". Folding@home HAS NO OBLIGATION TO PROVIDE 
++MAINTENANCE, SUPPORT, UPDATES, ENHANCEMENTS, OR MODIFICATIONS. 
++
++Restrictions:
++
++You may use this software on a computer system only if you own the system or have the permission of the owner. 
++You may not alter the software or associated data files. 
++You may only use unmodified versions of Folding@home obtained through authorized distributors to connect 
++to the Folding@Home servers. Use of other software to connect to the Folding@home servers is strictly prohibited. 
++Distribution of this software is prohibited. It may only be obtained by downloading from Stanford's web site 
++(http://folding.stanford.edu and pages linked therein) or the web site of one of our commercial partners (Sony, NVIDIA, and ATI).
+diff -Naur blank/foldingathome.rc.d 6.02-1/foldingathome.rc.d
+--- blank/foldingathome.rc.d	1969-12-31 16:00:00.000000000 -0800
++++ 6.02-1/foldingathome.rc.d	2008-08-21 17:00:48.000000000 -0700
+@@ -0,0 +1,60 @@
++#!/bin/bash
++#/etc/rc.d/foldingathome
++#
++# Starts the Folding@Home client in the background
++
++. /etc/rc.conf
++. /etc/rc.d/functions
++. /etc/conf.d/foldingathome
++
++PID=`pidof -o %PPID /opt/fah/fah6`
++case "$1" in
++	start)
++	stat_busy "Starting Folding@Home"
++	if [ -z "$PID" ]; then
++		if [ ! -z "$FAH_USER" ] ; then
++			if [ ! -d "/opt/fah/$FAH_USER" ] ; then
++				mkdir /opt/fah/$FAH_USER
++				chown $FAH_USER /opt/fah/$FAH_USER
++				if [ ! -z "$FAH_GRP" ] ; then
++					chgrp $FAH_GRP /opt/fah/$FAH_USER
++				else
++					chgrp users /opt/fah/$FAH_USER
++				fi
++			fi
++			cd /opt/fah/$FAH_USER
++			su $FAH_USER -c "nice --adjustment 19 /opt/fah/fah6 -verbosity 9 > /opt/fah/$FAH_USER/myfah.log" &
++		else
++			cd /opt/fah
++			nice --adjustment 19 /opt/fah/fah6 -verbosity 9 > /opt/fah/myfah.log &
++		fi
++	fi
++	if [ ! -z "$PID" -o $? -gt 0 ]; then
++		stat_fail
++	else
++		add_daemon foldingathome
++		stat_done
++	fi
++	;;
++	
++	stop)
++	stat_busy "Stopping Folding@Home"
++	[ ! -z "$PID" ]&& kill $PID &> /dev/null
++	if [ $? -gt 0 ]; then
++		stat_fail
++	else
++		rm_daemon foldingathome
++		stat_done
++	fi
++	;;
++	
++	restart)
++	$0 stop
++	sleep 1
++	$0 start
++	;;
++	
++	*)
++	echo $"Usage: $0 {start|stop|restart}"
++esac
++
diff --git a/abs/extra-testing/community/foldingathome/foldingathome.install b/abs/extra-testing/community/foldingathome/foldingathome.install
new file mode 100755
index 0000000..8eedb6c
--- /dev/null
+++ b/abs/extra-testing/community/foldingathome/foldingathome.install
@@ -0,0 +1,30 @@
+# arg 1:  the new package version
+post_install() {
+  cat << 'EOM'
+  --> Please cd to /opt/fah/ and execute ./fah6 -smp -configonly 
+  --> to configure your settings. Then add "foldingathome" to the list
+  --> of daemons in /etc/rc.conf. If you would like to join the Arch 
+  --> Linux team, use team number 45032. To check current progress,
+  --> point your browser to file://opt/fah/MyFolding.html
+
+  --> It is strongly recommended that you run foldingathome as a user other
+  --> than root. You can identify a user in /etc/conf.d/foldingathome.
+  --> A directory called /opt/fah/$FAH_USER will be created."
+EOM
+}
+
+# arg 1:  the new package version
+# arg 2:  the old package version
+post_upgrade() {
+  post_install $1
+}
+
+# arg 1:  the old package version
+pre_remove() {
+  /bin/true
+}
+
+op=$1
+shift
+
+$op $* 
-- 
cgit v0.12