From 2d5c4683d60ad39f51944e2e4d3c22a928c2d953 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Thu, 31 Jan 2019 21:51:29 +0000
Subject: gtk3: update to 3.24.4

---
 ...o-cursor-name-fallback-for-standard-names.patch |  85 -----------------
 ...y-do-cursor-name-fallback-for-standard-na.patch |  94 ------------------
 abs/extra/gtk3/PKGBUILD                            | 106 +++++++++++----------
 abs/extra/gtk3/gtk-query-immodules-3.0.hook        |  11 +++
 abs/extra/gtk3/gtk-update-icon-cache.hook          |  13 +++
 abs/extra/gtk3/gtk-update-icon-cache.install       |   3 -
 abs/extra/gtk3/gtk-update-icon-cache.script        |  10 ++
 abs/extra/gtk3/gtk3.install                        |  15 ---
 8 files changed, 91 insertions(+), 246 deletions(-)
 delete mode 100644 abs/extra/gtk3/0001-x11-Only-do-cursor-name-fallback-for-standard-names.patch
 delete mode 100644 abs/extra/gtk3/0002-wayland-Only-do-cursor-name-fallback-for-standard-na.patch
 create mode 100644 abs/extra/gtk3/gtk-query-immodules-3.0.hook
 create mode 100644 abs/extra/gtk3/gtk-update-icon-cache.hook
 delete mode 100644 abs/extra/gtk3/gtk-update-icon-cache.install
 create mode 100644 abs/extra/gtk3/gtk-update-icon-cache.script

diff --git a/abs/extra/gtk3/0001-x11-Only-do-cursor-name-fallback-for-standard-names.patch b/abs/extra/gtk3/0001-x11-Only-do-cursor-name-fallback-for-standard-names.patch
deleted file mode 100644
index d187d40..0000000
--- a/abs/extra/gtk3/0001-x11-Only-do-cursor-name-fallback-for-standard-names.patch
+++ /dev/null
@@ -1,85 +0,0 @@
-From affd6e70734d7897324409d6fc0beb7b4eb7235a Mon Sep 17 00:00:00 2001
-From: Matthias Clasen <mclasen@redhat.com>
-Date: Wed, 6 Jan 2016 14:54:33 -0500
-Subject: [PATCH 1/2] x11: Only do cursor name fallback for standard names
-
-Always returning a left_ptr if we can't find anything better
-broke firefox application-specific fallback for missing cursors.
-Keep that working by only doing the fallback for the CSS cursor
-names, not for things like hashes.
-
-https://bugzilla.gnome.org/show_bug.cgi?id=760141
----
- gdk/x11/gdkcursor-x11.c | 24 ++++++++++++++++++++----
- 1 file changed, 20 insertions(+), 4 deletions(-)
-
-diff --git a/gdk/x11/gdkcursor-x11.c b/gdk/x11/gdkcursor-x11.c
-index 540f48e..d619f58 100644
---- a/gdk/x11/gdkcursor-x11.c
-+++ b/gdk/x11/gdkcursor-x11.c
-@@ -611,17 +611,23 @@ static const struct {
-   const gchar *css_name, *traditional_name;
- } name_map[] = {
-   { "default",      "left_ptr" },
-+  { "help",         "left_ptr" },
-+  { "context-menu", "left_ptr" },
-   { "pointer",      "hand" },
-   { "progress",     "left_ptr_watch" },
-   { "wait",         "watch" },
-   { "cell",         "crosshair" },
-   { "crosshair",    "cross" },
-   { "text",         "xterm" },
-+  { "vertical-text","xterm" },
-   { "alias",        "dnd-link" },
-   { "copy",         "dnd-copy" },
-+  { "move",         "dnd-move" },
-   { "no-drop",      "dnd-none" },
-   { "not-allowed",  "crossed_circle" },
-   { "grab",         "hand2" },
-+  { "grabbing",     "hand2" },
-+  { "all-scroll",   "left_ptr" },
-   { "col-resize",   "h_double_arrow" },
-   { "row-resize",   "v_double_arrow" },
-   { "n-resize",     "top_side" },
-@@ -636,6 +642,8 @@ static const struct {
-   { "ns-resize",    "v_double_arrow" },
-   { "nesw-resize",  "fd_double_arrow" },
-   { "nwse-resize",  "bd_double_arrow" },
-+  { "zoom-in",      "left_ptr" },
-+  { "zoom-out",     "left_ptr" },
-   { NULL, NULL }
- };
- 
-@@ -650,7 +658,7 @@ name_fallback (const gchar *name)
-         return name_map[i].traditional_name;
-     }
- 
--  return "left_ptr";
-+  return NULL;
- }
- 
- GdkCursor*
-@@ -683,9 +691,17 @@ _gdk_x11_display_get_cursor_for_name (GdkDisplay  *display,
-       xdisplay = GDK_DISPLAY_XDISPLAY (display);
-       xcursor = XcursorLibraryLoadCursor (xdisplay, name);
-       if (xcursor == None)
--        xcursor = XcursorLibraryLoadCursor (xdisplay, name_fallback (name));
--      if (xcursor == None)
--        xcursor = XcursorLibraryLoadCursor (xdisplay, "left_ptr");
-+        {
-+          const char *fallback;
-+
-+          fallback = name_fallback (name);
-+          if (fallback)
-+            {
-+              xcursor = XcursorLibraryLoadCursor (xdisplay, fallback);
-+              if (xcursor == None)
-+                xcursor = XcursorLibraryLoadCursor (xdisplay, "left_ptr");
-+            }
-+        }
-       if (xcursor == None)
-         return NULL;
-     }
--- 
-2.7.0
-
diff --git a/abs/extra/gtk3/0002-wayland-Only-do-cursor-name-fallback-for-standard-na.patch b/abs/extra/gtk3/0002-wayland-Only-do-cursor-name-fallback-for-standard-na.patch
deleted file mode 100644
index 94b69fb..0000000
--- a/abs/extra/gtk3/0002-wayland-Only-do-cursor-name-fallback-for-standard-na.patch
+++ /dev/null
@@ -1,94 +0,0 @@
-From 81a287478a4db9ce650cc764474b9c173b137dee Mon Sep 17 00:00:00 2001
-From: Matthias Clasen <mclasen@redhat.com>
-Date: Wed, 6 Jan 2016 14:56:06 -0500
-Subject: [PATCH 2/2] wayland: Only do cursor name fallback for standard names
-
-Always returning a left_ptr if we can't find anything better
-broke firefox application-specific fallback for missing cursors.
-Keep that working by only doing the fallback for the CSS cursor
-names, not for things like hashes.
-
-https://bugzilla.gnome.org/show_bug.cgi?id=760141
----
- gdk/wayland/gdkcursor-wayland.c | 29 +++++++++++++++++++++--------
- 1 file changed, 21 insertions(+), 8 deletions(-)
-
-diff --git a/gdk/wayland/gdkcursor-wayland.c b/gdk/wayland/gdkcursor-wayland.c
-index 8aee5ae..bdfa316 100644
---- a/gdk/wayland/gdkcursor-wayland.c
-+++ b/gdk/wayland/gdkcursor-wayland.c
-@@ -87,17 +87,23 @@ static const struct {
-   const gchar *css_name, *traditional_name;
- } name_map[] = {
-   { "default",      "left_ptr" },
-+  { "help",         "left_ptr" },
-+  { "context-menu", "left_ptr" },
-   { "pointer",      "hand" },
-   { "progress",     "left_ptr_watch" },
-   { "wait",         "watch" },
-   { "cell",         "crosshair" },
-   { "crosshair",    "cross" },
-   { "text",         "xterm" },
-+  { "vertical-text","xterm" },
-   { "alias",        "dnd-link" },
-   { "copy",         "dnd-copy" },
-+  { "move",         "dnd-move" },
-   { "no-drop",      "dnd-none" },
-   { "not-allowed",  "crossed_circle" },
-   { "grab",         "hand2" },
-+  { "grabbing",     "hand2" },
-+  { "all-scroll",   "left_ptr" },
-   { "col-resize",   "h_double_arrow" },
-   { "row-resize",   "v_double_arrow" },
-   { "n-resize",     "top_side" },
-@@ -112,6 +118,8 @@ static const struct {
-   { "ns-resize",    "v_double_arrow" },
-   { "nesw-resize",  "fd_double_arrow" },
-   { "nwse-resize",  "bd_double_arrow" },
-+  { "zoom-in",      "left_ptr" },
-+  { "zoom-out",     "left_ptr" },
-   { NULL, NULL }
- };
- 
-@@ -126,7 +134,7 @@ name_fallback (const gchar *name)
-         return name_map[i].traditional_name;
-     }
- 
--  return "left_ptr";
-+  return NULL;
- }
- 
- static gboolean
-@@ -144,17 +152,22 @@ _gdk_wayland_cursor_update (GdkWaylandDisplay *wayland_display,
-                                                         cursor->scale);
-   c = wl_cursor_theme_get_cursor (theme, cursor->name);
-   if (!c)
--    c = wl_cursor_theme_get_cursor (theme, name_fallback (cursor->name));
-+    {
-+      const char *fallback;
-+
-+      fallback = name_fallback (cursor->name);
-+      if (fallback)
-+        {
-+          c = wl_cursor_theme_get_cursor (theme, name_fallback (cursor->name));
-+          if (!c)
-+            c = wl_cursor_theme_get_cursor (theme, "left_ptr");
-+        }
-+    }
- 
-   if (!c)
-     {
-       g_warning (G_STRLOC ": Unable to load %s from the cursor theme", cursor->name);
--
--      /* return the left_ptr cursor as a fallback */
--      c = wl_cursor_theme_get_cursor (theme, "left_ptr");
--
--      if (!c)
--        return FALSE;
-+      return FALSE;
-     }
- 
-   cursor->wl_cursor = c;
--- 
-2.7.0
-
diff --git a/abs/extra/gtk3/PKGBUILD b/abs/extra/gtk3/PKGBUILD
index 15dc342..bd062d0 100644
--- a/abs/extra/gtk3/PKGBUILD
+++ b/abs/extra/gtk3/PKGBUILD
@@ -1,74 +1,82 @@
-# $Id$
-# Maintainer: Ionut Biru <ibiru@archlinux.org>
 # Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor: Ionut Biru <ibiru@archlinux.org>
 
 pkgbase=gtk3
 pkgname=(gtk3 gtk-update-icon-cache)
-pkgver=3.18.6
-pkgrel=2
+pkgver=3.24.4+15+g80b5024239
+pkgrel=1
 pkgdesc="GObject-based multi-platform GUI toolkit"
-arch=(i686 x86_64)
-url="http://www.gtk.org/"
-depends=(atk cairo libcups libxcursor libxinerama libxrandr libxi libepoxy gdk-pixbuf2
-         libxcomposite libxdamage pango shared-mime-info colord at-spi2-atk wayland libxkbcommon
-         adwaita-icon-theme json-glib rest librsvg)
-makedepends=(gobject-introspection libcanberra)
+arch=(x86_64)
+url="https://www.gtk.org/"
+depends=(atk cairo libxcursor libxinerama libxrandr libxi libepoxy gdk-pixbuf2 dconf
+         libxcomposite libxdamage pango shared-mime-info at-spi2-atk wayland libxkbcommon
+         adwaita-icon-theme json-glib librsvg wayland-protocols desktop-file-utils mesa
+         cantarell-fonts colord rest libcups libcanberra)
+makedepends=(gobject-introspection gtk-doc git glib2-docs sassc)
 license=(LGPL)
-source=(https://download.gnome.org/sources/gtk+/${pkgver:0:4}/gtk+-$pkgver.tar.xz
-        0001-x11-Only-do-cursor-name-fallback-for-standard-names.patch
-        0002-wayland-Only-do-cursor-name-fallback-for-standard-na.patch
-        settings.ini)
-sha256sums=('78cabf0fd5a662f8723f62d5ac633072c76c557c1d700454c9c3deaa37e441ef'
-            '0402c3b7801810beb0f24ad20e4fb2eb7519cf3984f39e093a6e2752a0f7d9de'
-            '94722b06284e76f628fc8933617ac19c14f6775a5250fe3c382defab63d7b10e'
-            '01fc1d81dc82c4a052ac6e25bf9a04e7647267cc3017bc91f9ce3e63e5eb9202')
+_commit=80b5024239ee358ede8203666dfe9ea790a29b70  # gtk-3-24
+source=("git+https://gitlab.gnome.org/GNOME/gtk.git#commit=$_commit"
+        settings.ini
+        gtk-query-immodules-3.0.hook
+        gtk-update-icon-cache.hook
+        gtk-update-icon-cache.script)
+sha256sums=('SKIP'
+            '01fc1d81dc82c4a052ac6e25bf9a04e7647267cc3017bc91f9ce3e63e5eb9202'
+            'de46e5514ff39a7a65e01e485e874775ab1c0ad20b8e94ada43f4a6af1370845'
+            '496064a9dd6214bd58f689dd817dbdc4d7f17d42a8c9940a87018c3f829ce308'
+            'f1d3a0dbfd82f7339301abecdbe5f024337919b48bd0e09296bb0e79863b2541')
 
-prepare() {
-    cd gtk+-$pkgver
+pkgver() {
+  cd gtk
+  git describe --tags | sed 's/-/+/g'
+}
 
-    # Fix zoom in/out cursors in GTK3 builds of Firefox
-    # https://bugzilla.gnome.org/show_bug.cgi?id=760141
-    patch -Np1 -i ../0001-x11-Only-do-cursor-name-fallback-for-standard-names.patch
-    patch -Np1 -i ../0002-wayland-Only-do-cursor-name-fallback-for-standard-na.patch
+prepare() {
+  cd gtk
+  NOCONFIGURE=1 ./autogen.sh
 }
 
 build() {
-    cd "gtk+-$pkgver"
+  cd gtk
 
-    CXX=/bin/false ./configure --prefix=/usr \
-        --sysconfdir=/etc \
-        --localstatedir=/var \
-        --disable-schemas-compile \
-        --enable-x11-backend \
-        --enable-broadway-backend \
-        --enable-wayland-backend
+  ./configure --prefix=/usr \
+    --sysconfdir=/etc \
+    --localstatedir=/var \
+    --disable-schemas-compile \
+    --enable-x11-backend \
+    --enable-broadway-backend \
+    --enable-wayland-backend \
+    --disable-gtk-doc
 
-    #https://bugzilla.gnome.org/show_bug.cgi?id=655517
-    sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+  #https://bugzilla.gnome.org/show_bug.cgi?id=655517
+  sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
 
-    make
+  make
 }
 
 package_gtk3() {
-    depends+=(gtk-update-icon-cache)
-    optdepends=('libcanberra: gtk3-widget-factory demo')
-    install=gtk3.install
+  depends+=(gtk-update-icon-cache)
+  provides=(gtk3-print-backends)
+  conflicts=(gtk3-print-backends)
+  replaces=("gtk3-print-backends<=3.22.26-1")
+  install=gtk3.install
+
+  DESTDIR="$pkgdir" make -C gtk install
 
-    cd "gtk+-$pkgver"
-    make DESTDIR="$pkgdir" install
-    install -Dm644 ../settings.ini "$pkgdir/usr/share/gtk-3.0/settings.ini"
+  install -Dt "$pkgdir/usr/share/gtk-3.0" -m644 settings.ini
+  install -Dt "$pkgdir/usr/share/libalpm/hooks" -m644 gtk-query-immodules-3.0.hook
 
-    # split this out to use with gtk2 too
-    rm "$pkgdir/usr/bin/gtk-update-icon-cache"
+  # split this out to use with gtk2 too
+  mv "$pkgdir/usr/bin/gtk-update-icon-cache" "$srcdir"
 }
 
 package_gtk-update-icon-cache() {
-    pkgdesc="GTK+ icon cache updater"
-    depends=(gdk-pixbuf2 hicolor-icon-theme)
-    install=gtk-update-icon-cache.install
+  pkgdesc="GTK+ icon cache updater"
+  depends=(gdk-pixbuf2 librsvg hicolor-icon-theme)
 
-    cd gtk+-$pkgver/gtk
-    install -Dm755 gtk-update-icon-cache "$pkgdir/usr/bin/gtk-update-icon-cache"
+  install -Dt "$pkgdir/usr/bin" gtk-update-icon-cache
+  install -Dt "$pkgdir/usr/share/libalpm/hooks" -m644 gtk-update-icon-cache.hook
+  install -D gtk-update-icon-cache.script "$pkgdir/usr/share/libalpm/scripts/gtk-update-icon-cache"
 }
 
-# vim:set et sw=4:
+# vim:set ts=2 sw=2 et:
diff --git a/abs/extra/gtk3/gtk-query-immodules-3.0.hook b/abs/extra/gtk3/gtk-query-immodules-3.0.hook
new file mode 100644
index 0000000..c7703cf
--- /dev/null
+++ b/abs/extra/gtk3/gtk-query-immodules-3.0.hook
@@ -0,0 +1,11 @@
+[Trigger]
+Type = File
+Operation = Install
+Operation = Upgrade
+Operation = Remove
+Target = usr/lib/gtk-3.0/3.0.0/immodules/*.so
+
+[Action]
+Description = Probing GTK3 input method modules...
+When = PostTransaction
+Exec = /usr/bin/gtk-query-immodules-3.0 --update-cache
diff --git a/abs/extra/gtk3/gtk-update-icon-cache.hook b/abs/extra/gtk3/gtk-update-icon-cache.hook
new file mode 100644
index 0000000..fca3fdc
--- /dev/null
+++ b/abs/extra/gtk3/gtk-update-icon-cache.hook
@@ -0,0 +1,13 @@
+[Trigger]
+Type = File
+Operation = Install
+Operation = Upgrade
+Operation = Remove
+Target = usr/share/icons/*/
+Target = !usr/share/icons/*/?*
+
+[Action]
+Description = Updating icon theme caches...
+When = PostTransaction
+Exec = /usr/share/libalpm/scripts/gtk-update-icon-cache
+NeedsTargets
diff --git a/abs/extra/gtk3/gtk-update-icon-cache.install b/abs/extra/gtk3/gtk-update-icon-cache.install
deleted file mode 100644
index 1afcc72..0000000
--- a/abs/extra/gtk3/gtk-update-icon-cache.install
+++ /dev/null
@@ -1,3 +0,0 @@
-post_install() {
-  gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
-}
diff --git a/abs/extra/gtk3/gtk-update-icon-cache.script b/abs/extra/gtk3/gtk-update-icon-cache.script
new file mode 100644
index 0000000..ee0f1d1
--- /dev/null
+++ b/abs/extra/gtk3/gtk-update-icon-cache.script
@@ -0,0 +1,10 @@
+#!/bin/bash
+
+while read -r f; do
+  if [[ -e ${f}index.theme ]]; then
+    gtk-update-icon-cache -q "$f"
+  elif [[ -d $f ]]; then
+    rm -f "${f}icon-theme.cache"
+    rmdir --ignore-fail-on-non-empty "$f"
+  fi
+done
diff --git a/abs/extra/gtk3/gtk3.install b/abs/extra/gtk3/gtk3.install
index f57b1bf..c0c4453 100644
--- a/abs/extra/gtk3/gtk3.install
+++ b/abs/extra/gtk3/gtk3.install
@@ -1,18 +1,3 @@
-post_install() {
-    /usr/bin/gtk-query-immodules-3.0 --update-cache
-    /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas
-    /usr/bin/gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
-}
-
-post_upgrade() {
-    post_install
-}
-
 pre_remove() {
     rm -f /usr/lib/gtk-3.0/3.0.0/immodules.cache
 }
-
-post_remove() {
-    /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas
-    /usr/bin/gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
-}
-- 
cgit v0.12