From 30389cf99f1c91e32a6966e2668fe358139a329a Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Wed, 13 Jan 2016 20:22:22 +0000
Subject: LinHES-system: add /etc/X11/autostart/autostart.run

---
 abs/core/LinHES-system/PKGBUILD      | 8 +++++---
 abs/core/LinHES-system/autostart.run | 7 +++++++
 2 files changed, 12 insertions(+), 3 deletions(-)
 create mode 100644 abs/core/LinHES-system/autostart.run

diff --git a/abs/core/LinHES-system/PKGBUILD b/abs/core/LinHES-system/PKGBUILD
index c700861..26fc453 100755
--- a/abs/core/LinHES-system/PKGBUILD
+++ b/abs/core/LinHES-system/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-system
 pkgver=8.3
-pkgrel=22
+pkgrel=23
 arch=('i686' 'x86_64')
 install=system.install
 pkgdesc="Everything that makes LinHES an automated system"
@@ -10,7 +10,7 @@ depends=('linhes-sounds' 'xdotool' 'tilda' 'keylaunch'
         'python2-dbus' 'unclutter' 'wmctrl' 'archlinux-xdg-menu'
         'ethtool' 'gnu-netcat' 'normalize' 'ttf-overlock'
         'handbrake-cli' 'mkvtoolnix' 'mplayer' 'runit-scripts>=8.1-12')
-backup=('etc/modprobe.d/alsa-base.conf')
+backup=('etc/modprobe.d/alsa-base.conf' 'etc/X11/autostart/autostart.run')
 binfiles="LinHES-start optimize_mythdb.py myth_mtc.py
  load-modules-mythvantage.sh unclutter-toggle.sh tvterm.sh
  mythfrontend-start set_windowmanager.sh myth_status.py myth_status.sh
@@ -28,7 +28,7 @@ binfiles="LinHES-start optimize_mythdb.py myth_mtc.py
  linhes_update.sh linhes_update2.sh myth2mkv myth2mp3 ripD_eject.sh
  mythwelcome-config.py mythwelcome-set-alarm.sh mythwelcome-test-wakeup.sh"
 
-source=(LinHES-session LinHES-profile.sh $binfiles
+source=(LinHES-session autostart.run LinHES-profile.sh $binfiles
     alsa-base cacheclean.cron fstrim.cron myth_mtc.cron xfs_defrag.cron etc_care.cron
     readme_is_xml readme_light add_storage.readme
     system-sudo.rules msg.cfg)
@@ -40,6 +40,7 @@ package() {
     BINDIR=$pkgdir/usr/bin
 
     install -m755 -D LinHES-session $pkgdir/etc/X11/Sessions/LinHES
+    install -m755 -D autostart.run $pkgdir/etc/X11/autostart/autostart.run
     install -m755 -D LinHES-profile.sh $pkgdir/etc/profile.d/LinHES-profile.sh
     
     #files install to /usr/LH/bin
@@ -79,6 +80,7 @@ package() {
 }
 
 md5sums=('76842f8cff548d2c1289e0992a8b84dd'
+         'ad5e144999b6f37931dea799c2761c7e'
          'de32a1c50101265dd7f6ca5037f7a26a'
          '2d7b8414ddce5f401331342ac1529c22'
          '76b2637cac0452b3acdbeeb4e8a5474b'
diff --git a/abs/core/LinHES-system/autostart.run b/abs/core/LinHES-system/autostart.run
new file mode 100644
index 0000000..278bc2b
--- /dev/null
+++ b/abs/core/LinHES-system/autostart.run
@@ -0,0 +1,7 @@
+#!/bin/bash
+# autostart.run runs after X has started.
+# Put startup commands for scripts and programs in this file.
+# Any files with execute permission in /etc/X11/autostart will also be run
+#   when X starts.
+# Scripts and programs that don't require X can be started from
+#   /etc/runit/1.local.
-- 
cgit v0.12