From 4d67ee347d2b9d46841b9d75ebee8039d1d0b445 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Thu, 1 Mar 2018 17:38:59 +0000
Subject: python-cryptography: update to 2.1.4

---
 .../python_modules/python-cryptography/PKGBUILD    | 61 ++++++++++++----------
 .../python_modules/python-cryptography/__changelog |  1 -
 2 files changed, 32 insertions(+), 30 deletions(-)
 delete mode 100644 abs/core/python_modules/python-cryptography/__changelog

diff --git a/abs/core/python_modules/python-cryptography/PKGBUILD b/abs/core/python_modules/python-cryptography/PKGBUILD
index d336c94..e578a2e 100644
--- a/abs/core/python_modules/python-cryptography/PKGBUILD
+++ b/abs/core/python_modules/python-cryptography/PKGBUILD
@@ -2,51 +2,54 @@
 # Maintainer: Felix Yan <felixonmars@archlinux.org>
 
 pkgbase=python-cryptography
-pkgname=('python2-cryptography')
-pkgver=1.3.1
+pkgname=('python-cryptography' 'python2-cryptography')
+pkgver=2.1.4
 pkgrel=1
 pkgdesc="A package designed to expose cryptographic recipes and primitives to Python developers"
-arch=('i686' 'x86_64')
+arch=('x86_64')
 license=('Apache')
 url="http://pypi.python.org/pypi/cryptography"
-makedepends=('python2-setuptools' 'python2-six' 'python2-cffi' 'python2-enum34'
-             'python2-pyasn1' 'python2-idna' 'python2-ipaddress')
-checkdepends=('python2-pytest-runner' "python2-cryptography-vectors=$pkgver"
-              'python2-iso8601' 'python2-pretend' 'python2-pyasn1-modules'
-              'python2-hypothesis')
-source=("http://pypi.python.org/packages/source/c/cryptography/cryptography-$pkgver.tar.gz")
-md5sums=('bc8148d2ff2d80fef8ef2d2e856b3a7f')
+makedepends=('python-setuptools' 'python2-setuptools' 'python-six' 'python2-six' 'python-cffi'
+             'python2-cffi' 'python2-enum34' 'python-pyasn1' 'python2-pyasn1' 'python-idna'
+             'python2-idna' 'python2-ipaddress' 'python-asn1crypto' 'python2-asn1crypto')
+checkdepends=('python-pytest-runner' 'python2-pytest-runner' "python-cryptography-vectors=$pkgver"
+              "python2-cryptography-vectors=$pkgver" 'python-iso8601' 'python2-iso8601'
+              'python-pretend' 'python2-pretend' 'python-hypothesis' 'python2-hypothesis'
+              'python-pytz' 'python2-pytz')
+source=("https://pypi.io/packages/source/c/cryptography/cryptography-$pkgver.tar.gz")
+sha512sums=('f749cb4384badc174a842514e5a4fee2ed01ab9c716799d8d9d5301f6d2d97b6c41deb9e425f48928b639fa34bef8c05529ed7e5b777ef5ca75c244f8fda8fd4')
 
 prepare() {
   cp -a cryptography-${pkgver}{,-python2}
 }
 
 build() {
-   cd "$srcdir"/cryptography-$pkgver
-#   python setup.py build
- 
-   cd "$srcdir"/cryptography-$pkgver-python2
-   python2 setup.py build
+  cd "$srcdir"/cryptography-$pkgver
+  python setup.py build
+
+  cd "$srcdir"/cryptography-$pkgver-python2
+  python2 setup.py build
 }
 
 check() {
-   cd "$srcdir"/cryptography-$pkgver
-   PYTHONPATH="$PWD/build/lib.linux-$CARCH-3.5:$PYTHONPATH" python setup.py ptr
+  cd "$srcdir"/cryptography-$pkgver
+  python setup.py pytest
 
-   cd "$srcdir"/cryptography-$pkgver-python2
-   PYTHONPATH="$PWD/build/lib.linux-$CARCH-2.7:$PYTHONPATH" python2 setup.py ptr
+  cd "$srcdir"/cryptography-$pkgver-python2
+  python2 setup.py pytest
 }
- 
+
 package_python-cryptography() {
-   depends=('python-pyasn1' 'python-six' 'python-cffi' 'python-idna')
- 
-   cd cryptography-$pkgver
-   python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+  depends=('python-six' 'python-cffi' 'python-idna' 'python-setuptools' 'python-asn1crypto')
+
+  cd cryptography-$pkgver
+  python setup.py install --root="$pkgdir" --optimize=1 --skip-build
 }
- 
+
 package_python2-cryptography() {
-   depends=('python2-pyasn1' 'python2-six' 'python2-cffi' 'python2-enum34' 'python2-idna' 'python2-ipaddress')
- 
-   cd cryptography-$pkgver-python2
-   python2 setup.py install --root="$pkgdir" --optimize=1 --skip-build
+  depends=('python2-six' 'python2-cffi' 'python2-enum34' 'python2-idna' 'python2-ipaddress'
+           'python2-setuptools' 'python2-asn1crypto')
+
+  cd cryptography-$pkgver-python2
+  python2 setup.py install --root="$pkgdir" --optimize=1 --skip-build
 }
diff --git a/abs/core/python_modules/python-cryptography/__changelog b/abs/core/python_modules/python-cryptography/__changelog
deleted file mode 100644
index 488d3cf..0000000
--- a/abs/core/python_modules/python-cryptography/__changelog
+++ /dev/null
@@ -1 +0,0 @@
-PKGBUILD: rm py 3 stuff
-- 
cgit v0.12