From 47370d32cc936953ca5121de009eebb297b1c8db Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Mon, 1 Dec 2014 18:55:06 +0000
Subject: pango: update to 1.36.8. dep of gtk3

---
 abs/core/pango/PKGBUILD      | 18 ++++++++++--------
 abs/core/pango/pango.install |  9 +--------
 2 files changed, 11 insertions(+), 16 deletions(-)

diff --git a/abs/core/pango/PKGBUILD b/abs/core/pango/PKGBUILD
index b07ef9c..3adc9a6 100644
--- a/abs/core/pango/PKGBUILD
+++ b/abs/core/pango/PKGBUILD
@@ -1,23 +1,24 @@
-# $Id: PKGBUILD 161372 2012-06-10 10:55:15Z jgc $ 
+# $Id$ 
 # Maintainer: Jan de Groot <jgc@archlinux.org>
 
 pkgname=pango
-pkgver=1.30.1
+pkgver=1.36.8
 pkgrel=1
 pkgdesc="A library for layout and rendering of text"
 arch=('i686' 'x86_64')
 license=('LGPL')
-depends=('glib2' 'cairo' 'libxft' 'libthai' 'freetype2')
-makedepends=('gobject-introspection' 'libxt' 'gtk-doc')
-options=('!libtool' '!emptydirs')
+depends=('libthai' 'cairo' 'libxft' 'harfbuzz')
+makedepends=('harfbuzz' 'fontconfig' 'cairo' 'libxft' 'libthai' 'gobject-introspection' 'help2man' 'python2')
 install=pango.install
-source=(http://ftp.gnome.org/pub/gnome/sources/${pkgname}/${pkgver:0:4}/${pkgname}-${pkgver}.tar.xz)
+source=(http://download.gnome.org/sources/${pkgname}/${pkgver:0:4}/${pkgname}-${pkgver}.tar.xz)
 url="http://www.pango.org/"
-sha256sums=('3a8c061e143c272ddcd5467b3567e970cfbb64d1d1600a8f8e62435556220cbe')
+sha256sums=('18dbb51b8ae12bae0ab7a958e7cf3317c9acfc8a1e1103ec2f147164a0fc2d07')
 
 build() {
   cd ${pkgname}-${pkgver}
 
+  rm -f pango-view/pango-view.1.in
+
   ./configure --prefix=/usr --sysconfdir=/etc \
       --localstatedir=/var --with-included-modules=basic-fc
   make
@@ -25,5 +26,6 @@ build() {
 
 package() {
   cd ${pkgname}-${pkgver}
-  make DESTDIR="${pkgdir}" install
+  make -j1 DESTDIR="${pkgdir}" install
+  install -m755 -d "${pkgdir}/etc/pango"
 }
diff --git a/abs/core/pango/pango.install b/abs/core/pango/pango.install
index 73b0f5b..4aa7c4d 100644
--- a/abs/core/pango/pango.install
+++ b/abs/core/pango/pango.install
@@ -1,21 +1,14 @@
-# arg 1:  the new package version
 post_install() {
-	# we need to ldconfig first, in case xfree86's libs aren't
-	# in ld.so.cache yet
-	sbin/ldconfig -r .
 	usr/bin/pango-querymodules >etc/pango/pango.modules
 }
 
-# arg 1:  the new package version
-# arg 2:  the old package version
 post_upgrade() {
 	if [ -f usr/etc/pango/pango.modules ]; then
 		rm usr/etc/pango/pango.modules
 	fi
-	post_install $1
+	post_install
 }
 
-# arg 1:  the old package version
 pre_remove() {
 	rm etc/pango/pango.modules
 }
-- 
cgit v0.12