# $Id$
# Maintainer: Allan McRae <allan@archlinux.org>
# Contributor: Judd Vinet <jvinet@zeroflux.org>

pkgname=libjpeg
pkgver=7
pkgrel=1
pkgdesc="Library of JPEG support functions"
arch=('i686' 'x86_64')
url="http://www.ijg.org/"
license=('custom')
depends=('glibc')
makedepends=('libtool')
options=(!libtool)
source=(http://www.ijg.org/files/jpegsrc.v7.tar.gz)
md5sums=('382ef33b339c299b56baf1296cda9785')

build() {
  cd $srcdir/jpeg-$pkgver
  ./configure --prefix=/usr --enable-shared --enable-static
  make || return 1
  make prefix=$pkgdir/usr mandir=$pkgdir/usr/share/man install
  
  # See FS#11116 - re-assess need with v7 release sometime...
  install -m644 jpegint.h $pkgdir/usr/include

  install -Dm644 README $pkgdir/usr/share/licenses/libjpeg/README
}