# Contributor: Hugo Ideler <hugoideler@dse.nl>

pkgname=libstatgrab
pkgver=0.14
pkgrel=1
pkgdesc="A library that provides cross platform access to statistics about the system on which it's run"
url="http://www.i-scream.org/libstatgrab"
license=""
depends=()
makedepends=()
conflicts=()
replaces=()
backup=()
arch=('i686')
install=
source=(ftp://ftp.uk.i-scream.org/pub/i-scream/libstatgrab/$pkgname-$pkgver.tar.gz)

build() {
  cd $startdir/src/$pkgname-$pkgver
  ./configure --prefix=/usr
  make || return 1

#What you get when people make broken Makefiles...
sed -i -e 's:chown root ${exec_prefix}/bin/statgrab::' ./src/statgrab/Makefile 
sed -i -e 's:chmod u+s ${exec_prefix}/bin/statgrab::' ./src/statgrab/Makefile 
sed -i -e 's:chown root ${exec_prefix}/bin/saidar::' ./src/saidar/Makefile 
sed -i -e 's:chmod u+s ${exec_prefix}/bin/saidar::' ./src/saidar/Makefile 
  make DESTDIR=$startdir/pkg install
#MAKE="make DESTDIR=$startdir/pkg prefix=$startdir/pkg"
}