# Contributor: Stefano Zamprogno <stefano dot zamprogno at gmail dot com>
# Contributor: Chuck Yang <Chuck.Yang@gmail.com>

pkgname=lshw
pkgver=B.02.13
pkgrel=1
pkgdesc="A small tool to provide detailed information on the hardware configuration of the machine."
url="http://ezix.org/project/wiki/HardwareLiSter"
license=('GPL')
source=(http://ezix.org/software/files/lshw-B.02.13.tar.gz abi_stdlib.diff)
md5sums=('e94c728ed037ca706436b5ef71aa392d' '8696f9e8ecb71bedf374b538e8634d2d')
arch=('i686' 'x86_64')
depends=('gtk2')
makedepends=('gcc')

build() {
	cd $startdir/src/$pkgname-$pkgver

	patch -Np0 -i ../abi_stdlib.diff || return 1

	make || return 1
	make gui || return 1
	make DESTDIR=$startdir/pkg/ install
	make DESTDIR=$startdir/pkg/ install-gui
}