# $Id$
# Maintainer:

pkgname=perl-data-dump
pkgver=1.23
pkgrel=1
pkgdesc="Pretty printing of data structures"
arch=(any)
url="https://metacpan.org/release/Data-Dump"
license=(PerlArtistic GPL)
depends=('perl')
options=(!emptydirs)
source=("http://search.cpan.org/CPAN/authors/id/G/GA/GAAS/Data-Dump-${pkgver}.tar.gz")
sha1sums=('7da875cde34b6fe32b680eaa0c70121e4b69f09b')
sha1sums=('3f5c0d4a15c8dd6befbcdceb41fe15b9aef1b741')

build() {
  cd Data-Dump-${pkgver}
  perl Makefile.PL INSTALLDIRS=vendor
  make
}

check() {
  cd Data-Dump-${pkgver}
  make test
}

package() {
  cd Data-Dump-${pkgver}
  make DESTDIR="$pkgdir" install
}