# $Id$
# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
# Maintainer: Charles Mauch <cmauch@gmail.com>
# Contributor: Francois Charette <firmicus@gmx.net>

pkgname=perl-file-remove
pkgver=1.57
pkgrel=2
pkgdesc="Remove files and directories"
depends=('perl')
arch=('any')
url="http://search.cpan.org/dist/File-Remove"
license=('GPL' 'PerlArtistic')
options=('!emptydirs')
source=(http://search.cpan.org/CPAN/authors/id/S/SH/SHLOMIF/File-Remove-$pkgver.tar.gz)
md5sums=('fe7da64339206d6568037209a577724f')

build() {
  cd  "$srcdir"/File-Remove-$pkgver
  PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
  make
}

package() {
  cd  "$srcdir"/File-Remove-$pkgver
  make install DESTDIR="$pkgdir"
  find "$pkgdir" -name '.packlist' -delete
  find "$pkgdir" -name '*.pod' -delete
}