# $Id$
# Maintainer: Felix Yan <felixonmars@archlinux.org>
# Contributor: TDY <tdy@gmx.com>
# Contributor: François Charette <firmicus ατ gmx δοτ net>

pkgname=perl-par-dist
pkgver=0.49
pkgrel=3
pkgdesc="Perl bindings to create and manipulate PAR distributions"
arch=('any')
url="http://search.cpan.org/dist/PAR-Dist/"
license=('GPL' 'PerlArtistic')
depends=('perl')
options=('!emptydirs')
source=("http://search.cpan.org/CPAN/authors/id/R/RS/RSCHUPP/PAR-Dist-$pkgver.tar.gz")
md5sums=('bd852113974544f3c8c107ab4055cf8c')

build() {
  cd "$srcdir/PAR-Dist-$pkgver"
  PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
  make
}

check() {
  cd "$srcdir/PAR-Dist-$pkgver"
  make test
}

package() {
  cd "$srcdir/PAR-Dist-$pkgver"
  make install DESTDIR="$pkgdir"
}