# $Id$
# Maintainer: Jonathan Steel <jsteel@aur.archlinux.org>
# Contributor: Justin Davis (juster) <jrcd83@gmail.com>

pkgname=perl-sub-install
pkgver=0.928
pkgrel=3
pkgdesc="Install subroutines into packages easily"
arch=('any')
url="https://metacpan.org/release/Sub-Install"
license=('PerlArtistic' 'GPL')
depends=('perl')
options=('!emptydirs')
source=(http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/Sub-Install-$pkgver.tar.gz)
sha1sums=('868c6cb4c0232d9ac3f865f232359f82012be8d6')

build() {
  cd Sub-Install-$pkgver
  perl Makefile.PL INSTALLDIRS=vendor
  make
}

check() {
  cd Sub-Install-$pkgver
  make test
}

package() {
  cd Sub-Install-$pkgver
  make DESTDIR="$pkgdir" install
}