# $Id$
# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
# Maintainer: Charles Mauch <cmauch@gmail.com>

pkgname=perl-test-exception
pkgver=0.43
pkgrel=3
pkgdesc="Perl/CPAN Module Test::Exception : Functions for testing exceptionbased code"
arch=("any")
url="http://search.cpan.org/dist/Test-Exception/"
license=("GPL" "PerlArtistic")
depends=("perl-sub-uplevel")
source=("http://search.cpan.org/CPAN/authors/id/E/EX/EXODIST/Test-Exception-$pkgver.tar.gz")
md5sums=('572d355026fb0b87fc2b8c64b83cada0')

build() {
  cd "$srcdir"/Test-Exception-$pkgver
  PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
  make
}

package() {
  cd "$srcdir"/Test-Exception-$pkgver
  make install DESTDIR="$pkgdir"
  find "$pkgdir" -name '.packlist' -delete
  find "$pkgdir" -name '*.pod' -delete
}