# $Id$
# Maintainer: Jonathan Steel <jsteel@aur.archlinux.org>
# Contributor: Justin Davis (juster) <jrcd83@gmail.com>

pkgname=perl-test-fatal
pkgver=0.014
pkgrel=3
pkgdesc="Incredibly simple helpers for testing code with exceptions"
arch=('any')
url="https://metacpan.org/release/Test-Fatal"
license=('PerlArtistic' 'GPL')
depends=('perl-try-tiny')
options=('!emptydirs')
source=(http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/Test-Fatal-$pkgver.tar.gz)
sha1sums=('6984ef1c0aed1d2c8334e8f20818cbf269abc345')

build() {
  cd "$srcdir/Test-Fatal-$pkgver"
  perl Makefile.PL
  make
}

check() {
  cd "$srcdir/Test-Fatal-$pkgver"
  make test
}

package() {
  cd "$srcdir/Test-Fatal-$pkgver"
  make INSTALLDIRS=vendor DESTDIR="$pkgdir" install
}