# $Id$
# Maintainer: Jonathan Steel <jsteel@aur.archlinux.org>
# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
# Contributor: Justin Davis <jrcd83@gmail.com>

pkgname=perl-test-requires
pkgver=0.10
pkgrel=3
pkgdesc="Checks to see if the module can be loaded"
arch=('any')
license=('PerlArtistic' 'GPL')
options=('!emptydirs')
depends=('perl')
url='http://search.cpan.org/dist/Test-Requires'
source=("http://search.cpan.org/CPAN/authors/id/T/TO/TOKUHIROM/Test-Requires-$pkgver.tar.gz")
md5sums=('0d5da779609d0c8fa6f796b45ff8c6f3')

build() {
  cd "$srcdir"/Test-Requires-$pkgver
  perl Makefile.PL INSTALLDIRS=vendor
  make
}

check() {
  cd "$srcdir"/Test-Requires-$pkgver
  make test
}

package() {
  cd "$srcdir"/Test-Requires-$pkgver
  make DESTDIR="$pkgdir"/ install
}