# $Id: PKGBUILD 66104 2012-02-23 01:05:44Z spupykin $
# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
# Contributor: Francois Charette <firmicus@gmx.net>

pkgname=perl-www-mechanize
pkgver=1.72
pkgrel=1
pkgdesc="Automates web page form & link interaction"
arch=(any)
url="http://search.cpan.org/dist/WWW-Mechanize"
license=('GPL' 'PerlArtistic')
depends=('perl-libwww' 'perl-html-parser' 'perl-uri' 'perl-http-response-encoding'
	 'perl-http-server-simple' 'perl-test-warn' 'perl-html-form')
options=('!emptydirs')
source=(http://search.cpan.org/CPAN/authors/id/J/JE/JESSE/WWW-Mechanize-$pkgver.tar.gz)
md5sums=('231709669de7d912185b91e454206532')

build() {
  cd  $srcdir/WWW-Mechanize-$pkgver
  PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
  make
  make install DESTDIR=$pkgdir
  find $pkgdir -name '.packlist' -delete
  find $pkgdir -name '*.pod' -delete
}