pkgname=sudo
pkgver=1.7.0
pkgrel=3
pkgdesc="Give certain users the ability to run some commands as root"
arch=(i686 x86_64)
url="http://www.sudo.ws/sudo/"
# 2 separate licenses apply, custom and ISC, each covering part of the software
license=('custom' 'ISC')
depends=('glibc' 'pam')
backup=('etc/sudoers' 'etc/pam.d/sudo')
source=(ftp://ftp.sudo.ws/pub/sudo/$pkgname-$pkgver.tar.gz sudo.pam )
options=('!libtool' '!makeflags')

build() {
  cd $startdir/src/$pkgname-$pkgver || return 1

  ./configure --prefix=/usr --with-pam --libexecdir=/usr/lib \
    --with-env-editor --with-all-insults --with-logfac=auth || return 1
  make || return 1
  make DESTDIR=$startdir/pkg install || return 1
  install -D -m644 $startdir/src/sudo.pam $startdir/pkg/etc/pam.d/sudo \
  	|| return 1

  #install the license
  install -D -m644 LICENSE $startdir/pkg/usr/share/licenses/sudo/LICENSE \
  	|| return 1
}