# $Id$
# Maintainer: Alexander Rødseth <rodseth@gmail.com>
# Contributor: Tobias Powalowski <tpowa@archlinux.org>

pkgname=camlp4
pkgver=4.04
pkgrel=1
pkgdesc='Caml preprocessor and pretty-printer'
arch=('x86_64' 'i686')
license=('GPL2')
url='https://github.com/ocaml/camlp4/releases'
depends=('ocaml>=4.04.0')
makedepends=('git' 'ocamlbuild')
options=('!makeflags' '!emptydirs' 'staticlibs')
source=("git://github.com/ocaml/camlp4#branch=$pkgver")
md5sums=('SKIP')

build() {
  cd "$pkgname"

  ./configure
  make all camlp4/META
}

package() {
  make -C "$pkgname" \
    BINDIR="$pkgdir/usr/bin" \
    LIBDIR="$pkgdir/usr/lib/ocaml" \
    PKGDIR="$pkgdir/usr/lib/ocaml" \
    install install-META
}

# vim:set ts=2 sw=2 et: