# $Id: PKGBUILD 21081 2008-12-09 17:41:11Z alexanderf $
# Maintainer: Alexander Fehr <pizzapunk gmail com>

pkgname=htop
pkgver=0.8.1
pkgrel=1
pkgdesc="Interactive process viewer"
arch=('i686' 'x86_64')
url="http://htop.sourceforge.net/"
license=('GPL')
depends=('ncurses')
options=('!emptydirs')
source=(http://downloads.sourceforge.net/htop/htop-$pkgver.tar.gz
        htop-treeview.patch)
md5sums=('f0b259ca29175656de48bf0fa0a2e619'
         '54613e5237592691da8903fae05780d9')

build() {
  cd "$srcdir/htop-$pkgver"

  # Fix tree view
  # http://sourceforge.net/tracker2/?func=detail&aid=2343835&group_id=108839&atid=651635
  patch -Np1 -i "$srcdir/htop-treeview.patch" || return 1

  ./configure --prefix=/usr --enable-unicode || return 1
  make || return 1
  make DESTDIR="$pkgdir" install || return 1
}