# Maintainer: Andrew Cook <ariscop@gmail.com>

pkgname=libbluray-git
pkgver=20101110
pkgrel=1
pkgdesc="Blu-Ray access library"
arch=('i686' 'x86_64')
depends=('doxygen')
license=('LGPL')
url="http://www.videolan.org/developers/libbluray.html"
makedepends=('git')
source=()
md5sums=()
provides=('libbluray')
conflicts=('libbluray')

_gitroot="git://git.videolan.org/libbluray.git"
_gitname="libbluray"

build() {
    msg "Connecting to GIT server..."

    if [ -d ${srcdir}/$_gitname ] ; then
        cd $_gitname && git pull origin
        msg "The local files are updated."
    else
        git clone $_gitroot
    fi
    
    msg "GIT checkout done or server timeout"
    msg "Starting make..."

    cd ${srcdir}/libbluray
    ./bootstrap
    ./configure --prefix=/
    make || return 1
    make DESTDIR=${pkgdir}/usr install || return 1    
}