# $Id$
# Maintainer: Jan de Groot <jgc@archlinux.org>
# Contributor: William Rea <sillywilly@gmail.com>

pkgname=libnl
pkgver=1.1
pkgrel=3
pkgdesc="Library for applications dealing with netlink sockets"
arch=('i686' 'x86_64')
url="http://www.infradead.org/~tgr/libnl/"
license=('GPL')
depends=('glibc')
source=("http://www.infradead.org/~tgr/libnl/files/${pkgname}-${pkgver}.tar.gz"
        'fix-compilation.patch')

build() {
  cd ${srcdir}/libnl-${pkgver}
  patch -Np1 -i ${srcdir}/fix-compilation.patch
  ./configure --prefix=/usr
  make
}

package() {
  cd ${srcdir}/libnl-${pkgver}
  make DESTDIR=${pkgdir} install
}
md5sums=('ae970ccd9144e132b68664f98e7ceeb1'
         '2490289a9edcc5c03802d151bcf3acc4')