# Maintainer: Daenyth <Daenyth+Arch [at] gmail [dot] com>
# Contributor: Angel 'angvp' Velasquez <angvp[at]archlinux.com.ve>
# Contributor: kagan <juanynie@mi.madritel.es>
pkgname=mednafen
pkgver=0.8.D
pkgrel=1
pkgdesc="A command-line multi-system gaming emulator"
url="http://mednafen.sourceforge.net/"
license=(GPL)
arch=('i686' 'x86_64')
depends=('libcdio>=0.82' 'libsamplerate' 'libogg' 'libvorbis' 'sdl' 'sdl_net' 'libsndfile' 'zlib')
makedepends=('pkgconfig' 'mesa')
source=(http://downloads.sourceforge.net/mednafen/$pkgname-$pkgver.tar.bz2 fix_build.diff)
md5sums=('4c3f337f80bf54d2df0f3a0f24203141'
         '0f44ef41b0220b66579626548d044f15')

build() {
  cd $srcdir/$pkgname
  patch -Np1 -i $srcdir/fix_build.diff || return 1
  ./configure --prefix=/usr || return 1
  make || return 1
  make DESTDIR=$pkgdir install
}