# $Id$
# Maintainer : Ionut Biru <ibiru@archlinux.org>
# Contributor: Timm Preetz <timm@preetz.us>

pkgname=vala
pkgver=0.30.0
pkgrel=1
pkgdesc="Compiler for the GObject type system"
arch=('i686' 'x86_64')
url="http://live.gnome.org/Vala"
license=('LGPL')
depends=('glib2')
makedepends=('libxslt')
checkdepends=('dbus' 'libx11' 'gobject-introspection')
source=(https://download.gnome.org/sources/$pkgname/${pkgver:0:4}/$pkgname-$pkgver.tar.xz)
sha256sums=('61f0337b000f7ed6ef8c1fea87e0047d9bd7c0f91dd9c5b4eb70fd3fb883dedf')

build() {
    cd $pkgname-$pkgver
    ./configure --prefix=/usr --enable-vapigen
    make
}

check() {
    cd $pkgname-$pkgver
#    make check
}

package() {
    cd $pkgname-$pkgver
    make DESTDIR="$pkgdir" install
}