summaryrefslogtreecommitdiffstats
path: root/abs/chroot-devel/thunar/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2008-10-04 04:07:38 (GMT)
committerJames Meyer <james.meyer@operamail.com>2008-10-04 04:07:38 (GMT)
commitdb40f2ab304cc32d9a69ee215727c8663b757c53 (patch)
tree02437908944190186e1ab040fcf5f13c80fbc316 /abs/chroot-devel/thunar/PKGBUILD
parentea26ba87276362ba1e99ececcb9e802ab2bd8776 (diff)
downloadlinhes_pkgbuild-db40f2ab304cc32d9a69ee215727c8663b757c53.zip
linhes_pkgbuild-db40f2ab304cc32d9a69ee215727c8663b757c53.tar.gz
linhes_pkgbuild-db40f2ab304cc32d9a69ee215727c8663b757c53.tar.bz2
adding tools for chroot-devel
Diffstat (limited to 'abs/chroot-devel/thunar/PKGBUILD')
-rw-r--r--abs/chroot-devel/thunar/PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/abs/chroot-devel/thunar/PKGBUILD b/abs/chroot-devel/thunar/PKGBUILD
new file mode 100644
index 0000000..bc05564
--- /dev/null
+++ b/abs/chroot-devel/thunar/PKGBUILD
@@ -0,0 +1,31 @@
+
+pkgname=thunar
+pkgver=0.9.0
+pkgrel=2
+pkgdesc="new modern file manager for Xfce"
+arch=(i686 x86_64)
+license=('GPL2' 'LGPL2')
+url="http://thunar.xfce.org"
+groups=('xfce4')
+depends=('exo>=0.3.4' 'shared-mime-info' 'pcre' \
+ 'desktop-file-utils' 'libexif' 'hal' \
+ )
+makedepends=('intltool' 'pkgconfig')
+options=('!libtool')
+install=${pkgname}.install
+source=(http://www.xfce.org/archive/xfce-4.4.2/src/Thunar-${pkgver}.tar.bz2 \
+ http://foo-projects.org/pipermail/thunar-dev/attachments/20071203/a44d5411/thunar-vfs-volume-hal_missing-audio-cds-for-volman.bin \
+ http://bugzilla.xfce.org/attachment.cgi?id=1452
+)
+
+build() {
+ cd ${startdir}/src/Thunar-${pkgver}
+ patch -Np0 -i ../thunar-vfs-volume-hal_missing-audio-cds-for-volman.bin || return 1
+ patch -Np0 -i ../attachment.cgi?id=1452 || return 1
+ ./configure --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib/xfce4 \
+ --localstatedir=/var --disable-static \
+ --disable-gnome-thumbnailers --enable-exif --enable-pcre --disable-fam
+ make || return 1
+ make DESTDIR=${startdir}/pkg install
+ sed -i 's:x-directory/gnome-default-handler;::' ${startdir}/pkg/usr/share/applications/Thunar-folder-handler.desktop
+}